We help IT Professionals succeed at work.

I already have a phone alarm that forces headset but I want ringtone or messages to wake me.

rgb192
rgb192 asked
on
123 Views
Last Modified: 2018-11-26
android 7
Model number
SM-G920P

I already have a phone alarm that forces headset but I want ringtone or messages to wake me.
sounds & vibration

sound mode
default

but I hear from phone even when I have headset

I only want to wake myself

I dont want others to hear incoming messages
I only want to hear on my headset when I am sleeping
to wake me up (but not other people)


more than a notification setting
because these deals with sound
Comment
Watch Question

Scott FellDeveloper
CERTIFIED EXPERT
Fellow
Most Valuable Expert 2013
Commented:
This problem has been solved!
(Unlock this solution with a 7-day Free Trial)
UNLOCK SOLUTION
Martin NguyenMember Experience manager
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
Hi rgb192,

To piggyback on Scott's question, if you want to have all sounds go to your headset when its plugged in, and not come out of your phone's speakers on your Galaxy S6, I was able to find an app that will let you do that. It is called SoundAbout https://play.google.com/store/apps/details?id=com.woodslink.android.wiredheadphoneroutingfix. It does  say some types of audio outputs are available if you purchase a key to unlock the Pro version.

Hope this helps,
Martin Nguyen

Author

Commented:
only want the sound to go through the headset and not the speaker
sound about free does not stop ringing noises from going through speaker. (or I dont know preferences. Many choices in soud about)
Martin NguyenMember Experience manager
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
In SoundAbout there should be a group of settings called Alert Behavior, and from there you should be able to have them go to headphones only. If that doesn't work, or if its a locked feature only for the Pro version I found another app that may help you.

Make sure you uninstall SoundAbout and your device is working properly before installing a new app that would change your sound settings.

https://play.google.com/store/apps/details?id=com.nordskog.LesserAudioSwitch&hl=en is the other app I found, that will mute your phone speakers and re-route the audio to your headphones.

Hope this helps,
Martin

Author

Commented:
5 options in "alert behavior"
but all screens are greyed out so no choices when I click on options
Martin NguyenMember Experience manager
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
Hi rgb192,
Sounds like those options are reserved for the Pro version of SoundAbout. Sorry I can't be more help in finding a solution. It seems Google has notification and call sounds come out of the phone speakers even when headphones are plugged in as a feature, and there are not many workarounds available for that.

Regards,
Martin

Author

Commented:
It seems Google has notification and call sounds come out of the phone speakers even when headphones are plugged in as a feature, and there are not many workarounds available for that.
so premium soundabout would work?
Martin NguyenMember Experience manager
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
Hi rgb192,

Yes that app should work for your specific phone and version of Android. Be sure to restart your phone after installing it. If you upgrade phones and/or to a newer version of Android, it may not work anymore.

Regards,
Martin

Author

Commented:
what menu do I do now that I have paid version
Martin NguyenMember Experience manager
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
Hi rgb192,

You should be able to find this under the SoundAbout settings:
Notification:
1) Press "Alert behavior"
2) Press "Wired Headset behavior"
3) Press "Notifications To".  Change to "Headset only (override)" OR "Current Phone setting (Headset only)"

Ringer:
1) Press "Alert behavior"
2) Press "Wired Headset behavior"
3) Press "Ringtones To".  Change to "Headset only (override)" OR "Current Phone setting (Headset only)"

Please update if it works or does not,
Martin

Author

Commented:
Notification:
1) Press "Alert behavior"
2) Press "Wired Headset behavior"
3) Press "Notifications To".  Change to Current Phone setting (Headset only)"

Ringer:
1) Press "Alert behavior"
2) Press "Wired Headset behavior"
3) Press "Ringtones To".  Change to Current Phone setting (Headset only)"

I now hear ringtone in only headset but sms is silent in both speaker and headset
Martin NguyenMember Experience manager
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
I'll look into if there's a different setting for SMS, but I would think that would fall under Notifications.

Glad its mostly working so far.
Member Experience manager
CERTIFIED EXPERT
Distinguished Expert 2018
Commented:
This problem has been solved!
(Unlock this solution with a 7-day Free Trial)
UNLOCK SOLUTION

Author

Commented:
works. thanks
Martin NguyenMember Experience manager
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
Glad to have help you find a solution rgb192!

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions