How to fix my Asus RoG laptop's boot/sleep exit speeds?

My gaming laptop, an Asus G551JM is having some weird boot issues.

It used to have a hybrid drive, and after the drive broke I bought a new Kingston UV500 960GB SSD for it.
After installing Windows 10 on it I quickly noticed that the boot times were... odd.

Sometimes a boot lasts 2 minutes, sometimes around 40 seconds.
I ran a boot cycle test with Windows Performance Recorder.
The pre-session init phase seems to take around 30 seconds, the rest very little.
It just feels like something is stalling... and once it times out the computer then boots really fast.

https://imgur.com/EWE53EU

I'm new to the program, so I admittedly don't really understand them well.
Perhaps some of you are familiar with them?

This is my personal computer, so I feel it's fine for me to share the log files:
https://files.fm/u/nt4cjcau

I've also ran a few disk check programs and all of them have reported that the disk is in excellent condition.
It moves files fast and seems to work great in actual use.

Also, oddly, the computer would restart whenever it was trying to recover from sleep mode... but I kind of fixed it.
I read that some Asus laptops with sleep mode issues start working if you re-flash them with the same BIOS it already has, using WinFlash.
I gave it a shot! ...and now instead of rebooting from sleep mode, it actually recovers. ...very slowly (1 min 30 sec or so)
(Re-flashed from the already newest version... I have NO idea why that changed anything!)

I've also read that Asus laptops sometimes have issues with the Intel Management Engine Interface, so I've tried fiddling with it.
I've tried to disable it from device manager. Tried an older version. Doesn't seem to do much in my case.
Dunno if it's doing something in my case.

I'm handier with computers than the average person, but I'm not a professional.
I feel like this is way out of my skill level.

I would be most grateful for any help that you can offer!
Sami KoskinenAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Nolan MasonIT ProfessionalCommented:
Any chance that the slow boots are due to it trying and failing to boot to a USB device, such as a flash drive or external hard drive?  I've definitely seen problems like this when a USB drive is plugged into a computer during boot-up.  I've corrected it by either unplugging the device or setting the machine not to boot to USB drives in the BIOS.
0
Sami KoskinenAuthor Commented:
Ah yes, my laptop has an USB headset and an USB mouse.
I've tried unplugging both before, then using the integrated trackpad to restart the computer.
Didn't seem to change anything.

Thanks for the suggestion, though!
My mouse has on-board memory and it crossed my mind that maybe something would go wrong trying to access it or something.
0
Nolan MasonIT ProfessionalCommented:
You say you installed Windows 10.  Was this an upgrade or a fresh install?  I assume fresh install since it was a new SSD, but worth asking.

Did you reset the BIOS to defaults after reflashing?
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Sami KoskinenAuthor Commented:
Yeah, it was an unformatted SSD, fresh off the box.
I used an USB memory stick to install Windows 10 on it. (and thus format it)
I downloaded it from the official Microsoft site.
Since my previous drive had a legit version of Windows 10, this one didn't need a new key.
(So it's not a pirated one)

I did reset the BIOS to default settings after reflashing.
I tried default settings before reflashing, too, though.

The BIOS has a Fast Boot option, plus some security settings and CMS.
I had to change the settings to make it boot from an USB, and I reset them to defaults afterwards.


Edit: I dunno if this is relevant, but for a while after the install I saw a "phantom drive" in the partition manager.
I assume that was just from me using an USB to install the OS. It disappeared afterwards.
0
Nolan MasonIT ProfessionalCommented:
Just for good measure, check what happens if you disable every type of boot device in the in the BIOS' boot priority order except the hard drive (eg. optical drive, floppy, usb, network).
0
Sami KoskinenAuthor Commented:
My only (listed) boot option is "Windows Boot Manager".
I do have a DVD drive, but it's not listed as a boot option.

For good measure I just tried setting everything in I/O to locked and booting.
(So, I locked camera, all usb ports, HD audio, etc etc.)
Didn't fix anything.
After that, I reset the BIOS settings, booted, then typed this reply!
0
Nolan MasonIT ProfessionalCommented:
Is the Intel chipset software definitely installed?

https://downloadcenter.intel.com/download/20775/Intel-Chipset-Device-Software-INF-Update-Utility-?product=1145

I know these are extremely basic suggestions, but, at the moment, I can't think of anything beyond the basics that causes this sort of issue.
0
Sami KoskinenAuthor Commented:
Pretty sure they are, but I tried running that anyway!
I then restarted the computer, checked windows update and yeah, no new updates, seems like.

6.9.2017, ver 14.8.18.1066
0
nobusCommented:
you said "It used to have a hybrid drive, "  but you did not tell us which one
i see in the specs there are models with an 8GB SSD and normal HDD, so if you had that, it 's probably related to your problem
anyhow, i would contact Asus with this problem, they have helped me often : https://www.asus.com/ca-en/Laptops/ROG-G551JM/HelpDesk/
--scroll down on that page for contact options
0
Sami KoskinenAuthor Commented:
The old one was a hybrid drive with 128GB SSD and 1T HDD in one.
The SSD part of it eventually broke, after years of use.
At first I thought that the partition tables were messed up, but no partition repair program was able to find any trace of it.
The model of the old one is HTS541010A9E680, but oddly you'll find drives with different specs with that on Google.

Anyway, thank you for your time!
If anyone here finds a solution, cool! If not, I guess I'll have to manage.

I'm glad to hear that Asus has good tech support. I'll give it a try.
0
McKnifeCommented:
To me it sounds as though you had and still have two drives in it, one of them about to fail causing large detection timeouts. As your reported old HTS541010A9E680 is no hybrid drive, you might simply have taken it for one and the ssd part was, and most probably still is, onboard, as in and PCIe SSD drive (.m2/nvme).

Please consult your bios what drives it sees and show that to us.
0
Sami KoskinenAuthor Commented:
What an interesting thought!
I did wonder about the weird SATA listing, but didn't think too much of it.
So you think that the empty slot 5 could be a faulty internal SSD?
(Btw, is it weird to not have a 1 and a 3?)

Edit: Oh, or it might have something to do with the SSD cache thing.
I dunno how exactly those work, so maybe that's it? Hmm.

 IMG_20181007_111019.jpg

The boot list is... short.
IMG_20181007_111258.jpg
0
McKnifeCommented:
I am still not convinced as to whether there is a 2nd disk or not.
Please open an elevated command line and launch these tow commands:
diskpart
list disk

Open in new window

then share the output.
0
Sami KoskinenAuthor Commented:
DISKPART> list disk

  Disk ###  Status         Size     Free     Dyn  Gpt
  --------  -------------  -------  -------  ---  ---
  Disk 0    Online          894 GB    97 GB        *

That only shows one.

...weird, it says 97GB free.
In reality I have 50GB free out of 93,6GB on C:, 608GB free out of 702GB on D: and 97,66GB unpartitioned.
0
McKnifeCommented:
Ok. Then I suspect this is a hardware problem, not disk related.
Please use knoppix or some other Linux live OS and test with it. Even better: backup windows and install Ubuntu on it for testing.
0
McKnifeCommented:
Another thing: can you find out, what storage constellation you bought?
Asus lists the following possible configs:
--
- 750GB HDD 5400 RPM
- 750GB HDD 7200 RPM
- 1TB HDD 5400 RPM
- 1TB HDD 7200 RPM
- 1.5TB HDD 5400 RPM
- 750GB 5400 RPM With 8 G SSD SSH
- 1TB 5400 RPM With 8 G SSD SSH
- 256GB SSD
--
0
Sami KoskinenAuthor Commented:
I took the full model code off the box it came in and put it in Google.

https://www.proshop.se/Baerbar/ASUS-ROG-G551JM-CN247H-156-Core-i7-4710/2471911

I couldn't find an English language site for it!

Core i7 4710HQ / 2.5 GHz
Windows 8.1 64-bit
16 GB RAM, 128 GB SSD + 1 TB HDD
DVD SuperMulti, 15.6" 1920 x 1080 ( Full HD ), NVIDIA GeForce GTX 860M

Mine only came with 8GB RAM originally, and a different DVD drive.
Definitely the same model, however, and I'm pretty sure I had a 128GB SSD.
I always juggled a little to fit stuff on it!

It's funny, I first thought that it would have had a separate HDD and SSD.
Once I first opened it up (to install RAM, I think) I went "Oh! There's only one drive? A hybrid? I guess that's a thing."
And now, it seems, I learn that it had an internal SSD and a separate HDD.


I feel really silly now.
But this is why I came here, I had no idea what was going on.
I focused so much on staring at test logs and testing device drivers, never checked my actual hardware properly.

I think you solved this mystery!

Just in case I'm going to test Linux as you suggested, but yeah I now fully expect it to boot slow as well.
Will update.
0
McKnifeCommented:
Read about where to find that second drive and remove it. Maybe it is half-dead causing this.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Sami KoskinenAuthor Commented:
Yep, I didn't even need to install the Linux, it was running snappy even from USB.
Then I tried sleep mode and... well it took AGES and left some black glitchy gunk on the screen.

So the bad news is my laptop has a bad internal part.
The good news is I (probably) have a perfectly good SSD (new) and a good HDD (old).

Thank you very much to all of you. There's no way I would have figured this out on my own!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Boot issue

From novice to tech pro — start learning today.