ORA-27044 while moving .dbf file path

Hi Experts

Trying to move .dbf file but getting ORA-27044 cannot write header of file

SQL> ALTER DATABASE MOVE DATAFILE 'C:\APP\<DBFOLDER>\ORADATA\ORCL\USERS01.DBF' TO '
C:\temp\USERS01.DBF';

データベース・ファイル'C:\TEMP\USERS01.DBF'の作成中にエラーが発生しました。
ORA-27044: ファイルのヘッダー・ブロックを書き込めません。
OSD-04008: WriteFile()????s????????B?t?@?C???????????????????S-Error:

One instance on expert exchange says it is because of bug and suggestion was to add "control_file_record_keep_time=0" in init.ora. Done that and restarted instance but same result. My Oracle version is 12.1.0.2.0.
Any suggestion please?
Chandan PratihastAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

slightwv (䄆 Netminder) Commented:
That post on here was from 2001 and from Oracle version 8.  You need to be careful when trying random stuff on the Internet.

I see some references to these errors being caused by there not being enough free space to perform the copy.

Make sure you have enough space.

Why are you wanting to copy the datafile to TEMP?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Chandan PratihastAuthor Commented:
Hi

On my laptop the main drive storage space is mostly used. And at times I need to import DB data from different test environment. So trying to store all major datafiles on a separate USB or Micro SSD storage.

In the process tried to move it first to a local directory.
It was failing. Today try with 32GB micro sd card.

Thanks.
0
Chandan PratihastAuthor Commented:
The filesystem of SD Card was FAT32. Formatted it to NTFS.

The main point was that the file size was 24GB which was more than the target available space.

Thanks for the help to resolve it.
0
Chandan PratihastAuthor Commented:
The file system on the SSD storage was FAT32 and I formatted it to NTFS and then was able to move the file.

Your point was correct my data size was 24GB and the target space was less than that.

Thanks for helping to resolve it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.