Link to home
Start Free TrialLog in
Avatar of Goutham
GouthamFlag for India

asked on

connection is established but packets are not flowing

Dear Experts

CRM system work flow triggers emails to the prospect email account as and when the prospect statues changes via the SMTP server ( without password that is without authentication as it is Relay server hosted locally-office 365 mail protection ). We could see the connection to the email server getting established but no packets sent/received , but through telnet we can send and receive mails by making use of from and to email commands through the telnet session, can you help where the things are going wrong. following SL2 cases it works but SL3 it does not work.
1. though telnet to the smtp server with FROM and TO commands it works that is mail is delivered to the TO addressed account.
2. though CRM system configure email settings with email account, smtp and port without the SMTP authentication mail is getting delivered to the To account.
3. CRM system through workflow trigger email on each status changes mail is not getting delivered instead we can see connection is ESTABLISHED to the smtp server
Avatar of noci
noci

TCPDUMP from a session (tshark from wireshark is also useful).
SOLUTION
Avatar of David Favor
David Favor
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Goutham

ASKER

thanks for the reply, it is windows 2012 R2 server will the tshark and SWAKS work for windows 2012 R2.
Avatar of Goutham

ASKER

by running tshark and SWAKS can we capture and store the log file for later review.
2. connection is getting established but no packet flow what would be the issue, please suggest me possible cases.
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Goutham

ASKER

using offfice 365 SMTP relay to send mails to the external users though the CRM application, i,e option 3 in the following URL
https://support.office.com/en-us/article/how-to-set-up-a-multifunction-device-or-application-to-send-email-using-office-365-69f58e99-c550-4274-ad18-c805d654b4c4
Important observation
1. we observed the  CRM system workflow triggers emails when port 80 opened for the CRM system at the gateway/firewall level, the CRM system gets connected to internet to  crl.globalsign.com  and from the it connects to office365 smtp.
2. when we disable access to external network i,e port 80 http blocked for CRM system at gateway/firewall then emails does not flow ,
3. we only allowed CRM system can talk to crl.globalsign.com  then emails are getting triggered.
can you please help me understand how this office365 is working when it is configured to the CRM system. is it essential that CRM system to be allowed to talk to crl.globalsign.com . please suggest.