Why is Import and export greyed out in SQL Express

Hi,
I've just installed Microsoft SQL Express as well as Server Management Studio and Visual Studio.
However when I open the Management Studio and connect and create a database it displays it with a black lock icon.
Is this normal ?
My question is:  Why, when I right click on the selected database and click tasks why are both Import and Export options greyed out. ?
Thanks for your help
Ian
Ian BellretiredAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kyle AbrahamsSenior .Net DeveloperCommented:
IS the wizard installed on your computer?
https://docs.microsoft.com/en-us/sql/integration-services/import-export-data/start-the-sql-server-import-and-export-wizard?view=sql-server-2017

Also note if it's not available in SQL express directly you may be able to download the stand alone SSMS and connect to sql express that way.  Try that and see if the import / export is still greyed out.
0
Ian BellretiredAuthor Commented:
It shows the wizard is available for importing flat file so I'm guessing it would be available for ordinary import and export. Please correct me if you think I'm wrong here.
0
Kyle AbrahamsSenior .Net DeveloperCommented:
It might not be.  What version of SQL Express are you running?

I confirmed that I can run an export data on SQL express with SSMS 17.8.1

It might be the version of SSMS you have or it could be you missed something during the installation of sql express.
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

Ian BellretiredAuthor Commented:
Management Studio Version 18 Preview 4
15.0.18040.0
Do you think I should uninstall and reinstall ?
0
Kyle AbrahamsSenior .Net DeveloperCommented:
0
Ian BellretiredAuthor Commented:
Same one already installed.
I went ahead and uninstalled it and did a reinstall and downloaded accompanying links.
Still same problem.
Have you any details of where I can contact the SQL team ? I need to sort this one way or another
many thanks
Ian
0
Kyle AbrahamsSenior .Net DeveloperCommented:
Try the 17.9 version?  (EG: Not the preview).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ian BellretiredAuthor Commented:
That solved that problem thanks
Now a new problem is error
ace.oledb.16.0 not in local machine
I have downloaded the two Access components from MS
and installed them but still asking to register on local machine
how do I do that ?
0
Ian BellretiredAuthor Commented:
Here are the message details. They are all gobbledegook to my eyes

The 'Microsoft.ACE.OLEDB.16.0' provider is not registered on the local machine. (System.Data)

------------------------------
Program Location:

   at System.Data.OleDb.OleDbServicesWrapper.GetDataSource(OleDbConnectionString constr, DataSourceWrapper& datasrcWrapper)
   at System.Data.OleDb.OleDbConnectionInternal..ctor(OleDbConnectionString constr, OleDbConnection connection)
   at System.Data.OleDb.OleDbConnectionFactory.CreateConnection(DbConnectionOptions options, DbConnectionPoolKey poolKey, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningObject)
   at System.Data.ProviderBase.DbConnectionFactory.CreateConnection(DbConnectionOptions options, DbConnectionPoolKey poolKey, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection, DbConnectionOptions userOptions)
   at System.Data.ProviderBase.DbConnectionFactory.CreateNonPooledConnection(DbConnection owningConnection, DbConnectionPoolGroup poolGroup, DbConnectionOptions userOptions)
   at System.Data.ProviderBase.DbConnectionFactory.TryGetConnection(DbConnection owningConnection, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal oldConnection, DbConnectionInternal& connection)
   at System.Data.ProviderBase.DbConnectionInternal.TryOpenConnectionInternal(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
   at System.Data.ProviderBase.DbConnectionClosed.TryOpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
   at System.Data.ProviderBase.DbConnectionInternal.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
   at System.Data.OleDb.OleDbConnection.Open()
   at Microsoft.SqlServer.Dts.DtsWizard.DTSWizard.GetOpenedConnection(WizardInputs wizardInputs, String connEntryName)
   at Microsoft.SqlServer.Dts.DtsWizard.Step1.OnLeavePage(LeavePageEventArgs e)
0
Ian BellretiredAuthor Commented:
I've now installed the 17.8.1 version and again the same error message  Microsoft ACE.OLEDB.12.0 is not registered on the local machine. (System.Data)
As you can see this version mentions the OLDB 12.0 whilst the 17.9 version was 16.0
If I can't sort it this time I will have to give up and grow mushrooms. :)
0
Ian BellretiredAuthor Commented:
Thanks Kyle the version you suggested solved the greyed out problem.
I will start a new question re above problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SQL

From novice to tech pro — start learning today.