Windows Authentication in Chrome

greenshoots
greenshoots used Ask the Experts™
on
Windows Authentication in Chrome does not works as expected from AD/Domain environment.

It works perfect in Firefox after adding the http://app.domain.local to network.automatic-ntlm-auth.trusted-uris

It works also good in Edge and Internet Explorer after adding the URL in Local Intranet - Sites.

I expect it to work in Chrome too. But I am always being promted. Any ideas?

I have tried with or without Negotiate security method for Windows Authentification. I am currently using only NTLM.

Chrome version 69.0.3497.100 64 bit.
IIS 8 and MVC (Webform) (newer version) ASP.Net app
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Solutions Architect
Top Expert 2016
Commented:
If you have overridden the AuthNegotiateDelegateWhitelist or the AuthServerWhitelist policy settings in your environment, ensure that you add the URL in there.

https://www.chromium.org/administrators/policy-list-3#AuthNegotiateDelegateWhitelist
https://www.chromium.org/administrators/policy-list-3#AuthServerWhitelist

Author

Commented:
Thank you Jian. We had an GPO that set those values. (AuthNegotiateDelegateWhitelist and AuthServerWhitelist). I have added my app to the GPO now. I now wait for the GPO to sync.

Author

Commented:
That worked really well. Thank you very much.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial