How do I get SCCM to silent hit OK on a prompt dialogue box?

I am working with app packaging in SCCM 2012R2 and have an application installer (.exe) that while running launches a second .exe (Sentinel Runtime) to install. At the end of the second one installing, there is a prompt to hit OK. The application install won't go past this point if you don't hit OK. So in SCCM, it will run until it times out then the installation will fail. I haven't been able to get it to move beyond this point no matter what switches I use. It would be great to get some help with this. I am running the installation again to get some fresh logs as I am sure someone will want to know. Below is the string I am using in the installation line.

".\tnxTower8040_Setup.exe" /S /v"/qn " /norestart

I've tried many variations of the same command, but have had no luck. I've also reached out to their support and they were unhelpful as well. So now I am reaching out to the experts!

Thanks in advance!!
Curtis W. SmithIT Support AnalystAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Adam LeinssServer SpecialistCommented:
Given those command line options, I'm guessing that is an Installshield wrapper for a MSI file.  Try opening the EXE file with 7zip and see if there is a MSI file you can extract.  Otherwise, you can start the install, then go to Run>Start, type in %TEMP% and look for any recent folders and within them MSI files.
0
Leon TaljaardSystem Center Specialist - ArchitectureCommented:
Hi Curtis,

Have a look at this link from some time back and comments from Garth Jones. You would need to either see if you can extract it as mentioned by Adam and see if there is a way for to then run the extracted files/installer or as mentioned in this link below.


How to use SCCM to push a custom setup EXE that prompts "Yes or No"
0
Curtis W. SmithIT Support AnalystAuthor Commented:
Adam,
Thanks for the response. I was suspicious that the scenario you mentioned was the case which is why I added the /v" qn " Portion to the string. The one in the documentation doesn't have that as a part of it. I've also tried /SILENT /VERYSILENT and /SUPPRESSMSGBOXES which had no luck.

I tried opening the .exe and extracting the .msi from the inside. the problem is that the .msi won't run on it's own, and I've searched all through the folders to find the second installer and see if I can install it separately as a prerequisite, but i can't find it. Inside there is an .msi that won't run on it's own and another exe that just launches the same installer I see when I run it normally.

So I'm beginning to wonder if it is possible with this installer. Previous versions worked fine with the normal switches I have in my original post, but so far this one will make everything silent but that one box.

Leon,
I appreciate the help. The link just took me to another link which took me to ITNinja, which is fine ( I will do some searching there) but nothing specific. Do you have any idea where the original link took? We have Admin Studio, but I haven't had a ton of experience with it and so far everything I package with it doesn't install correctly.

Thanks all for the help so far!
0
Starting with Angular 5

Learn the essential features and functions of the popular JavaScript framework for building mobile, desktop and web applications.

Adam LeinssServer SpecialistCommented:
I did a Google search on the EXE you gave and found a download here, so I downloaded that: http://www.towernx.com/support/updates/tnxtower/download_current_tnxtower.html.

You are right the MSI does nothing when ran by itself.

I used strings from Sysinternals on the EXE and found this:

/silent

I ran the EXE with /silent and saw it's actually InstallAware, not Installshield and /silent did not work.

I did a Google search and found this:

https://www.installaware.com/flashhelp/setupcommandlineparameters.htm

Tried with /s and that seemed to work, except I got the OK prompt on sentinel run-time environment.

So it's not really the installer that is the problem, but the embedded package that installs the HASP drivers.

One thing you could try is to install the HASP drivers ahead of time using the command line options here:

http://sentineldiscussion.gemalto.com/topic/hasp-hl-iis-there-a-silent-or-unattended-install-method-available-for-the-driver-of-this-dongle

When I extracted the EXE install, haspdinst.exe was in \data\OFFLINE\837B07DE\8FE7F849.

Looking at the strings results of the setup EXE, it looks like they are using this command to install the HASP drivers:

haspdinst.exe -i -kp -fss

Which would explain why you are getting the pop up box, because they are not using -nomsg switch.

You are really at their mercy in fixing the installer.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Curtis W. SmithIT Support AnalystAuthor Commented:
Adam,
That is the exact thought I had. I was actually just about to post that I tried installing the hasp driver prior to the installation and it still runs the Hasp installer during the installation anyways. I was beginning to fear that it was up to them to fix it. I might try and package it in Admin Studio and just see.  
I appreciate your help with this! I will update later if I find out something else, or if they can fix the installer.
0
Adam LeinssServer SpecialistCommented:
Only other thing I can think of is you could write a loop that keeps checking for the HASP drivers on the C: drive, then do a task kill on the HASP install once they exist (give maybe a 5 second delay) and see if the install will complete and work properly.  Complete hack of course if it does work.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Installation

From novice to tech pro — start learning today.