Cluster Preferred Owners automatically changed to "Anynode" after reboot

I had setup Preferred Owners to User setting. At General tab, i had selected a specific node and tick the node.

After rebooted, the "Preferred Owners" setting Changed to "Any Node"

How to permanently set this as User setting.
Doodad BoySupprtAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Raja Jegan RSQL Server DBA & Architect, EE Solution GuideCommented:
Just wondering whether you have configured the Preferred owner and set the Order of the Preferred owner by moving UP/DOWN the nodes available.
Shared a link with attachment showing how to move UP/DOWN the owner which will help achieve your requirement..
https://www.techveze.com/preferred-owner-and-failover-settings/

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Doodad BoySupprtAuthor Commented:
Hi Raja,

Yep, the preferred owner node has been selected and moved to UP.

But when ever the server been rebooted, the setting changed to "Any Node", and found both node are tick.
Raja Jegan RSQL Server DBA & Architect, EE Solution GuideCommented:
>> But when ever the server been rebooted, the setting changed to "Any Node", and found both node are tick.

Both nodes ticked shouldn't be a problem, if the order is retained, then it should be sufficient as the 1st in the order will be the preferred node at any point in time..
Doodad BoySupprtAuthor Commented:
Hi Raja,

After the preferred node is back Online, the role does not moving back to the preferred node.

Please advise further how to fix this.
Raja Jegan RSQL Server DBA & Architect, EE Solution GuideCommented:
Sorry, not sure how I missed your response..
Okay, to explain more there are 2 scenarios:
1. Automatic - It will go to the next node in sequence and not the first preferred node.
2. Manual - It will go to the first node in preferred sequence.

For the explanation, you can check the scenarios 1 and 3 in the link below..
https://support.microsoft.com/en-us/help/299631/failover-behavior-on-clusters-of-three-or-more-nodes

Kindly let me know for more details..
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.