Can't hear audio in web training app using IE v11, turned off by default

Hello EE,

Our company has an online training video (powered through Cornerstone) that is unable to play sound when first loaded.  The sound icon embedded in the video is turned off by default.  We have to manually turn the icon on and then the sound works.  If closing the browser and reopening the training video, the sound is once again turned off. This seems to randomly be occurring on different machines, including my own.  

I've tested several other test machines, and the sound is enabled from the beginning and works without problem.

This only occurs in Internet Explorer v11, our company's default browser.  It works fine on Chrome and Firefox.

I've tried different Dell laptop models and Windows OS (7, 1607, 1709) versions, can't find a pattern.

I've tried the following so far:

a.      Added website to compatibility view, no change.
b.      Deleted all browsing history, no change.
c.      Reset IE settings/Deleted personal settings, no change.
d.      Website domain is added as a Trusted Site in IE.
e.      Checked the following registry key…HKCU\Software\Microsoft\Internet Explorer\Main; PlaySounds was set to 0, I set it to 1, no change.
f.      I imported the Main registry keys from a PC where the audio works, onto my PC, no change.
g.      IE > Tools > Active X Filtering is turned off.
h.    Uninstalled audio driver, tried both generic and model specific drivers.
i.     Deleted Flash player browsing data and settings.
j.     Ran IE v11 with all add-ins disabled.

Not sure where else to look.  Thoughts?

Thanks!
ctme2000Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Drop a comment about video formats.

For example, V11 is know for auto-muting flash videos. A bit of simple Javascript fixes this. Google for the answer, if you're running flash.

If your serving *.mp4 containers then then audio should not reset to disabled... well, unless you're using a flash based player.

Best to just post a link to one of your video pages + likely someone can debug the problem + provide a solution.

Tough to guess. Likely easy to look at a real page + provide a solution.
ctme2000Author Commented:
@ David, the video is Flash based.  Can't post a link, as it requires a login to the site itself in order to watch the video.  I ran a debug on the video and as far as I can tell both sets of code are identical between the working and non-working versions.

I did notice there was a difference in IE11 versions.  The one it works on is 11.2189.14393.0CO, whereas the one it does not work on is 11.371.16299.0CO.

I was looking around for Windows updates to see if there is a way to downgrade/upgrade to those builds, to test.  Don't see any specific updates or offline installers available for Windows 10 though.  Does such a thing even exist?
ctme2000Author Commented:
Hi All,

Just wanted to reach out again, and see if there is anything I can look at?

Thanks,
ctme2000Author Commented:
As an update..

I spoke with the MS engineer and he mentioned it seems the code for the video is set to be disabled for tablets and enabled for desktops.  The newer laptops do have touchscreens available, and we were wondering if this then considers a touch-screen enabled laptop as a 'tablet' and so disables the sound toggle by default.  I tested several different laptops, and all of the touch-screen ones had the setting disabled, whereas the non-touch screen laptops had the audio toggle enabled by default.

I went through Device Manager and disabled/uninstalled the 'HID compliant touch screen'; no change.  I also went through and disabled several different 'touch' related registry entries (hkcu and hklm\wisp\touch), by setting them to 0; no change.

I checked the BIOS as well, and do not see any touch-screen related settings there.

Are there any other touch-related settings I should be aware of that can be disabled?

Thanks,
ctme2000Author Commented:
I have posted a new question in regards to the touch-screen issue, and will resolve this one.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Internet Explorer (IE)

From novice to tech pro — start learning today.