brake point never hit

Hi, I like to use  a brake point for debug.  Never had a problem with it until I started to work on VS 2017 (Professional ).
Now no matter where I put a brake point it is never hit.
Do you have any idea how to fix this?
LVL 1
mastiSoftAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AndyAinscowFreelance programmer / ConsultantCommented:
Are you actually running the code you have in the editor.  Maybe the time stamps have got corrupted somehow.

You could try performing a rebuild all and seeing if that helps.
Chris StanyonWebDevCommented:
Clean the solution, rebuild the solution and make sure you have the Debug configuration selected. If you have Release selected, you won't hit the breakpoints.
Ryan ChongSoftware Team LeadCommented:
Now no matter where I put a brake point it is never hit.

try do a step debugging (F11) and see if it hits that break point?
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

mastiSoftAuthor Commented:
I have Active(Debug) configuration and using F11 didn't make any difference.
Chinmay PatelChief Technology NinjaCommented:
1. It sounds like a hack but please clear all existing break points and then add a new one and see if it works. This worked for me in one of the app - I never encountered it afterwards so I am not sure.
2. Take a screen shot of Tools -> Options -> Debugging -> General and post it here.
3. What value do you see in Project Properties -> Advanced -> Debugging?
AndyAinscowFreelance programmer / ConsultantCommented:
Did you do a complete rebuild as I suggested.  (That is nothing to do with the F11 key).
mastiSoftAuthor Commented:
Yes I complete rebuild as you suggested Andy, but still nothing happens.
mastiSoftAuthor Commented:
Hi Chinmay.
Please find attached here screen shots of Options and Project Properties. I hope you find something.
Options.PNG
ProjectPropert.PNG
ProjectPropert2.PNG
Chinmay PatelChief Technology NinjaCommented:
Please uncheck Optimize Code flag. It will optimize the code and that will rid of the debugging data from the generated executable i.e. No Debugging.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mastiSoftAuthor Commented:
Thank you Mr. Chinmay ). You always help me.
Chinmay PatelChief Technology NinjaCommented:
Glad I could help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
WPF

From novice to tech pro — start learning today.