USB Port not recognizing printer

Hi, we have a newish Dell laptop with Windows 10 on it. Yesterday I plugged in a USB switch. One side went to the Dell laptop, the other to my HP laptop, and the output of the switch to the printer (A Brother MFC-7340).

Perfect! Moved the switch from one laptop to the other, both print.

today... The dell laptop won't print, Brother printer is offline. Switch to HP laptop, works perfectly. Reboot Dell, nothing. Replug the USB, get an error not recognizing device. Try plugging directly into printer, same thing.

Plugin the old inkjet printer, doesn't recognize that either. Reboot the Dell laptop, and get a critical error screen. Took it into the repair place, he's able to get it back.

1. Plug in the Brother printer, reboot, not there.
2. Go to device manager, uninstall device, reboot, not there. Same unrecognized device issue.
3. Switch to other laptop, prints fine.

Any ideas? What could be the problem? Thanks. Meanwhile we have the dell plugged into the inkjet printer, Same USB port, and it's working as well as it ever works. Meaning the USB port is working, the inkjet printer's a piece of junk.
Melody ScottAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Darrell PorterEnterprise Business Process ArchitectCommented:
If, once you get the Dell printing to the POS inkjet printer, try disconnecting the inkjet using the Eject feature (safely remove...), wait 60 seconds and connect just the new Brother printer.
Does it recognise it?
Is the USB A/B switch a mechanical switch or an intelligent USB switch?
Perhaps configure the built-in Wireless network adapter to share it instead of dealing with USB cables and switches?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Melody ScottAuthor Commented:
Thanks, Darrell, I don't know if I even realized it had a wireless feature. :) Let me try that first, and see what happens. It is an actual USB switch, and seems to work well on my end, but it's old.
Melody ScottAuthor Commented:
Hi, I went here: https://support.brother.com/g/b/faqend.aspx?c=as_ot&lang=en&prod=mfc1910w_eu_as&faqid=faq00100109_004 and because I don't have the Cd-ROM, I downloaded the Full Driver & Software Package.

But it suggests that I'll see a window offering Choose Wireless Network Connection, but it just goes through the normal screens you see on software installation.

It's installed, but I can't seem to see any program I can open except the control center, which has no options to connect wirelessly.  Just wondered if anyone had any suggestions?
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

Melody ScottAuthor Commented:
I just realized it doesn't have an ethernet port, so likely doesn't have a wireless adapter.
web_trackerComputer Service TechnicianCommented:
Use an application called USB oblivion  https://www.majorgeeks.com/files/details/usb_oblivion.html , this tool cleans up remnants of drivers found in the registry that are associated with each usb port for devices no longer plugged into that port.  Clearing this info may help the Dell laptop to associate the correct drivers fro the printer.
William FulksSystems Analyst & WebmasterCommented:
Have you tried swapping the USB cable? Sometimes when they start acting crazy like that it's from a bad cable.
nobusCommented:
no errors in device manager?
look also in event viewer what it says about it
Melody ScottAuthor Commented:
Hi, all! Ok... USB cable is brand new, but I did try swapping it. Last night I turned the laptop off, plugged the USB cable directly into the printer and the laptop, and turned the laptop back on. I got the 'windows blocked the installation of a digitally unsigned driver' error.

I'll check to see there are no errors n the device manager (there were before the laptop failed completely), and check the event viewer (Never thought of that!), and then follow instructions here: https://ph.answers.acer.com/app/answers/detail/a_id/38288/~/windows-10%3A-disable-signed-driver-enforcement

If that doesn't work, I'll try the oblivion tool. Thanks for all the advice!
Melody ScottAuthor Commented:
ok, once I had unplugged the other printer and restarted with the USB plugged directly into the printer, that's what finall showed me the error I could clear. Printer's working. Thanks!
nobusCommented:
what was the error then?
Melody ScottAuthor Commented:
windows blocked the installation of a digitally unsigned driver. I solved it by doing this:  https://ph.answers.acer.com/app/answers/detail/a_id/38288/~/windows-10%3A-disable-signed-driver-enforcement
nobusCommented:
tx for the update !
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.