CHI-LTD
asked on
Routing multiple vlans across multiple switches.
Hi
I had issues routing voice traffic across two same make/model switches, one as a core and the other as edge. Managed to resolve this by tagging ports in the respective vlans on the switches, simple fix but not something im used to.
However we are now trying to get two older HP/3com switches to do the same.
Switch Config overview:
HP1910 switch using default vlan1 across all ports. Connected to:
HP2910 switch vlan1 interface (acts as core and routes to firewall). Connects to:
HP/3com2952 switch vlan1 interface. This will connect to:
A new HP2910 switch. This will in turn re-route back to the HP1910 above to form chain topology rather than current loop. I'm assuming this is good?
I am not using any trunks or LACP.
Part one will be to route the new HP switch back to the 2952, once working ill then connect this back to the 1910.
So far i have created a new vlan20 on the old 2952 and tagged the port thats connected to the new 2910. Here is the config:
[3Com Baseline Switch]display current-configuration
#
version 5.20 Release 1101P10
#
sysname 3Com Baseline Switch
#
super password level 3 simple
#
domain default enable system
#
telnet server enable
#
ip ttl-expires enable
#
vlan 1
#
vlan 20
description Voice
#
radius scheme system
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
password simple
authorization-attribute level 3
service-type lan-access
service-type ssh telnet terminal
service-type ftp
#
stp mode rstp
stp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 172.19.4.3 255.255.0.0
#
interface GigabitEthernet1/0/1
stp edged-port enable
#
interface GigabitEthernet1/0/2
stp edged-port enable
#
interface GigabitEthernet1/0/3
stp edged-port enable
#
interface GigabitEthernet1/0/4
stp edged-port enable
#
interface GigabitEthernet1/0/5
stp edged-port enable
#
interface GigabitEthernet1/0/6
stp edged-port enable
#
interface GigabitEthernet1/0/7
port link-type hybrid
port hybrid vlan 20 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
ip route-static 0.0.0.0 0.0.0.0 172.19.4.5
#
snmp-agent
snmp-agent local-engineid 8000002B0320FDF1066322
snmp-agent community read public
snmp-agent community write private
snmp-agent sys-info contact IT
snmp-agent sys-info location HQ
snmp-agent sys-info version all
#
ntp-service source-interface Vlan-interface1
#
load xml-configuration
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return
[3Com Baseline Switch]
The new HP2910 config is as follows:
Running configuration:
; J9148A Configuration Editor; Created on release #W.15.14.0016
; Ver #06:04.18.63.ff.35.05:b6
hostname "HP2910al-48G-PoE-GroundFl oor"
module 1 type j9148a
power-over-ethernet pre-std-detect ports 1-48
qos type-of-service diff-services
sflow 1 destination 172.19.10.23
sflow 1 sampling 2-48 500
timesync sntp
sntp unicast
sntp server priority 1 87.124.126.49
sntp server priority 2 178.79.165.21
time timezone 60
interface 1
name "to port 7 on HP2952"
exit
snmp-server community "public" unrestricted
snmp-server contact "IT" location "Ground Floor"
vlan 1
name "DEFAULT_VLAN"
no untagged 48
untagged 1-47
ip address 172.19.4.6 255.255.0.0
exit
vlan 20
name "VLAN20"
tagged 1,33-48
ip address 172.16.4.6 255.255.0.0
ip helper-address 172.19.10.30
ip helper-address 172.19.10.31
qos dscp 101110
voice
exit
spanning-tree
no tftp server
no autorun
no dhcp config-file-update
password manager
Why can i not ping devices on vlan20 from vlan1? Default route on the 3com the problem? Do i need an IP address associated to newly created vlan20?
Thanks
Edit: i can ping from the 2952 switch console to hosts on 172.19.4.5 and 172.16.*.* fine but cannot ping the 172.16.4.6 interface at all.
Here's the other two switch configs:
Core:
Running configuration:
; J9148A Configuration Editor; Created on release #W.15.08.0012
; Ver #02:11.05:16
hostname "HP-E2910al-48G-PoE-"
module 1 type j9148a
power-over-ethernet pre-std-detect
qos type-of-service diff-services
sflow 1 destination 172.19.10.23
sflow 1 sampling 1-48 500
timesync sntp
sntp unicast
sntp server priority 1 87.124.126.49
sntp server priority 2 178.79.165.21
time timezone 60
ip authorized-managers 172.19.0.0 255.255.0.0 access manager
ip authorized-managers 172.16.0.0 255.255.0.0 access manager
ip authorized-managers 10.255.255.0 255.255.255.128 access manager
ip authorized-managers 192.168.2.0 255.255.255.0 access manager
ip authorized-managers 192.168.3.0 255.255.255.0 access manager
ip authorized-managers 10.255.254.0 255.255.255.128 access manager
ip authorized-managers 192.168.100.0 255.255.255.0 access manager
ip authorized-managers 192.168.200.0 255.255.255.0 access manager
ip authorized-managers 10.255.253.0 255.255.255.0 access manager
ip default-gateway 172.19.10.15
no ip icmp redirects
ip route 0.0.0.0 0.0.0.0 172.19.10.15
ip routing
interface 1
name "to HP1910 (top)"
no power-over-ethernet
exit
interface 2
name "to 3com (bottom)"
no power-over-ethernet
exit
interface 3
name "to ASA 5505 fe01"
no power-over-ethernet
exit
interface 4
name "Cisco_AP_172.19.3.20"
exit
interface 5
name "to HP2910 Ground Floor (TEST)"
exit
interface 6
no power-over-ethernet
exit
interface 7
name "Shoretel E1k"
speed-duplex 100-full
exit
interface 8
name "Shoretel SG90"
speed-duplex 100-full
exit
interface 9
name "Shoretel SG90Bri"
speed-duplex 100-full
exit
interface 10
name "chi-Oaisys"
exit
interface 11
name "Shoretel HQ"
exit
interface 12
name "Ingate"
exit
interface 16
name "Server Room"
exit
interface 19
name "Test Phone"
exit
interface 21
name ""
exit
interface 22
name "Meeting Room"
exit
interface 25
name ""
exit
interface 31
name ""
exit
interface 35
name ""
exit
interface 37
name "to onenet e0/1"
exit
interface 38
name "to cisco asa e0/0"
exit
interface 39
name "to juniper e0/1"
exit
snmp-server community "public" unrestricted
snmp-server contact "IT" location "HQ"
spanning-tree
vlan 1
name "DEFAULT_VLAN"
no untagged 7-48
untagged 1-6
ip address 172.19.4.5 255.255.0.0
exit
vlan 20
name "Voice"
untagged 7-12,35
tagged 5,13-34,36-48
ip address 172.16.4.5 255.255.0.0
ip helper-address 172.19.10.30
ip helper-address 172.19.10.31
qos dscp 101110
voice
exit
vlan 50
name "vlan50"
untagged 37-39
no ip address
exit
no autorun
password manager
HP1910:
<HP V1910 Switch 2>display current-configuration
#
version 5.20 Release 1111
#
sysname HP V1910 Switch 2
#
clock timezone #Web#0#02 add 00:00:00
#
super password level 3 simple
#
domain default enable system
#
telnet server enable
#
ip ttl-expires enable
#
web idle-timeout 30
#
vlan 1
#
radius scheme system
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
password simple
authorization-attribute level 3
service-type ssh telnet terminal
#
stp mode rstp
stp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 172.19.4.4 255.255.0.0
#
interface GigabitEthernet1/0/1
stp edged-port enable
#
interface GigabitEthernet1/0/2
stp edged-port enable
#
interface GigabitEthernet1/0/3
stp edged-port enable
#
interface GigabitEthernet1/0/4
stp edged-port enable
#
interface GigabitEthernet1/0/5
stp edged-port enable
#
interface GigabitEthernet1/0/6
stp edged-port enable
#
interface GigabitEthernet1/0/7
stp edged-port enable
#
interface GigabitEthernet1/0/8
stp edged-port enable
#
interface GigabitEthernet1/0/9
stp edged-port enable
#
interface GigabitEthernet1/0/10
stp edged-port enable
#
interface GigabitEthernet1/0/11
stp edged-port enable
#
interface GigabitEthernet1/0/12
stp edged-port enable
#
interface GigabitEthernet1/0/13
stp edged-port enable
#
interface GigabitEthernet1/0/14
stp edged-port enable
#
interface GigabitEthernet1/0/15
stp edged-port enable
#
interface GigabitEthernet1/0/16
stp edged-port enable
#
interface GigabitEthernet1/0/17
stp edged-port enable
#
interface GigabitEthernet1/0/18
stp edged-port enable
#
interface GigabitEthernet1/0/19
stp edged-port enable
#
interface GigabitEthernet1/0/20
stp edged-port enable
#
interface GigabitEthernet1/0/21
stp edged-port enable
#
interface GigabitEthernet1/0/22
stp edged-port enable
#
interface GigabitEthernet1/0/23
stp edged-port enable
#
interface GigabitEthernet1/0/24
stp edged-port enable
#
interface GigabitEthernet1/0/25
stp edged-port enable
#
interface GigabitEthernet1/0/26
stp edged-port enable
#
interface GigabitEthernet1/0/27
stp edged-port enable
#
interface GigabitEthernet1/0/28
stp edged-port enable
#
interface GigabitEthernet1/0/29
stp edged-port enable
#
interface GigabitEthernet1/0/30
stp edged-port enable
#
interface GigabitEthernet1/0/31
stp edged-port enable
#
interface GigabitEthernet1/0/32
stp edged-port enable
#
interface GigabitEthernet1/0/33
stp edged-port enable
#
interface GigabitEthernet1/0/34
stp edged-port enable
#
interface GigabitEthernet1/0/35
stp edged-port enable
#
interface GigabitEthernet1/0/36
stp edged-port enable
#
interface GigabitEthernet1/0/37
stp edged-port enable
#
interface GigabitEthernet1/0/38
stp edged-port enable
#
interface GigabitEthernet1/0/39
stp edged-port enable
#
interface GigabitEthernet1/0/40
stp edged-port enable
#
interface GigabitEthernet1/0/41
stp edged-port enable
#
interface GigabitEthernet1/0/42
stp edged-port enable
#
interface GigabitEthernet1/0/43
stp edged-port enable
#
interface GigabitEthernet1/0/44
stp edged-port enable
#
interface GigabitEthernet1/0/45
stp edged-port enable
#
interface GigabitEthernet1/0/46
stp edged-port enable
#
interface GigabitEthernet1/0/47
stp edged-port enable
#
interface GigabitEthernet1/0/48
stp edged-port enable
#
interface GigabitEthernet1/0/49
stp edged-port enable
#
interface GigabitEthernet1/0/50
stp edged-port enable
#
interface GigabitEthernet1/0/51
stp edged-port enable
#
interface GigabitEthernet1/0/52
stp edged-port enable
#
ip route-static 0.0.0.0 0.0.0.0 172.19.4.5
#
snmp-agent
snmp-agent local-engineid 800063A203B8AF67426857
snmp-agent community read public
snmp-agent community write private
snmp-agent sys-info contact IT
snmp-agent sys-info location
snmp-agent sys-info version all
#
ntp-service source-interface Vlan-interface1
ntp-service unicast-server 81.168.77.149
ntp-service unicast-server 194.35.252.7
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return
<HP V1910 Switch 2>
I had issues routing voice traffic across two same make/model switches, one as a core and the other as edge. Managed to resolve this by tagging ports in the respective vlans on the switches, simple fix but not something im used to.
However we are now trying to get two older HP/3com switches to do the same.
Switch Config overview:
HP1910 switch using default vlan1 across all ports. Connected to:
HP2910 switch vlan1 interface (acts as core and routes to firewall). Connects to:
HP/3com2952 switch vlan1 interface. This will connect to:
A new HP2910 switch. This will in turn re-route back to the HP1910 above to form chain topology rather than current loop. I'm assuming this is good?
I am not using any trunks or LACP.
Part one will be to route the new HP switch back to the 2952, once working ill then connect this back to the 1910.
So far i have created a new vlan20 on the old 2952 and tagged the port thats connected to the new 2910. Here is the config:
[3Com Baseline Switch]display current-configuration
#
version 5.20 Release 1101P10
#
sysname 3Com Baseline Switch
#
super password level 3 simple
#
domain default enable system
#
telnet server enable
#
ip ttl-expires enable
#
vlan 1
#
vlan 20
description Voice
#
radius scheme system
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
password simple
authorization-attribute level 3
service-type lan-access
service-type ssh telnet terminal
service-type ftp
#
stp mode rstp
stp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 172.19.4.3 255.255.0.0
#
interface GigabitEthernet1/0/1
stp edged-port enable
#
interface GigabitEthernet1/0/2
stp edged-port enable
#
interface GigabitEthernet1/0/3
stp edged-port enable
#
interface GigabitEthernet1/0/4
stp edged-port enable
#
interface GigabitEthernet1/0/5
stp edged-port enable
#
interface GigabitEthernet1/0/6
stp edged-port enable
#
interface GigabitEthernet1/0/7
port link-type hybrid
port hybrid vlan 20 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
ip route-static 0.0.0.0 0.0.0.0 172.19.4.5
#
snmp-agent
snmp-agent local-engineid 8000002B0320FDF1066322
snmp-agent community read public
snmp-agent community write private
snmp-agent sys-info contact IT
snmp-agent sys-info location HQ
snmp-agent sys-info version all
#
ntp-service source-interface Vlan-interface1
#
load xml-configuration
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return
[3Com Baseline Switch]
The new HP2910 config is as follows:
Running configuration:
; J9148A Configuration Editor; Created on release #W.15.14.0016
; Ver #06:04.18.63.ff.35.05:b6
hostname "HP2910al-48G-PoE-GroundFl
module 1 type j9148a
power-over-ethernet pre-std-detect ports 1-48
qos type-of-service diff-services
sflow 1 destination 172.19.10.23
sflow 1 sampling 2-48 500
timesync sntp
sntp unicast
sntp server priority 1 87.124.126.49
sntp server priority 2 178.79.165.21
time timezone 60
interface 1
name "to port 7 on HP2952"
exit
snmp-server community "public" unrestricted
snmp-server contact "IT" location "Ground Floor"
vlan 1
name "DEFAULT_VLAN"
no untagged 48
untagged 1-47
ip address 172.19.4.6 255.255.0.0
exit
vlan 20
name "VLAN20"
tagged 1,33-48
ip address 172.16.4.6 255.255.0.0
ip helper-address 172.19.10.30
ip helper-address 172.19.10.31
qos dscp 101110
voice
exit
spanning-tree
no tftp server
no autorun
no dhcp config-file-update
password manager
Why can i not ping devices on vlan20 from vlan1? Default route on the 3com the problem? Do i need an IP address associated to newly created vlan20?
Thanks
Edit: i can ping from the 2952 switch console to hosts on 172.19.4.5 and 172.16.*.* fine but cannot ping the 172.16.4.6 interface at all.
Here's the other two switch configs:
Core:
Running configuration:
; J9148A Configuration Editor; Created on release #W.15.08.0012
; Ver #02:11.05:16
hostname "HP-E2910al-48G-PoE-"
module 1 type j9148a
power-over-ethernet pre-std-detect
qos type-of-service diff-services
sflow 1 destination 172.19.10.23
sflow 1 sampling 1-48 500
timesync sntp
sntp unicast
sntp server priority 1 87.124.126.49
sntp server priority 2 178.79.165.21
time timezone 60
ip authorized-managers 172.19.0.0 255.255.0.0 access manager
ip authorized-managers 172.16.0.0 255.255.0.0 access manager
ip authorized-managers 10.255.255.0 255.255.255.128 access manager
ip authorized-managers 192.168.2.0 255.255.255.0 access manager
ip authorized-managers 192.168.3.0 255.255.255.0 access manager
ip authorized-managers 10.255.254.0 255.255.255.128 access manager
ip authorized-managers 192.168.100.0 255.255.255.0 access manager
ip authorized-managers 192.168.200.0 255.255.255.0 access manager
ip authorized-managers 10.255.253.0 255.255.255.0 access manager
ip default-gateway 172.19.10.15
no ip icmp redirects
ip route 0.0.0.0 0.0.0.0 172.19.10.15
ip routing
interface 1
name "to HP1910 (top)"
no power-over-ethernet
exit
interface 2
name "to 3com (bottom)"
no power-over-ethernet
exit
interface 3
name "to ASA 5505 fe01"
no power-over-ethernet
exit
interface 4
name "Cisco_AP_172.19.3.20"
exit
interface 5
name "to HP2910 Ground Floor (TEST)"
exit
interface 6
no power-over-ethernet
exit
interface 7
name "Shoretel E1k"
speed-duplex 100-full
exit
interface 8
name "Shoretel SG90"
speed-duplex 100-full
exit
interface 9
name "Shoretel SG90Bri"
speed-duplex 100-full
exit
interface 10
name "chi-Oaisys"
exit
interface 11
name "Shoretel HQ"
exit
interface 12
name "Ingate"
exit
interface 16
name "Server Room"
exit
interface 19
name "Test Phone"
exit
interface 21
name ""
exit
interface 22
name "Meeting Room"
exit
interface 25
name ""
exit
interface 31
name ""
exit
interface 35
name ""
exit
interface 37
name "to onenet e0/1"
exit
interface 38
name "to cisco asa e0/0"
exit
interface 39
name "to juniper e0/1"
exit
snmp-server community "public" unrestricted
snmp-server contact "IT" location "HQ"
spanning-tree
vlan 1
name "DEFAULT_VLAN"
no untagged 7-48
untagged 1-6
ip address 172.19.4.5 255.255.0.0
exit
vlan 20
name "Voice"
untagged 7-12,35
tagged 5,13-34,36-48
ip address 172.16.4.5 255.255.0.0
ip helper-address 172.19.10.30
ip helper-address 172.19.10.31
qos dscp 101110
voice
exit
vlan 50
name "vlan50"
untagged 37-39
no ip address
exit
no autorun
password manager
HP1910:
<HP V1910 Switch 2>display current-configuration
#
version 5.20 Release 1111
#
sysname HP V1910 Switch 2
#
clock timezone #Web#0#02 add 00:00:00
#
super password level 3 simple
#
domain default enable system
#
telnet server enable
#
ip ttl-expires enable
#
web idle-timeout 30
#
vlan 1
#
radius scheme system
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
password simple
authorization-attribute level 3
service-type ssh telnet terminal
#
stp mode rstp
stp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 172.19.4.4 255.255.0.0
#
interface GigabitEthernet1/0/1
stp edged-port enable
#
interface GigabitEthernet1/0/2
stp edged-port enable
#
interface GigabitEthernet1/0/3
stp edged-port enable
#
interface GigabitEthernet1/0/4
stp edged-port enable
#
interface GigabitEthernet1/0/5
stp edged-port enable
#
interface GigabitEthernet1/0/6
stp edged-port enable
#
interface GigabitEthernet1/0/7
stp edged-port enable
#
interface GigabitEthernet1/0/8
stp edged-port enable
#
interface GigabitEthernet1/0/9
stp edged-port enable
#
interface GigabitEthernet1/0/10
stp edged-port enable
#
interface GigabitEthernet1/0/11
stp edged-port enable
#
interface GigabitEthernet1/0/12
stp edged-port enable
#
interface GigabitEthernet1/0/13
stp edged-port enable
#
interface GigabitEthernet1/0/14
stp edged-port enable
#
interface GigabitEthernet1/0/15
stp edged-port enable
#
interface GigabitEthernet1/0/16
stp edged-port enable
#
interface GigabitEthernet1/0/17
stp edged-port enable
#
interface GigabitEthernet1/0/18
stp edged-port enable
#
interface GigabitEthernet1/0/19
stp edged-port enable
#
interface GigabitEthernet1/0/20
stp edged-port enable
#
interface GigabitEthernet1/0/21
stp edged-port enable
#
interface GigabitEthernet1/0/22
stp edged-port enable
#
interface GigabitEthernet1/0/23
stp edged-port enable
#
interface GigabitEthernet1/0/24
stp edged-port enable
#
interface GigabitEthernet1/0/25
stp edged-port enable
#
interface GigabitEthernet1/0/26
stp edged-port enable
#
interface GigabitEthernet1/0/27
stp edged-port enable
#
interface GigabitEthernet1/0/28
stp edged-port enable
#
interface GigabitEthernet1/0/29
stp edged-port enable
#
interface GigabitEthernet1/0/30
stp edged-port enable
#
interface GigabitEthernet1/0/31
stp edged-port enable
#
interface GigabitEthernet1/0/32
stp edged-port enable
#
interface GigabitEthernet1/0/33
stp edged-port enable
#
interface GigabitEthernet1/0/34
stp edged-port enable
#
interface GigabitEthernet1/0/35
stp edged-port enable
#
interface GigabitEthernet1/0/36
stp edged-port enable
#
interface GigabitEthernet1/0/37
stp edged-port enable
#
interface GigabitEthernet1/0/38
stp edged-port enable
#
interface GigabitEthernet1/0/39
stp edged-port enable
#
interface GigabitEthernet1/0/40
stp edged-port enable
#
interface GigabitEthernet1/0/41
stp edged-port enable
#
interface GigabitEthernet1/0/42
stp edged-port enable
#
interface GigabitEthernet1/0/43
stp edged-port enable
#
interface GigabitEthernet1/0/44
stp edged-port enable
#
interface GigabitEthernet1/0/45
stp edged-port enable
#
interface GigabitEthernet1/0/46
stp edged-port enable
#
interface GigabitEthernet1/0/47
stp edged-port enable
#
interface GigabitEthernet1/0/48
stp edged-port enable
#
interface GigabitEthernet1/0/49
stp edged-port enable
#
interface GigabitEthernet1/0/50
stp edged-port enable
#
interface GigabitEthernet1/0/51
stp edged-port enable
#
interface GigabitEthernet1/0/52
stp edged-port enable
#
ip route-static 0.0.0.0 0.0.0.0 172.19.4.5
#
snmp-agent
snmp-agent local-engineid 800063A203B8AF67426857
snmp-agent community read public
snmp-agent community write private
snmp-agent sys-info contact IT
snmp-agent sys-info location
snmp-agent sys-info version all
#
ntp-service source-interface Vlan-interface1
ntp-service unicast-server 81.168.77.149
ntp-service unicast-server 194.35.252.7
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return
<HP V1910 Switch 2>
The only switch that should have a vlan 20 ip address is the core switch. There is no reason for the new switch to have a vlan interface with an ip address. I don't see why there is a default route on the 3com. I am not that familiar with them. I know on cisco's a switch in layer 2 mode would have a default gateway configured for management reachability. A switch with a default route configured in Cisco world is a switch in L3 mode. Maybe that is similar with the 3com. Regardless, the 3com only needs a vlan 1 address for management as well. All switches should be tagging vlan 20 to the core switch.
ASKER
Sure, i tried with and without an IP (as per other post) and can still route fine.
I can try an remove the default route.
I will also try and add tagging vlan20 on the other switch too, but dont think this will help.
I can try an remove the default route.
I will also try and add tagging vlan20 on the other switch too, but dont think this will help.
If the new switch isn't routing for vlan 20, or vlan 20 isn't being used for management for that switch, having an ip address for vlan 20 and vlan 1 is kind of redundant. Yes, ip connectivity will work, but there is no point to have both interfaces.
ASKER
I've removed i and can still route fine. Its handy to have it for testing and mgt i guess.
Yes, from the perspective of verifying L2 reachability it is a good way to determine that.
Where do you currently stand with this?
ASKER
I was going to try and remove the static route but concerned i may lose connection to the switch..?
ASKER
Connected the HP2952 to the HP 2910 (core) and i lose vlan20 devices on the new HP2910 switch. Unplugging it brings the vlan20 hosts back online/pingable..
Maybe these old switches aren't capable?
Maybe these old switches aren't capable?
ASKER CERTIFIED SOLUTION
membership
Create a free account to see this answer
Signing up is free and takes 30 seconds. No credit card required.
ASKER
Well i'm sure the switch that my desktop was connected to that was up-linked to the new L3 switch 9that then connects to the core L3 switch) and tagged was configured correctly. i couldn't route properly, taking out the new L3 switch.
Do i 100% need an SVI (switch virtual interface?) on all vlans?
Default gateway fro the HP1910 and HP2952 is set (i thought this was the problem why i couldn't route from HP2952 to new HP2910 to old core 2910.. Who knows.
When i added the uplinked port on the 1910 it changed it from untagged to hybrid. It also shows the port as tagged under the vlan20 interface in the gui. I think its correct.
Do i 100% need an SVI (switch virtual interface?) on all vlans?
Default gateway fro the HP1910 and HP2952 is set (i thought this was the problem why i couldn't route from HP2952 to new HP2910 to old core 2910.. Who knows.
When i added the uplinked port on the 1910 it changed it from untagged to hybrid. It also shows the port as tagged under the vlan20 interface in the gui. I think its correct.
The only switch that needs both the vlan 1 and vlan 20 interface is your core switch. The other switches can use either a vlan 1 or vlan 20 interface. Whichever vlan you are using for management of those switches. I assume vlan 1, so you don't need a vlan 20 svi on the other switches. You just need to make sure the other switches have vlan 20 and it's tagged on the port connecting to the core. As well as the core ports connected to the other switches.
ASKER
When you say vlan interface, do you mean an IP address associated?
Yes mgt for all other switches is vlan1.
See attached how i tried connecting this all up. Red is what i have in place. Purple was how i also tried this (to get it in a looped config).
Guessing i should have tagged and created vlan20 between the 2910 - 1910 - 2952 uplinks also?
Yes mgt for all other switches is vlan1.
See attached how i tried connecting this all up. Red is what i have in place. Purple was how i also tried this (to get it in a looped config).
Guessing i should have tagged and created vlan20 between the 2910 - 1910 - 2952 uplinks also?
where is the attachment
Red is fine. Purple is also as long at you tag vlan 20 through the other switches back to the core. Also create vlan 20 on them.
When i added the uplinked port on the 1910 it changed it from untagged to hybrid. It also shows the port as tagged under the vlan20 interface in the gui. I think its correct.If I remember correctly difference between hybrid and trunk on 3COM switches, difference can be when you have more than 2 VLANs on port, which you may want to add in the future.
ASKER
So back to the diagram, and the purposes of testing while in production. Can i leave the existing uplinks untouched and add new one tagging vlan1 and 20 across the switches or do i need to dismantle the existing red links and/or configuration?
if you want to add new upliks you need STP. Additionally, depending where you will plug links even with STP one of links will be disabled. But, without functional STP you can't run multiple links between switches.
I was under the impression that you are currently not tagging VLAN 1 and only tagging vlan 20 correct? Adding the purple link will be fine if you piecemeal it. What I mean is add the link and configure each switch and trunk leading back to the correct one at a time. You biggest concern will be spanning-tree. Making sure your new switch block that second link and not cause a loop once the trunks are all configured back to the core.
ASKER
i think all are stp and rstp enabled.
ASKER
Correct, sort of, the core switch uplinked to the older switches (daisied) were untagged for vlan1.
Currently the new 2910 that is uplinked directly to the other 2910 has vlan1 tagged which has got this switch and vlans working.
I want to get the older two switches added into a chain topology. I did try adding the 2952 to the new 2910 (purple) and tagged vlan1. I never tagged vlan1 on new or existing uplink on the 1910. Guess this why i lost connection to the new 2910. Couldn't ping the vlan1 interface 172.19.4.6 which i found strange.
Currently the new 2910 that is uplinked directly to the other 2910 has vlan1 tagged which has got this switch and vlans working.
I want to get the older two switches added into a chain topology. I did try adding the 2952 to the new 2910 (purple) and tagged vlan1. I never tagged vlan1 on new or existing uplink on the 1910. Guess this why i lost connection to the new 2910. Couldn't ping the vlan1 interface 172.19.4.6 which i found strange.
So just to be clear, you were unable to leave vlan 1 untagged for the new switch to the core and just tag vlan 20? That seems odd considering the core doesn't tag vlan 1 to the old switches.
ASKER
Hang on, no sorry.
Core switch:
vlan 1
name "DEFAULT_VLAN"
no untagged 7-48
untagged 1-6
ip address 172.19.4.5 255.255.0.0
exit
vlan 20
name "Voice"
untagged 7-12,35
tagged 5,13-34,36-48
ip address 172.16.4.5 255.255.0.0
ip helper-address 172.19.10.30
ip helper-address 172.19.10.31
qos dscp 101110
voice
exit
New:
vlan 1
name "DEFAULT_VLAN"
no untagged 2,48
untagged 1,3-47
ip address 172.19.4.6 255.255.0.0
exit
vlan 20
name "VLAN20"
untagged 2
tagged 1,33-48
ip address 172.16.4.6 255.255.0.0
ip helper-address 172.19.10.30
ip helper-address 172.19.10.31
qos dscp 101110
voice
exit
Core switch:
vlan 1
name "DEFAULT_VLAN"
no untagged 7-48
untagged 1-6
ip address 172.19.4.5 255.255.0.0
exit
vlan 20
name "Voice"
untagged 7-12,35
tagged 5,13-34,36-48
ip address 172.16.4.5 255.255.0.0
ip helper-address 172.19.10.30
ip helper-address 172.19.10.31
qos dscp 101110
voice
exit
New:
vlan 1
name "DEFAULT_VLAN"
no untagged 2,48
untagged 1,3-47
ip address 172.19.4.6 255.255.0.0
exit
vlan 20
name "VLAN20"
untagged 2
tagged 1,33-48
ip address 172.16.4.6 255.255.0.0
ip helper-address 172.19.10.30
ip helper-address 172.19.10.31
qos dscp 101110
voice
exit
So vlan 1 is untagged to the new switch? Is port 1 on the new switch the trunk to the core?
ASKER
Yes and Yes..
ASKER
Thinking of this staged attack (so i dont down the network)..
2018_10_26_15_18_24_Ground_Floor_Net.jpg
2018_10_26_15_18_24_Ground_Floor_Net.jpg
Ok, so that is what you will need to do for the second connection to the old switches: 1 untagged and vlan 20 tagged
new switch ---------------------> 3COM --------------------> 1910 ----------------------> Core
1 untag 1 untag 1 untag
20 tag 20 tag 20 tag
new switch ---------------------> 3COM --------------------> 1910 ----------------------> Core
1 untag 1 untag 1 untag
20 tag 20 tag 20 tag
Yes, that's what i meant a couple of posts up. Just do it piecemeal working your way back to the core, making sure STP is doing what it supposed to do.
ASKER
Leaving the old untagged vlan uplinks in place? Run the new links in vlan1 thats tagging vlan20 in the uplink ports alongside?
Will try and see.
Thanks
Will try and see.
Thanks
ASKER
Just uploaded screenshots of the old HPs (same interface).
Have i tagged this correctly or does the voice vlan need to be configured? Justin mentioned hybrid ports that it creates...
vlan.jpg
voice-vlan.jpg
Have i tagged this correctly or does the voice vlan need to be configured? Justin mentioned hybrid ports that it creates...
vlan.jpg
voice-vlan.jpg
ASKER
What do you mean run new uplinks? The only new one would be to from the new switch to the 3com. I assume all other uplinks are already there. You would just be tagging vlan 20 on those uplinks. As for voice vlan, it should be treated the same as any vlan for the switch trunks. Just tag it. Are you sharing pc and phones on the same switch port?
ASKER
Alongside the existing untagged vlan1 uplinks between the core and old HPs.
As per the diagram ive already added the new switch directly into the core switch and thats working. I'd like to connect that to the 3com and chain it all.
My concern is that i lose connection if i tag the uplink ports that are already in use.
If i add second uplinks (different ports) and tag the vlan20 on the vlan1 uplinks alongside the existing uplink that are not tagged in case it crashes and burns.
As per the diagram ive already added the new switch directly into the core switch and thats working. I'd like to connect that to the 3com and chain it all.
My concern is that i lose connection if i tag the uplink ports that are already in use.
If i add second uplinks (different ports) and tag the vlan20 on the vlan1 uplinks alongside the existing uplink that are not tagged in case it crashes and burns.
ASKER
So i have connecte port 2 in the new hp2910 which is tagging vlan20 traffic to port 7 on the old 3com 2952 and im losing ping to 172.16.4.6 on the new hp2910 switch
If you are intending on adding second physical connections alongside the existing you are really introducing a good chance of a switch loop. I would just tag vlan 20 on the existing uplinks. As I stated before, if you do one uplink at a time and verify it is up, you should be able to avoid major issues. Start with the uplink from the new switch to the 3com. Verify it is up. Then move to the link between the 1910 and 3com, then 1910 and core.
What is your spanning tree table showing for vlan 20 on the core switch. No reason adding that uplink should stop ping, since you have a direct connection to the core from the new switch.
ASKER
Yes that is the plan.
Well i tried the new to 3com and the new switch goes down.
Is this becuase the vlan20 traffic isnt tagged between 2952 1910 and core?
Well i tried the new to 3com and the new switch goes down.
Is this becuase the vlan20 traffic isnt tagged between 2952 1910 and core?
That shouldn't have anything to do with it. By going down, what do you mean. What is spanning tree showing when you connect the new switch to the 3com.
ASKER
HP-E2910al-48G-PoE-(config )# show spanning-tree
Multiple Spanning Tree (MST) Information
STP Enabled : Yes
Force Version : MSTP-operation
IST Mapped VLANs : 1-4094
Switch MAC Address : c8cbb8-dc5540
Switch Priority : 32768
Max Age : 20
Max Hops : 20
Forward Delay : 15
Topology Change Count : 1291
Time Since Last Change : 4 mins
CST Root MAC Address : 20fdf1-066320
CST Root Priority : 32768
CST Root Path Cost : 20000
CST Root Port : 2
IST Regional Root MAC Address : c8cbb8-dc5540
IST Regional Root Priority : 32768
IST Regional Root Path Cost : 0
IST Remaining Hops : 20
Root Guard Ports :
TCN Guard Ports :
BPDU Protected Ports :
BPDU Filtered Ports :
PVST Protected Ports :
PVST Filtered Ports :
| Prio | Designated Hello
Port Type | Cost rity State | Bridge Time PtP Edge
----- --------- + --------- ---- ---------- + ------------- ---- --- ----
1 100/1000T | 20000 128 Forwarding | c8cbb8-dc5540 2 Yes No
2 100/1000T | 20000 128 Forwarding | 20fdf1-066320 2 Yes No
3 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
4 100/1000T | 20000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
5 100/1000T | 20000 128 Forwarding | c8cbb8-dc5540 2 Yes No
6 100/1000T | Auto 128 Disabled |
7 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
8 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
9 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
10 100/1000T | 20000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
11 100/1000T | 20000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
12 100/1000T | 20000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
13 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
14 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
15 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
16 100/1000T | Auto 128 Disabled |
17 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
18 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
19 100/1000T | Auto 128 Disabled |
20 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
21 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
22 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
23 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
24 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
25 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
26 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
27 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
28 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
29 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
30 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
31 100/1000T | Auto 128 Disabled |
32 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
33 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
34 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
35 100/1000T | Auto 128 Disabled |
36 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
37 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
38 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
39 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
40 100/1000T | Auto 128 Disabled |
41 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
42 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
43 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
44 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
45 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
46 100/1000T | 20000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
47 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
48 100/1000T | Auto 128 Disabled |
HP-E2910al-48G-PoE-(config )#
Multiple Spanning Tree (MST) Information
STP Enabled : Yes
Force Version : MSTP-operation
IST Mapped VLANs : 1-4094
Switch MAC Address : c8cbb8-dc5540
Switch Priority : 32768
Max Age : 20
Max Hops : 20
Forward Delay : 15
Topology Change Count : 1291
Time Since Last Change : 4 mins
CST Root MAC Address : 20fdf1-066320
CST Root Priority : 32768
CST Root Path Cost : 20000
CST Root Port : 2
IST Regional Root MAC Address : c8cbb8-dc5540
IST Regional Root Priority : 32768
IST Regional Root Path Cost : 0
IST Remaining Hops : 20
Root Guard Ports :
TCN Guard Ports :
BPDU Protected Ports :
BPDU Filtered Ports :
PVST Protected Ports :
PVST Filtered Ports :
| Prio | Designated Hello
Port Type | Cost rity State | Bridge Time PtP Edge
----- --------- + --------- ---- ---------- + ------------- ---- --- ----
1 100/1000T | 20000 128 Forwarding | c8cbb8-dc5540 2 Yes No
2 100/1000T | 20000 128 Forwarding | 20fdf1-066320 2 Yes No
3 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
4 100/1000T | 20000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
5 100/1000T | 20000 128 Forwarding | c8cbb8-dc5540 2 Yes No
6 100/1000T | Auto 128 Disabled |
7 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
8 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
9 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
10 100/1000T | 20000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
11 100/1000T | 20000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
12 100/1000T | 20000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
13 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
14 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
15 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
16 100/1000T | Auto 128 Disabled |
17 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
18 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
19 100/1000T | Auto 128 Disabled |
20 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
21 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
22 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
23 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
24 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
25 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
26 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
27 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
28 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
29 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
30 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
31 100/1000T | Auto 128 Disabled |
32 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
33 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
34 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
35 100/1000T | Auto 128 Disabled |
36 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
37 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
38 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
39 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
40 100/1000T | Auto 128 Disabled |
41 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
42 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
43 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
44 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
45 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
46 100/1000T | 20000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
47 100/1000T | 200000 128 Forwarding | c8cbb8-dc5540 2 Yes Yes
48 100/1000T | Auto 128 Disabled |
HP-E2910al-48G-PoE-(config
ASKER
So connected the secondary uplinks from core to 1910 to 2952 alongside untagged vlan uplinks. All pingable (could be using the vlan1 ungagged uplinks alongside still?).
As soon as i connected 2952 to new 2910 i lose vlan20 still
As soon as i connected 2952 to new 2910 i lose vlan20 still
ASKER
Could it be differing STP, RSTP, MSTP ccausing issues?
Existing vlan1 untagged uplinks?
or incorrectly configured vlan tagging on old HP switches?
Do you want running configs?
Existing vlan1 untagged uplinks?
or incorrectly configured vlan tagging on old HP switches?
Do you want running configs?
Running MSTP with the other spanning can cause possible issues due to how MSTP views the other switches not running MSTP. Can you change the new switch to RSTP.
I also don't see the reason why you are adding additional uplink next to the existing ones. It just makes the STP topology more complex and prone for a loop. is over complicating it. At least make those two runs into port-channels.
Adding new link will/should cause 30 seconds of downtime.
HP is using CST, which means one STP tree for all VLANs.
When it comes to building STP tree you need to know strict rules how loop free topology will be built. What will happen is - higher port number upstream in direction of root bridge will be blocked port (it will not matter if it is forwarding 1 or 2 or more VLANs - port connected to higher port number on upstream device will go into blocked state).
Mixing RSTP and STP does not cause any issues. If MSTP is involved - there is a simple rule. Switch with the lowest BridgeID must be inside MSTP region, otherwise if MSTP boundary port receives superior BPDU from non MSTP region it will go to BPDU inconsistent state (practically disabling interface until timer expires and reason for BPDU inconsistency is not resolved).
HP is using CST, which means one STP tree for all VLANs.
When it comes to building STP tree you need to know strict rules how loop free topology will be built. What will happen is - higher port number upstream in direction of root bridge will be blocked port (it will not matter if it is forwarding 1 or 2 or more VLANs - port connected to higher port number on upstream device will go into blocked state).
Mixing RSTP and STP does not cause any issues. If MSTP is involved - there is a simple rule. Switch with the lowest BridgeID must be inside MSTP region, otherwise if MSTP boundary port receives superior BPDU from non MSTP region it will go to BPDU inconsistent state (practically disabling interface until timer expires and reason for BPDU inconsistency is not resolved).
ASKER
Well i understand running these new uplinks alongside isn't permanent, i'm simply trying to get the new 2910 to route through the older switches, which it currently isn't.
There wasnt any downtime when i added new vlan20 & enabled tagging on old switches. Same for connecting the new uplinks, all fine, until connecting the last uplink between new and old..
Im not stuck what to try next.
There wasnt any downtime when i added new vlan20 & enabled tagging on old switches. Same for connecting the new uplinks, all fine, until connecting the last uplink between new and old..
Im not stuck what to try next.
ASKER
Here's the running configs in case there is any mistakes..
CORE:
Running configuration:
; J9148A Configuration Editor; Created on release #W.15.08.0012
; Ver #02:11.05:16
hostname "HP-E2910al-48G-PoE-
module 1 type j9148a
power-over-ethernet pre-std-detect
qos type-of-service diff-services
sflow 1 destination 172.19.10.23
sflow 1 sampling 1-48 500
timesync sntp
sntp unicast
sntp server priority 1 87.124.126.49
sntp server priority 2 178.79.165.21
time timezone 60
ip authorized-managers 172.19.0.0 255.255.0.0 access manager
ip authorized-managers 172.16.0.0 255.255.0.0 access manager
ip authorized-managers 10.255.255.0 255.255.255.128 access manager
ip authorized-managers 192.168.2.0 255.255.255.0 access manager
ip authorized-managers 192.168.3.0 255.255.255.0 access manager
ip authorized-managers 10.255.254.0 255.255.255.128 access manager
ip authorized-managers 192.168.100.0 255.255.255.0 access manager
ip authorized-managers 192.168.200.0 255.255.255.0 access manager
ip authorized-managers 10.255.253.0 255.255.255.0 access manager
ip default-gateway 172.19.10.15
no ip icmp redirects
ip route 0.0.0.0 0.0.0.0 172.19.10.15
ip routing
interface 1
name "to HP1910 (top)"
no power-over-ethernet
exit
interface 2
name "to 3com (bottom)"
no power-over-ethernet
exit
interface 3
name "to ASA 5505 fe01"
no power-over-ethernet
exit
interface 4
name ""
exit
interface 5
name "to HP2910 Ground Floor (TEST)"
exit
interface 6
name "to port 2 in HP1910 (test)"
no power-over-ethernet
exit
interface 7
name "Shoretel E1k"
speed-duplex 100-full
exit
interface 8
name "Shoretel SG90"
speed-duplex 100-full
exit
interface 9
name "Shoretel SG90Bri"
speed-duplex 100-full
exit
interface 10
name "chi-Oaisys"
exit
interface 11
name "Shoretel HQ"
exit
interface 12
name
exit
interface 16
name "Server Room"
exit
interface 19
name "Test Phone"
exit
interface 21
name
exit
interface 22
name
exit
interface 25
name
exit
interface 31
name
exit
interface 35
name
exit
interface 37
name "to onenet e0/1"
exit
interface 38
name "to cisco asa e0/0"
exit
interface 39
name "to juniper e0/1"
exit
snmp-server community "public" unrestricted
snmp-server contact "IT" location "HQ"
spanning-tree
vlan 1
name "DEFAULT_VLAN"
no untagged 7-48
untagged 1-6
ip address 172.19.4.5 255.255.0.0
exit
vlan 20
name "Voice"
untagged 7-12,35
tagged 5-6,13-34,36-48
ip address 172.16.4.5 255.255.0.0
ip helper-address 172.19.10.30
ip helper-address 172.19.10.31
qos dscp 101110
voice
exit
vlan 50
name "vlan50"
untagged 37-39
no ip address
exit
no autorun
password manager
1910:
<HP V1910 Switch>display current-configuration
#
version 5.20 Release 1111
#
sysname HP V1910 Switch
#
clock timezone #Web#0#02 add 00:00:00
#
super password level 3 simple
#
domain default enable system
#
telnet server enable
#
ip ttl-expires enable
#
web idle-timeout 60
#
vlan 1
#
vlan 20
description Voice
#
radius scheme system
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
password simple
authorization-attribute level 3
service-type ssh telnet terminal
#
stp mode rstp
stp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 172.19.4.4 255.255.0.0
#
interface GigabitEthernet1/0/1
stp edged-port enable
#
interface GigabitEthernet1/0/2
port link-type hybrid
port hybrid vlan 20 tagged
port hybrid vlan 1 untagged
port hybrid pvid vlan 20
stp edged-port enable
#
interface GigabitEthernet1/0/3
stp edged-port enable
#
interface GigabitEthernet1/0/4
stp edged-port enable
#
interface GigabitEthernet1/0/5
stp edged-port enable
#
interface GigabitEthernet1/0/6
stp edged-port enable
#
interface GigabitEthernet1/0/7
port link-type hybrid
port hybrid vlan 20 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/8
stp edged-port enable
#
interface GigabitEthernet1/0/9
stp edged-port enable
#
#
ip route-static 0.0.0.0 0.0.0.0 172.19.4.5
#
snmp-agent
snmp-agent local-engineid 800063A203B8AF67426857
snmp-agent community read public
snmp-agent community write private
snmp-agent sys-info contact IT
snmp-agent sys-info location
snmp-agent sys-info version all
#
ntp-service source-interface Vlan-interface1
ntp-service unicast-server 81.168.77.149
ntp-service unicast-server 194.35.252.7
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return
<HP V1910 Switch>
2952:
<HP2952 Switch>display current-configuration
#
version 5.20 Release 1101P10
#
sysname HP2952 Switch
#
super password level 3 simple
#
domain default enable system
#
telnet server enable
#
ip ttl-expires enable
#
vlan 1
#
vlan 20
description Voice
#
radius scheme system
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
password simple
authorization-attribute level 3
service-type lan-access
service-type ssh telnet terminal
service-type ftp
#
stp mode rstp
stp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 172.19.4.3 255.255.0.0
#
interface GigabitEthernet1/0/1
stp edged-port enable
#
interface GigabitEthernet1/0/2
stp edged-port enable
#
interface GigabitEthernet1/0/3
stp edged-port enable
#
interface GigabitEthernet1/0/4
stp edged-port enable
#
interface GigabitEthernet1/0/5
stp edged-port enable
#
interface GigabitEthernet1/0/6
stp edged-port enable
#
interface GigabitEthernet1/0/7
port link-type hybrid
port hybrid vlan 20 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/8
stp edged-port enable
#
interface GigabitEthernet1/0/9
port link-type hybrid
port hybrid vlan 20 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/10
stp edged-port enable
#
ip route-static 0.0.0.0 0.0.0.0 172.19.4.5
#
snmp-agent
snmp-agent local-engineid 8000002B0320FDF1066322
snmp-agent community read public
snmp-agent community write private
snmp-agent sys-info contact IT
snmp-agent sys-info location HQ
snmp-agent sys-info version all
#
ntp-service source-interface Vlan-interface1
#
load xml-configuration
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return
<HP2952 Switch>
New 2910:
Running configuration:
; J9148A Configuration Editor; Created on release #W.15.14.0016
; Ver #06:04.18.63.ff.35.05:b6
hostname "HP2910al-48G-PoE-GroundFl oor"
module 1 type j9148a
power-over-ethernet pre-std-detect ports 1-48
qos type-of-service diff-services
sflow 1 destination 172.19.10.23
sflow 1 sampling 2-48 500
timesync sntp
sntp unicast
sntp server priority 1 87.124.126.49
sntp server priority 2 178.79.165.21
time timezone 60
interface 1
name "to port 5 on HP2910 (CORE)"
exit
interface 2
name "to port 7 on 3com2952 (test)"
exit
snmp-server community "public" unrestricted
snmp-server contact "IT" location "Ground Floor"
vlan 1
name "DEFAULT_VLAN"
no untagged 48
untagged 1-47
ip address 172.19.4.6 255.255.0.0
exit
vlan 20
name "VLAN20"
tagged 1-2,33-48
ip address 172.16.4.6 255.255.0.0
ip helper-address 172.19.10.30
ip helper-address 172.19.10.31
qos dscp 101110
voice
exit
spanning-tree
no tftp server
no autorun
no dhcp config-file-update
password manager
CORE:
Running configuration:
; J9148A Configuration Editor; Created on release #W.15.08.0012
; Ver #02:11.05:16
hostname "HP-E2910al-48G-PoE-
module 1 type j9148a
power-over-ethernet pre-std-detect
qos type-of-service diff-services
sflow 1 destination 172.19.10.23
sflow 1 sampling 1-48 500
timesync sntp
sntp unicast
sntp server priority 1 87.124.126.49
sntp server priority 2 178.79.165.21
time timezone 60
ip authorized-managers 172.19.0.0 255.255.0.0 access manager
ip authorized-managers 172.16.0.0 255.255.0.0 access manager
ip authorized-managers 10.255.255.0 255.255.255.128 access manager
ip authorized-managers 192.168.2.0 255.255.255.0 access manager
ip authorized-managers 192.168.3.0 255.255.255.0 access manager
ip authorized-managers 10.255.254.0 255.255.255.128 access manager
ip authorized-managers 192.168.100.0 255.255.255.0 access manager
ip authorized-managers 192.168.200.0 255.255.255.0 access manager
ip authorized-managers 10.255.253.0 255.255.255.0 access manager
ip default-gateway 172.19.10.15
no ip icmp redirects
ip route 0.0.0.0 0.0.0.0 172.19.10.15
ip routing
interface 1
name "to HP1910 (top)"
no power-over-ethernet
exit
interface 2
name "to 3com (bottom)"
no power-over-ethernet
exit
interface 3
name "to ASA 5505 fe01"
no power-over-ethernet
exit
interface 4
name ""
exit
interface 5
name "to HP2910 Ground Floor (TEST)"
exit
interface 6
name "to port 2 in HP1910 (test)"
no power-over-ethernet
exit
interface 7
name "Shoretel E1k"
speed-duplex 100-full
exit
interface 8
name "Shoretel SG90"
speed-duplex 100-full
exit
interface 9
name "Shoretel SG90Bri"
speed-duplex 100-full
exit
interface 10
name "chi-Oaisys"
exit
interface 11
name "Shoretel HQ"
exit
interface 12
name
exit
interface 16
name "Server Room"
exit
interface 19
name "Test Phone"
exit
interface 21
name
exit
interface 22
name
exit
interface 25
name
exit
interface 31
name
exit
interface 35
name
exit
interface 37
name "to onenet e0/1"
exit
interface 38
name "to cisco asa e0/0"
exit
interface 39
name "to juniper e0/1"
exit
snmp-server community "public" unrestricted
snmp-server contact "IT" location "HQ"
spanning-tree
vlan 1
name "DEFAULT_VLAN"
no untagged 7-48
untagged 1-6
ip address 172.19.4.5 255.255.0.0
exit
vlan 20
name "Voice"
untagged 7-12,35
tagged 5-6,13-34,36-48
ip address 172.16.4.5 255.255.0.0
ip helper-address 172.19.10.30
ip helper-address 172.19.10.31
qos dscp 101110
voice
exit
vlan 50
name "vlan50"
untagged 37-39
no ip address
exit
no autorun
password manager
1910:
<HP V1910 Switch>display current-configuration
#
version 5.20 Release 1111
#
sysname HP V1910 Switch
#
clock timezone #Web#0#02 add 00:00:00
#
super password level 3 simple
#
domain default enable system
#
telnet server enable
#
ip ttl-expires enable
#
web idle-timeout 60
#
vlan 1
#
vlan 20
description Voice
#
radius scheme system
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
password simple
authorization-attribute level 3
service-type ssh telnet terminal
#
stp mode rstp
stp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 172.19.4.4 255.255.0.0
#
interface GigabitEthernet1/0/1
stp edged-port enable
#
interface GigabitEthernet1/0/2
port link-type hybrid
port hybrid vlan 20 tagged
port hybrid vlan 1 untagged
port hybrid pvid vlan 20
stp edged-port enable
#
interface GigabitEthernet1/0/3
stp edged-port enable
#
interface GigabitEthernet1/0/4
stp edged-port enable
#
interface GigabitEthernet1/0/5
stp edged-port enable
#
interface GigabitEthernet1/0/6
stp edged-port enable
#
interface GigabitEthernet1/0/7
port link-type hybrid
port hybrid vlan 20 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/8
stp edged-port enable
#
interface GigabitEthernet1/0/9
stp edged-port enable
#
#
ip route-static 0.0.0.0 0.0.0.0 172.19.4.5
#
snmp-agent
snmp-agent local-engineid 800063A203B8AF67426857
snmp-agent community read public
snmp-agent community write private
snmp-agent sys-info contact IT
snmp-agent sys-info location
snmp-agent sys-info version all
#
ntp-service source-interface Vlan-interface1
ntp-service unicast-server 81.168.77.149
ntp-service unicast-server 194.35.252.7
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return
<HP V1910 Switch>
2952:
<HP2952 Switch>display current-configuration
#
version 5.20 Release 1101P10
#
sysname HP2952 Switch
#
super password level 3 simple
#
domain default enable system
#
telnet server enable
#
ip ttl-expires enable
#
vlan 1
#
vlan 20
description Voice
#
radius scheme system
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
password simple
authorization-attribute level 3
service-type lan-access
service-type ssh telnet terminal
service-type ftp
#
stp mode rstp
stp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 172.19.4.3 255.255.0.0
#
interface GigabitEthernet1/0/1
stp edged-port enable
#
interface GigabitEthernet1/0/2
stp edged-port enable
#
interface GigabitEthernet1/0/3
stp edged-port enable
#
interface GigabitEthernet1/0/4
stp edged-port enable
#
interface GigabitEthernet1/0/5
stp edged-port enable
#
interface GigabitEthernet1/0/6
stp edged-port enable
#
interface GigabitEthernet1/0/7
port link-type hybrid
port hybrid vlan 20 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/8
stp edged-port enable
#
interface GigabitEthernet1/0/9
port link-type hybrid
port hybrid vlan 20 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/10
stp edged-port enable
#
ip route-static 0.0.0.0 0.0.0.0 172.19.4.5
#
snmp-agent
snmp-agent local-engineid 8000002B0320FDF1066322
snmp-agent community read public
snmp-agent community write private
snmp-agent sys-info contact IT
snmp-agent sys-info location HQ
snmp-agent sys-info version all
#
ntp-service source-interface Vlan-interface1
#
load xml-configuration
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return
<HP2952 Switch>
New 2910:
Running configuration:
; J9148A Configuration Editor; Created on release #W.15.14.0016
; Ver #06:04.18.63.ff.35.05:b6
hostname "HP2910al-48G-PoE-GroundFl
module 1 type j9148a
power-over-ethernet pre-std-detect ports 1-48
qos type-of-service diff-services
sflow 1 destination 172.19.10.23
sflow 1 sampling 2-48 500
timesync sntp
sntp unicast
sntp server priority 1 87.124.126.49
sntp server priority 2 178.79.165.21
time timezone 60
interface 1
name "to port 5 on HP2910 (CORE)"
exit
interface 2
name "to port 7 on 3com2952 (test)"
exit
snmp-server community "public" unrestricted
snmp-server contact "IT" location "Ground Floor"
vlan 1
name "DEFAULT_VLAN"
no untagged 48
untagged 1-47
ip address 172.19.4.6 255.255.0.0
exit
vlan 20
name "VLAN20"
tagged 1-2,33-48
ip address 172.16.4.6 255.255.0.0
ip helper-address 172.19.10.30
ip helper-address 172.19.10.31
qos dscp 101110
voice
exit
spanning-tree
no tftp server
no autorun
no dhcp config-file-update
password manager
ASKER
As mentioned by Justin looks like trunk ports are required for uplinks on older switches?
https://support.hpe.com/hpsc/doc/public/display?docId=mmr_kc-0119782
https://support.hpe.com/hpsc/doc/public/display?docId=mmr_kc-0102233
https://support.hpe.com/hpsc/doc/public/display?docId=mmr_kc-0119782
https://support.hpe.com/hpsc/doc/public/display?docId=mmr_kc-0102233
We've being saying trunk ports from the very first comment. When you tag a vlan on a port connecting to another switch, it is essentially a trunk port.
ASKER
But hybrid appears similar looking at the guides..
You should stick with trunk configuration between the switches.
Trunk on ProVision switches has different meaning (link aggregation), trunk is only for 3com devices.
Do not configure stp edged-port enable on ports between switches, it might bite you...
Do not configure stp edged-port enable on ports between switches, it might bite you...
ASKER
Thats what i thought. So the newer switches are fine as uplinked ports and the older ones need to be configured as trunks?
What do you mean 'stp edged-port enable on ports between switches'
What do you mean 'stp edged-port enable on ports between switches'
Don't issue that command on uplinks.
ASKER
What? The 3com trunks on uplinks?
On any uplinks - edge port should be implemented only on ports where end devices are located.
ASKER
Well i have STP and RSTP enabled on the switches.
Not sure i follow you regards edge ports.
Back to the query. Should i be configuring the trunks on the 3com switches and leave the 2910s are standard uplinks?
Not sure i follow you regards edge ports.
Back to the query. Should i be configuring the trunks on the 3com switches and leave the 2910s are standard uplinks?
By trunking do you mean tagging vlan 20 or trunking multiple interfaces to a logical port? By edge ports, he means the ports where you will be plugging computer and phones to. Those ports you want the stp edge port config. It must equate to port-fast in Cisco. Where the port comes up quicker to allow dhcp to complete.
ASKER
The 3com guide i linked shows trunking as a way of tagging vlan20 traffic or using hybrid (for phones).
Got ya regards edge ports. Unsure what im supposed to configure;
spanning-tree
bpdu-protection-ti... Set the time for protected ports to be in down state
after receiving unauthorized BPDUs.
clear-debug-counters Clear spanning tree debug counters.
config-name Set the MST region configuration name (default is
switch's MAC address).
config-revision Set the MST region configuration revision number
(default is 0).
force-version Set Spanning Tree protocol compatibility mode.
forward-delay Set time the switch waits between transitioning from
listening to learning and from learning to forwarding
states.
hello-time Set time between messages transmission when the switch
is root.
instance Create, delete or configure an MST instance.
legacy-mode Set spanning-tree protocol to operate either in 802.1D
legacy mode or in 802.1s native mode.
legacy-path-cost Set 802.1D (legacy) or 802.1t (not legacy) default
pathcost values.
max-hops Set the max number of hops in a region before the MST
BPDU is discarded and the information held for a port is
aged (default is 20).
maximum-age Set maximum age of received STP information before it is
discarded.
pending Manipulate pending MSTP configuration.
[ethernet] PORT-LIST Configure the port-specific parameters of the spanning
tree protocol for individual ports.
priority Set the device STP priority (the value is in range of
0-61440 divided into steps of 4096 that are numbered
from 0 to 15, default is step 8).
trap Enable/disable STP traps.
<cr>
I just need to route the vlan20 traffic across the old HP/3com which i cant get working
Got ya regards edge ports. Unsure what im supposed to configure;
spanning-tree
bpdu-protection-ti... Set the time for protected ports to be in down state
after receiving unauthorized BPDUs.
clear-debug-counters Clear spanning tree debug counters.
config-name Set the MST region configuration name (default is
switch's MAC address).
config-revision Set the MST region configuration revision number
(default is 0).
force-version Set Spanning Tree protocol compatibility mode.
forward-delay Set time the switch waits between transitioning from
listening to learning and from learning to forwarding
states.
hello-time Set time between messages transmission when the switch
is root.
instance Create, delete or configure an MST instance.
legacy-mode Set spanning-tree protocol to operate either in 802.1D
legacy mode or in 802.1s native mode.
legacy-path-cost Set 802.1D (legacy) or 802.1t (not legacy) default
pathcost values.
max-hops Set the max number of hops in a region before the MST
BPDU is discarded and the information held for a port is
aged (default is 20).
maximum-age Set maximum age of received STP information before it is
discarded.
pending Manipulate pending MSTP configuration.
[ethernet] PORT-LIST Configure the port-specific parameters of the spanning
tree protocol for individual ports.
priority Set the device STP priority (the value is in range of
0-61440 divided into steps of 4096 that are numbered
from 0 to 15, default is step 8).
trap Enable/disable STP traps.
<cr>
I just need to route the vlan20 traffic across the old HP/3com which i cant get working
If 3com says trunking is tagging vlan20 then that is the port type you need to configure.
ASKER
Switch VLAN port types
Access ports:
• Belong to one VLAN – Port is untagged
Trunk ports:
• Carry multiple VLANs on a single physical link
• VLANs are 802.1Q tagged
• The native VLAN is untagged
Hybrid ports:
• Belongs to multiple VLANs
• Multiple VLANs can be untagged and tagged
• Typically used for IP phone connection
• Also in conjunction with protocol VLANs, IP subnet VLANs
Access ports:
• Belong to one VLAN – Port is untagged
Trunk ports:
• Carry multiple VLANs on a single physical link
• VLANs are 802.1Q tagged
• The native VLAN is untagged
Hybrid ports:
• Belongs to multiple VLANs
• Multiple VLANs can be untagged and tagged
• Typically used for IP phone connection
• Also in conjunction with protocol VLANs, IP subnet VLANs
Yep, trunk is what you want.
ASKER
and leave the newer hps as-is, tagged uplink ports?
and will this trunk act as the primary link for routing traffic? i.e. take the existing chained uplink ports down?
and will this trunk act as the primary link for routing traffic? i.e. take the existing chained uplink ports down?
The only connection that should go down by spanning tree is the new link between new switch and the 3COM. Provided you are running all the same spanning tree. Not the MST.
ASKER
Let me get this straight:
Change the current hybrid port to a trunk on the 3com 172.19.4.3 or use new port configuring this as a trunk port, connecting this to the new HP 2910 (leaving the existing port as uplink, tagging vlan20)?
Thanks
Change the current hybrid port to a trunk on the 3com 172.19.4.3 or use new port configuring this as a trunk port, connecting this to the new HP 2910 (leaving the existing port as uplink, tagging vlan20)?
Thanks
ASKER
Ne HP 2910s ar eusing MSTP.
Old 3com and HP are using RSTP
Old 3com and HP are using RSTP
Can you change them to RSTP?
ASKER
Change the new to RSTP? Isnt MSTP the next gen on from rstp?
ASKER
Latest diagram with revisions
2018_10_31_09_33_54_Window.jpg
2018_10_31_09_33_54_Window.jpg
ASKER
So currently:
Looped.
Core 2910 - HP 1910
Core 2910 - 3com 2952
Core 2910 - new 2910
Need chained.
Core 2910 - 1910 - 2952 - new 2910 - core 2910
Requirements.
Core 2910 - uplink tagged 20 - 1910 trunk port - 2952 trunk - core 2910?
Will be my last chance to configure this evening.
Thanks
Looped.
Core 2910 - HP 1910
Core 2910 - 3com 2952
Core 2910 - new 2910
Need chained.
Core 2910 - 1910 - 2952 - new 2910 - core 2910
Requirements.
Core 2910 - uplink tagged 20 - 1910 trunk port - 2952 trunk - core 2910?
Will be my last chance to configure this evening.
Thanks
The confusion here is your switches definition of trunking vs tagged. At the end of the day you want your uplink to carry VLAN 20 and VLAN1. Our understanding so far is that vlan 1 will be untagged between all switches. That said, what is left is tagging VLAN 20 between all switches. Now what you need to do when you are in each switch is determine if that particular switch thinks "trunk" is the same thing as tagging VLAN 20. Tagging VLAN 20 while leaving vlan 1 untagged and having them both traverse the same link is the end game.
ASKER
Sure i understand. My concern is the trunk changes on the older switches that are in production, and not being 100% sure about the hybrid or trunks on these.
We are going to leave it as-is i think.
Regarding the RSTP/MSTP differences, what should be done here? All on MSTP or RSTP?
We are going to leave it as-is i think.
Regarding the RSTP/MSTP differences, what should be done here? All on MSTP or RSTP?
if you are not sure MSTP or RSTP => RSTP.
ASKER
Thanks for all your help.
Will change all to RSTP over the weekend and configure switches like the attached.
2018_11_08_10_24_01_Window.jpg
Will change all to RSTP over the weekend and configure switches like the attached.
2018_11_08_10_24_01_Window.jpg