Link to home
Create AccountLog in
Avatar of Kevin
KevinFlag for United States of America

asked on

How can I Turn off UAC for ALL Users who log on to a paticular server?

Good Morning,

I am attempting to turn off UAC for ALL users who log on via RDP to one of my servers (Windows Server 2012 R2 Std).

My domain and forest functional levels is Windows Server 2012 R2.

Below is a screenshot of what I have in GPO.
User generated image
I have 2 standard users who connect to this server, and if I log in as them and go to the UAC settings I still see that it is on (screenshot below).
User generated image
Yet when I login (as a domain admin) to the server via RDP, my UAC setting is off (screenshot below).
User generated image
Please advise how I can turn UAC off completely for ALL users who log on to this server.

Kind Regards,
K
ASKER CERTIFIED SOLUTION
Avatar of aravind anche
aravind anche
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of Kevin

ASKER

Please advise path of registry addition in GPO. As I would like this change to be done via GPO.
The path is included, the key is EnableUAC value 0

Point is the setting is system based not user based.

The RDP has two functional modes. When you look at the uac, in which mode is the Server execute, install?
alternatively
In the GPMC editor click on Computer Configuration > Policies > Windows Settings > Security Settings > Local Policies > Security Options. On the right pane there are lot of settings that you see, so you need to modify the following policies.

1) User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode = Right click policy setting, click Properties. Check the box Define this policy setting and choose Elevate without prompting.

2) User Account Control: Detect application installations and prompt for elevation = Right click policy setting, click Properties. Check the box Define this policy setting and choose Disabled.

3) User Account Control: Run all administrators in Admin Approval Mode = Right click policy setting, click Properties. Check the box Define this policy setting and choose Disabled.

https://prajwaldesai.com/disable-user-account-control-using-group-policy/
Also do NOT turn UAC OFF.  Bad idea all around and on Workstations, Store and some Windows 10 Apps will not function.

I can log on to any halfway modern server with UAC ON.
The question of the day is, "Why?"
Avatar of Kevin

ASKER

@aravind anche - thank you, for your second posting, however as you can see from my initial post (first image), I have these options in GPO set already and it is not working. I will try and add the registry string to the computer account within the registry portion of GPO to see if it has any effect.

@John & @Philip - I appreciate your concern (and I am grateful for your opinions), but I did not ask for guidance within my initial post. We have no use for UAC to be on this particular server, nor will we be accessing the Microsoft store nor any windows 10 apps. I asked about turning UAC off on just one particular server. I cannot share on this public forum as to why. Thank you however for your response.
Avatar of Kevin

ASKER

Thank you.