Link to home
Create AccountLog in
Avatar of Smith and Andersen
Smith and AndersenFlag for Canada

asked on

Mapped drives missing from file explorer only

I have a bunch of win 10 boxes running at 1709 that are not showing mapped drives in the gui but do at the cmd
The mapped drives are obtained via a GPP drive mapping
If a user logs on in the morning they get all mapped drives as per design
As soon a policies refresh 90 min later half the drives are missing
If I do net use @ cmd I see all mapped drives and can browse all folders and files, however in file explorer all I see is half of the drives
If a user reboots again all the drives are there
Avatar of Robert
Robert
Flag of United States of America image

Check if you have the setting enabled to hide mapped drives in a GPO.
should be under
User Configuration > Administrative Templates > Windows Components > File Explorer

I have also seen security software such as certain AV software that has ability to hide drives from explorer.
If some folders are NETBIOS and some are WSD, Windows 10 Browse will not display them all.

I have done away with Browsing as a useful concept at least right now and map folders by NET USE, or Explorer Map Network drive. Either way works.
Avatar of Smith and Andersen

ASKER

Hi John
All drives are mapped fully qualified
I have to use GPP as we replicate servers across the country. Each office gets a drive pointing to the closest server and now we are introducing a vdi solution and we don't want users logging from 1 end of the country and getting a mapped drive from that office location for performance
I understand but Windows 10 does not browse properly across all mapped drives. We see that a lot and have moved away from it.

we don't want users logging from 1 end of the country and getting a mapped drive from that office location for performance

Mapped versus Browsed does not change performance in any way.
Ok. What I have just learned is that it definitely has something to do with explorer.exe
I killed the explorer process and started it again and all the drives were there!!
try creating regkey in below location
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
dwordvalue
EnableLinkedConnections value 1
restart computer and check if you can see drives
it can be cause of many reasons...


mapped drive preferences setting could be cause of it...
check the following link ... for settings ...

https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc770902(v=ws.11)

all the best
Verify your GPP.
The simple reason could be: you set the drives to replace instead of create. Set the to create, instead.
Hi guys.
Thanks for all the replies

John. Users cant browse for our cad files as they are drive letter dependant unfortunately. All supporting files for our MEP environment are also drive letter dependant. This could be changed but it would have to be done on over 250,000 dwg files. Our win 7 users have no issues

McKnife. I have tried both ways. they both work. AS I mentioned. The drives are technically mapped as we see them at the cmd prompt listed as OK, however explorer.exe doesn't see them. And my win 7 users have no issues with either create or replace

aravind. Killing explorer.exe in task manager and starting the same way brings them back to the gui
"I have tried both ways. they both work". You didn't get my point. At the time of the gpo refresh, the replace action will cause this unwanted effect. Try it out.
I tried browsing on the common V1803 version and also on the less common V1809 version and browsing was not completely successful where NET USE is always successful.  

This is a bit of an evergreen question in here and no bullet proof solution.
Hi Guys
All I needed to do was get the GPP to update and not replace
ASKER CERTIFIED SOLUTION
Avatar of Smith and Andersen
Smith and Andersen
Flag of Canada image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Setting it to "update" means "create it if it is not present", or "update it to new values, if it's present and the values are indeed different". Since you didn't change values, update is effectively the same as create - which I recommended to do.

But you prefer to select your own comment as solution - why is that, did you try "create" and it did not work?