Link to home
Create AccountLog in
Avatar of Howard Bash
Howard BashFlag for United States of America

asked on

SharePoint 2016 Missing Filter Web Parts

Have looked in site settings and cannot find the setting which enables the filters.
Avatar of Piotr Strycharz
Piotr Strycharz
Flag of Poland image

Filter Web Parts are the part of the 'SharePoint Server Enterprise Site Collection features' feature, which in turn activates "BizApps Site Templates" feature that contains web parts.
Avatar of Howard Bash

ASKER

It appears (how to tell) that this install is SharePoint Server Standard  as there is a "SharePoint Server Standard Site Collection Features".  If it is Standard am I out of look on these web parts?
I do not know what is actually included in the standard version of SharePoint. Check if you have C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\TEMPLATE\FEATURES\BizAppsSiteTemplates folder on the disk. If so -  you are free to install this feature. Please note that some webparts may not work with your SP version. Again - not sure as I do not have access to Standard Version.
I found some web parts in this folder:
C:\Program Files\Common Files\microsoft shared\Web Server Extensions\16\TEMPLATE\FEATURES\BizAppsSiteTemplates\dwp.  I assumpe the "16" in the path is because it's SP1016.

Here are the files I see:
AuthoredListFilter
BusinessDataFilter
DateFilter
FilterActions
OlapFilter
PageContentFilter
QueryStringFilter
SplistFilter
TextFilter
UserContextFilter

However,  I don't see a Filters category when I go to add a web part to  a page.
Did you run the command?:

Enable-SPFeature BizAppsSiteTemplates -URL http://YOUR-SITE-URL

Open in new window


I did check it for empty site (STS#1) and it works. In fact, I have some more webparts: AuthoredListFilter.webpart
BusinessDataActionsWebPart.dwp, BusinessDataAssociationWebPart.webpart, BusinessDataDetailsWebPart.webpart, BusinessDataFilter.dwp, BusinessDataItemBuilder.dwp, BusinessDataListWebPart.webpart, DateFilter.dwp, FilterActions.dwp, IndicatorWebPart.dwp, IViewWebPart.dwp, KpiListWebPart.dwp, OlapFilter.dwp, PageContextFilter.webpart, ProjectSummary.webpart, QueryStringFilter.webpart, SpListFilter.dwp, TextFilter.dwp, UserContextFilter.webpart, WSRPConsumerWebPart.dwp. But you have at least DateFilter, and it it enought to be visible in Filters section.
So, I ran that command and it failed for me.  Here is the error:

User generated image
ASKER CERTIFIED SOLUTION
Avatar of Piotr Strycharz
Piotr Strycharz
Flag of Poland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Command failed for me.  "The feature is not a farm level feature and is not found in a Site Level defined by http://some-site/.
Again, you did not install feature. If the feature is not installed the error is "Feature is not a Farm Level Feature...", if it does not exist the error is "Failed to find XML...".

PS C:\> Enable-SPFeature NonInstalledFeature -Url http://test
Enable-SPFeature : The Feature is not a Farm Level Feature and is not found in a Site level defined by the Url http://playdocs.
At line:1 char:1
+ Enable-SPFeature NonInstalledFeature -Url http://test
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidData: (Microsoft.Share...etEnableFeature:SPCmdletEnableFeature) [Enable-SPFeature], SPCmdletException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletEnableFeature

PS C:\> Install-SPFeature NonExistingFeature
Install-SPFeature : Failed to find the XML file at location '15\Template\Features\NonExistingFeature\feature.xml'
At line:1 char:1
+ Install-SPFeature NonExistingFeature
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidData: (Microsoft.Share...tInstallFeature:SPCmdletInstallFeature) [Install-SPFeature], SPException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletInstallFeature

Open in new window


Install the feature first:

Install-SPFeature BizAppsSiteTemplates

Open in new window