How do I get this server back online?

Have taken the time to update XenServer 6, trying to get it all the way. The most update, however looks to have broken it. This is a super critical machine and I've been on it for 6 hours now.

XenCenter 6.5 cannot see/connect to the host.

The Host seems to be stuck in maintenance mode. When I try to exist maintenance mode from xsconsole, I get ("'NoneType' object has no attribute 'xenapi'",)

The host is pingable and can ping out.

I cannot run any xe commands, it returns: Error: Connection refused (calling connect ).

If you anyone can get me out of this tight spot I will be eternally grateful!
Nathan DAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tony JohncockLead Technical ArchitectCommented:
I haven't come across this but a few others have when you Google.

Did you see this thread?

https://discussions.citrix.com/topic/361793-xenserver-65-cant-exit-maintenance-mode/
Nathan DAuthor Commented:
Yeah I've done the rounds online for the last 8 hours and it's driving me *insane!* Thankyou for for the effort though!
Tony JohncockLead Technical ArchitectCommented:
Is it a standalone server?

Tried renamiing the db file one of those links points to?
SolarWinds® VoIP and Network Quality Manager(VNQM)

WAN and VoIP monitoring tools that can help with troubleshooting via an intuitive web interface. Review quality of service data, including jitter, latency, packet loss, and MOS. Troubleshoot call performance and correlate call issues with WAN performance for Cisco and Avaya calls

Nathan DAuthor Commented:
Yep, it is the host to 2 VMs on it's own local storage.

I have tried the renaming state.db but unfortunately it hasn't helped.
Nathan DAuthor Commented:
We're at 22 hours in the office and I just cannot fix this thing. Any assistance would be greatly appreciated!
Peter HutchisonSenior Network Systems SpecialistCommented:
Have you tried rebooting it into single user mode so you have some sort of access?
https://support.citrix.com/article/CTX116019 (steps 1-6).
Nathan DAuthor Commented:
After barrelling through many, many support hoops, we got hold of some exceptional people at XenServer support. After many hours of messing around, the solution ended up being:

"xapi has the ability to read and manipulate the hidden PCI devices. However, xapi expects any hidden PCI device addresses to be specified with the domain, i.e. xxxx:xx:xx.x

The PCI address mentioned in extlinux.conf file was in the format xx:xx.x , however, it should be in the following format : 0000:xx:xx.x .After making the change and rebooting the server, everything got connected,"


Something so small, but so deeply buried. Thanks to all who assisted.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.