Help  deploying remote desktop connection shortcut on all users desktops

Rudia Plaga
Rudia Plaga used Ask the Experts™
on
I am trying to create a GPO to deploy the remote desktop connection shortcut(mstsc.exe) on all users desktops on the domain.

This is what I have:
I went into system32 and made a copy of the mstsc.exe file.
I then pasted the mstsc.exe into a share that I have on my C drive on the domain controller.
The permissions all the way through the share are everyone and domain users.
I'm starting the GPO at the root of my domain it is configured as a user policy
I am running gpudate on the DC & the client workstation.

I have included screenshots of the configuration.

I have never done this before, can someone assist me with this configuration. I will provide any additional information you may need.
Thank you.




Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Why don't you copy the configured file (saved as .rdp) itself to the desktop instead? The .RDP file is already defaulted to start correctly on all Windows PC since XP.
You could even write your own program, to actually CREATE the file on the desktop which could fill in the correct username even (.rdp files are basically text files)

Author

Commented:
Thank you very much. Forgive me for my ignorance, I just started learning this 2 days ago. Can it be done the way I was trying to configure it? Can you just tell me what is wrong with my configuration.
Thank you again.

Commented:
My feeling is (since I don't have all the facts available), yes, your method will work (though you're missing only the fact that your link is pointing to a local C:\drive of the AD server, which the shortcut ending up on the users desktop can't find, point it to the network folder, or copy the file to the users hard drive).
However, In most cases, you want to direct users to the correct server, and setup the correct options. Your way will end up having the user filling in all the info, setting all the options (which might all introduce errors, and hence, more work for you to solve).

Author

Commented:
Thank you .Okay, your saying that I need to use the UNC path instead of the local path. Let me try to fix it. If it doesn't work i will send you a new screenshot of what I did.
Thanks.

Author

Commented:
Thank you. Okay I have it working a little bit It. It is deploying the the RDP to the desktop, but it's not the displaying the way the the supervisors want it done. My office is closing now. I will make a new screenshot on the client workstation describing the way they want it done. I will post in the morning.
Thank you so much.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial