Wrong IP Address on Ubuntu?

Sheldon Livingston
Sheldon Livingston used Ask the Experts™
on
I have just configured a LAMP on my 10.1.1.x network.

The LAMP hits the Internet but shows an IP address of 192.168.0.109/24 (eno1).

Cable (Arris) modem is providing DHCP.

How is it possible for this to happen?  I'm thinking that I want the LAMP to have a 10.1 address.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
David FavorFractional CTO
Distinguished Expert 2018

Commented:
10.1.1.x is a nonroutable network. Meaning no one outside your LAN or WAN will see this address.

192.168.0.109 is your upstream, public IP which can be seen by everyone.

To say another way 10.1.1.x is what you see.

192.168.0.109 is your Google Fiber address (based on introspecting your IP) which anyone can see.

Now then. Whether or not anyone can connect to your LAMP Stack running on 10.1.1.x is an entirely different question.

If you have challenges connecting... which you likely will... open another question about this.

Tip: LAMP Stacks serving content to visitors should run on a public server, unless you have multiple IP providers + a backup generator, so your site(s) stay online, independent of network outages + power outages.

Check pricing of OVH + OVH imprints/brands (SoYouStart + KimSufi). Prices start at $5/month for dedicated servers.

This will give you a good foundation to build public LAMP Stack based sites.

Since your just getting started, you're welcome to PM me + we can book a Skype call. Likely I can provide you some tips to save you time.
Sheldon LivingstonConsultant

Author

Commented:
Sorry David... 192.168.0.109 falls into the non-routable space of 192.168.0.0 - 192.168.255.255.

https://en.wikipedia.org/wiki/Private_network
David FavorFractional CTO
Distinguished Expert 2018

Commented:
192.168.0.109 shows to be owned by Google Fiber.

If you're saying you don't have Google Fiber as your ISP than something's badly wrong + you should contact your ISP for further assistance, as they've assigned a wrong IP to your account.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

David FavorFractional CTO
Distinguished Expert 2018

Commented:
https://www.iplocation.net - IP ownership tester.

How Google routes packets is a different matter. They may route 192.168.0.109 through their infrastructure.

First question to answer is if your ISP is or isn't Google Fiber, so you know you have a correct upstream IP.
David FavorFractional CTO
Distinguished Expert 2018

Commented:
Next you can use the mtr command to provide a realtime view of packet flow, for further debugging.
Sheldon LivingstonConsultant

Author

Commented:
192.168.0.109 is a non-routable ip address.
David FavorFractional CTO
Distinguished Expert 2018

Commented:
You still haven't answered if your using Google or not.

If you are using Google, you have another problem.

https://fiber.google.com/legal/accepteduse/residential/ which specifically states you can't run any commercial servers using their IP.

The word commercial in this context means any listening servers - Apache, SMTP, IMAP4, anything listening.

I know on my Google Fiber connection, they block all ports listening, so the only way to run a LAMP Stack using a Google Fiber IP is to run an ssh proxy for your connection.

Way faster speed to use a dedicated server.
Sheldon LivingstonConsultant

Author

Commented:
192.168.0.109 is a non-routable address

https://www.lookip.net/whois/192.168.0.109
JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018

Commented:
shows an IP address of 192.168.0.109/24 (eno1).  Cable (Arris) modem is providing DHCP.

The Arris modem (I had one here) has a default internal subnet of 192.168.0.x  .  It will have an external IP address whatever the ISP assigned. That is how it has been set up and you need to access the Arris setup to change it. This is independent of Google Fiber.

I get the ISP to bridge my modem (done) and then use a hardware router to set the internal addressing to whatever I want.

My Arris modem was changed out to a Hitron modem but it works the same way.

I suggest you implement your own router to facilitate your own setups.
Sheldon LivingstonConsultant

Author

Commented:
Thank you John.

The ARRIS was reconfigured years ago when I obtained it.  Any other device logging into my network gets a 10.1.1.x address.

Only issue is with this LAMP.
JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018

Commented:
Yes, Sheldon, the Arris can be reconfigured for its internal IP. I agree with that. I use my own router for my own sanity and simplicity :)

The ARRIS was reconfigured years ago when I obtained it.  Any other device logging into my network gets a 10.1.1.x address.

I don't understand with the device in question stays with 192.168 addressing. I am still looking (but not with much success yet
Sheldon LivingstonConsultant

Author

Commented:
So I'm guessing that I'm not seeing the Arris as the issue.  I really don't want to get a router and set it up just for the sake of the LAMP when everything else works with the Arris.
JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018

Commented:
I am not sure about the following but some of the information appears to apply to you. Look at the Answer post part way down.

https://unix.stackexchange.com/questions/219654/cannot-access-lamp-web-server-on-ubuntu-server-14-04
Consultant
Commented:
Ugh... I had a "rogue" DHCP server on the network.  Fudge... I thought I had disabled it.
yo_beeDirector of Information Technology

Commented:
Solid catch

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial