Internet Explorer does not save passwords

Robert
Robert used Ask the Experts™
on
After joining a workstation to a new domain, IE will no longer prompt to save passwords for any website.  All options in the AutoComplete Settings are checked (none are greyed out).  I checked the GPM, and the only GPOs that affect IE are setting the homepage, and adding a server to the trusted intranet zone.  Roaming Profiles are enabled, as well as folder redirection for Desktop, Documents and Favorites.  IE loads websites, can login to secured sites without issue, and functions normally.

Server is Windows 2016
Affected workstations are Windows 7 and Windows 8
Internet Explorer is at ver 11

Any help is appreciated.  Thank you.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
RobertSystems Administrator

Author

Commented:
Hello, and thank you for the response.  I did a bit more digging, and it appears that only certain websites will not save the password.  For example, I tested the following websites to see if IE would give me to option to save the password:

Evernote - yes
LogMeIn - yes
Slickdeals.net - yes
Microsoft - yes
AOL - yes

Dropbox - no
Gmail - no

Since the problem appears to be site specific, how can I verify that the website itself it preventing the save password option, and not some random issue, such as the website is not trusted or the website does not satisfy some IE requirement?
Does chrome have the same issue?
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

RobertSystems Administrator

Author

Commented:
I have not tried a different browser yet.  We are having the password issue with an "IE-approved" website.  So while we can use Firefox/Chrome with the website, it is only technically designed to work with IE.

I will try and report my findings.
RobertSystems Administrator

Author

Commented:
I tested both Dropbox and Gmail using Firefox v63, and in both instances, it prompted to save my password.  So this still appears to be an IE specific limitation.

Any other ideas I can try or investigate?
What happens if you go to add/remove programs and select IE then uninstall. Does it give you option to repair.If so choose repair.
Oh. forgot to ask if IE is set to default browser?
RobertSystems Administrator

Author

Commented:
After checking out the HTML code on a few websites, I discovered that they are using autocomplete=off to prevent IE from saving the password.  An excerpt of code from one of the websites:

<input id=DEALER-WSLXloginPasswordInput autocomplete="off" name="b64Pwd" size="10" type="password">

This is further explained in the URL that @joinaunion posted at the top of the thread.

-Robert

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial