We help IT Professionals succeed at work.

Exchange database copy error

Barry Fields
Barry Fields asked
on
183 Views
Last Modified: 2018-12-07
I have just deleted and recreated a database on exchange 2016. When I try to add a database copy to the second server in my DAG I get the error network path not found. Please help
Comment
Watch Question

Hayes JupeIT Director
CERTIFIED EXPERT

Commented:
Hi,
     When you delete a database, the database files (edb etc) are not deleted, this has to be done manually.
So if you have recreated the database with exactly the same name - this is what I would check first.

Other than that - could you provide more detail on the exact steps your executing and the associated error. (and associated errors from the event log at the same time)
Daryl GawnSenior Infrastructure Engineer
CERTIFIED EXPERT

Commented:
check the location of the logs  and the database eg E:\Database\DatabaseName\DB.edb and E:\Database\translogs\ on the original server and see if the same path exsists on the server you are trying to create the database copy on
Barry FieldsIT manager

Author

Commented:
I am getting the following error;

The network path was not found.
    + CategoryInfo          : NotSpecified: (:) [Add-MailboxDatabaseCopy], IOException
    + FullyQualifiedErrorId : [Server=XXXXXXXX,RequestId=f7b56b74-a21b-48cf-90ea-667207ed287b,TimeStamp=11/20/2018 8
   :01:52 PM] [FailureCategory=Cmdlet-IOException] B5CA032F,Microsoft.Exchange.Management.SystemConfigurationTasks.Ad
  dMailboxDatabaseCopy
    + PSComputerName        : xxxxx.xxxx.com
Hayes JupeIT Director
CERTIFIED EXPERT

Commented:
ok, first port of call is to check both my comment and what daryl has said - both of which may be the issue.

The event logs may also have more detailed information.
Barry FieldsIT manager

Author

Commented:
Sorry, the database paths are the same on both servers as is the path for log files. The log files were deleted from the original database.
event-id-1006.rtf
event-id-4113.rtf
Hayes JupeIT Director
CERTIFIED EXPERT

Commented:
log files and the database?

those attachments don't appear to be in a readable format sorry mate.
AmitIT Architect
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
Wait for sometime and then try to add copy again. Check remote registry service running on destination server.
Barry FieldsIT manager

Author

Commented:
Barry FieldsIT manager

Author

Commented:
OK Amit
Barry FieldsIT manager

Author

Commented:
I waited overnight restarted the remote registry service and I am still getting the same error
Barry FieldsIT manager

Author

Commented:
AmitIT Architect
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
Barry FieldsIT manager

Author

Commented:
i am seeing an additional error when i go into the ecp and try to make any change with regards to the DAG
dag-error.docx
SysToolsData Expert - Recovery,Backup,Migration

Commented:
Barry FieldsIT manager

Author

Commented:
I already restarted the remote registry service on both servers in my DAG, problem still existed. I called Microsoft tech support and they solved this issue. I will post what was done once i get their report
IT manager
Commented:
This problem has been solved!
(Unlock this solution with a 7-day Free Trial)
UNLOCK SOLUTION
AmitIT Architect
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
pls share the solution, so others can be also benefited. thanks
Barry FieldsIT manager

Author

Commented:
Guys , MS has yet to give me the writeup, this is really my fault for not forcing the issue before close of the ticket. I may not get the actual solution in detail, from them. I do know that the DAG was disabled in the process, that's about it. Amit you were very helpful, as usual.
Barry FieldsIT manager

Author

Commented:
OK the short story on this issue was that the database copy was added  with the  database copy with Configuration Only switch