Enable insecure guest logoons on client needs to be Enabled??

Windows 10 Pro Client can't access files on workstation with Guest allowed on shares.
Fix was to change Enable insecure guest logons on the client via gpedit from Not Configured to Enabled.
It appears the description of this setting says it would be fine if it were Not Configured (which is the default).
Has something changed?
LVL 27
Fred MarshallPrincipalAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Windows 10 Pro Client can't access files on workstation with Guest allowed on shares

Normal behavior.   I think your change above changed networking to Private and that does allow access.

In V1803 or beyond, check the NIC settings in Windows Settings, Network.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Fred MarshallPrincipalAuthor Commented:
The networking on the client wasn't Private, if was Public.  One of the things we check when access doesn't work - but must have missed.
So, the change mentioned didn't cause it to go to Private.  It was still at Public when I re-checked it just now.
AND, according to its description, it should not have any effect in going from Not Configured to Enabled so, nor vice versa.
I fixed it with secpol settings in that there was no other apparent way to change to Private.  The normal settings didn't have the options showing - only Metered Connection.
JohnBusiness Consultant (Owner)Commented:
This setting here.  Click in the Network icon, then Properties of your NIC settings. This come up.

Public - Cannot access files, Private - Can access files.

Windows 10 Network Setting
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

JohnBusiness Consultant (Owner)Commented:
Also make sure in Advanced Network Options that File and Print Sharing is ON.
Fred MarshallPrincipalAuthor Commented:
Thanks!
JohnBusiness Consultant (Owner)Commented:
You are very welcome and I am always pleased to help
Fred MarshallPrincipalAuthor Commented:
I said:
"The normal settings didn't have the options showing - only Metered Connection. " 
So the familiar Public / Private selection was not available.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
file sharing

From novice to tech pro — start learning today.