TLS NEGOTATION FAILED FOR EMAILS SENT FROM GMAIL TO EXCHANGE 2013

My Exchange server is not receiving emails from GMAIL. I ran a checktls report for receiving emails and the gmail sender gets an error- "TLS Negotiation failed: generic::failed_precondition: starttls error (0): protocol error"
A test on checktls fails with errors:
-Cannot convert to SSL (reason: SSL connect attempt failed)
-Cannot proof email address (reason: MAIL FROM rejected)
I removed the IP Blacklist providers, and antivirus and that did not help.
Just not sure how to troubleshoot further and resolve.
I use a wildcard certificate in Exchange could that be the issue?
Help will be appreciated.
Steve
Steve WagnerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Looks like you may have forced TLS on your incoming MTA (Exchange) + it's somehow misconfigured.

Change your TLS setting to preferred rather than forced TLS. This will let you receive email while you debug the problem.

You can use the openssl command line tool to test + debug your connection.

The openssl command line tool gives correct answers to problems, so there's zero guessing about the real problem.
Steve WagnerAuthor Commented:
Thanks David,
As soon as I remove the TLS Authentication from the Default Frontend Receive Connector the Gmails come in.
Steve WagnerAuthor Commented:
David,
I resolved the issue by reapplying the SSL certificate to the Default Frontend Receive Connector on my server using the following Exchange powershell commands:

Get-ExchangeCertificate    (to identify the SSL certificate thumbprint)

$cert = Get-ExchangeCertificate -Thumbprint 6118939F03CDF30147BBC708C8EECC1CCDB02A26  (my certificate thumbrint)

$tlscertificatename = "<i>$($cert.Issuer)<s>$($cert.Subject)"

Set-ReceiveConnector "EX2013\Default Frontend EX2013" -TlsCertificateName $tlscertificatename

I then re-enable TLS authentication on this receive connector and restarted the MSExchangeFrontEndTransport service.

Thanks
Steve

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.