Excel crashes when Mac goes to sleep

tmartin40
tmartin40 used Ask the Experts™
on
I have a group of four users experiencing the same problem.  They are all using Macs running High Sierra and Office 365.  Additionally, these macs are connected to a Windows 2012 R2 server for file sharing.  Although the problem happens periodically in other applications the primary issue is when they are using Excel.  

User can open an Excel file from the network share and work on it and save it unless the computer goes to sleep.  If, for whatever reason, the computer is idle with the file open and goes to sleep, the file becomes corrupt somehow and they cannot save it.  I've tried to save it back to the share and to other locations (i.e. desktop) but it does not work.  Basically the file will not save anywhere.  As long as it is open, they can continue to work in the excel document, they just can't save it.  They receive an error similar to the attached image.Excel Error
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
First thing to do with all Macs connecting to Windows shares is to turn off writing directory stores to network shares.
Open Terminal.app and run the following command in each user's account:
defaults write com.apple.desktopservices DSDontWriteNetworkStores -bool TRUE

Unfortunately, when they idle out, they disconnect improperly.  You lost the actual network share connection within Excel.  Try to do a Save As, instead of a Save.  Do not edit files on a Windows share from Mac, because Apple threw out SAMBA and rewrote their SMB stack because they didn't want to be saddled with GPLv3.  Apple's version is seriously broken and not fully compatible with Windows SMB.

Author

Commented:
When the save failed but the file was still open, I tried save and save as.  Tried saving it (using save as) to different locations.  It just didn't work.  As I am not a Mac guy, I am a little confused.  Are you saying that running "defaults write com.apple.desktopservices DSDontWriteNetworkStores -bool TRUE" from terminal on all user machines (there are four of them), this will solve the problem?

I had someone else tell me to install "Automounter" and this would solve my problem.  Have you ever heard of this?
No, the DSDontWriteNetworkStores will mainly prevent Mac user contention when accessing the same folders, so they don't try to write the .DS_Store folders at the same time.

Automount is a built-in (unix) function

https://useyourloaf.com/blog/using-the-mac-os-x-automounter/

Author

Commented:
okay thanks.  I appreciate the help.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial