Word 2016 "There is insufficient memory or disk space. Word cannot display the requested font."

Word 2016 "There is insufficient memory or disk space. Word cannot display the requested font."

I am getting this error on a newly upgraded HP Z840, we upgraded from Win 7 pro to Win 10 Pro, also Office 2010 to Office 2016. Its the same shared file system however we did upgrade servers to 2016 and completely renamed the domain and nuked the old one. I dont see any permission issues with the old file system and I have tried every internet remedy. Rename .dot, check permissions on font folder, make sure document is not protected. It does not seem to do the same thing on newly created files.

This is my last attempt before contacting 365 support.

Thks...
kevin taylorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sam Simon NasserIT Support ProfessionalCommented:
do you face this issue on your computer only or other computers?
try repairing office, removing and reinstalling it again.
also try this command in administrator mode
sfc /scannow

Open in new window


also, some people mention that this is a fonts issue. so when installing a font, do not double-click it as this will install the fonts in your profile only (C:\Users\username\AppData\Local\Microsoft\Windows\Fonts), instead, right-click the font and select install for all users.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Sam Simon NasserIT Support ProfessionalCommented:
you can also try rebuilding your font cache, as mentioned here https://www.thewindowsclub.com/rebuild-font-cache-in-windows
Owen RubinConsultantCommented:
You checked permissions, but did you check ownership of the file that is not working? Maybe a problem of ownership and not simply permissions.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

kevin taylorAuthor Commented:
Okay so a little more history, 2 weeks ago 2 companies separated and I was hired to move their servers and start a new domain, So I nuked an existing domain and started a new, physically removed PC's from the old domain and joined the new one. Took a  copy of the old file system and restored it to the new servers. At the time PCs were Win7 with Office Pro 2010. Part of the job was to upgrade users from the old OS and Office to Win10 and Office 2016. All of the existing PCs with old OS and Office do not have this problem, only the ones I have upgraded.  With that said I just finished a  Win10 upgrade and have not yet upgraded office so this device is still 2010 but had the same error.

I will try above suggestions.
kevin taylorAuthor Commented:
Simon rebuilding font cache did not help. I did notice some files, will open but majority dont.
kevin taylorAuthor Commented:
trying scannow as we speak
kevin taylorAuthor Commented:
Okay so got it resolved. Could Microsoft make things more difficult. For me a combination of things, permissions and rebuilding font cache, both steps are required.

First correct ownership of the font file as suggested by Owen, then rebuild your font cache.

Run Powershell commands with elevated permissions.

Running these 2 lines fixed it for me, as it restored the permissions on those fonts.

Get-acl C:\Windows\fonts\arial.ttf | Set-Acl -path c:\windows\fonts\*.*

Get-acl C:\Windows\fonts\arial.ttf | Set-Acl -path c:\windows\fonts

Problem solved. I did try these individually and none worked on their own it took a combination in the order above..

Thank you fellows.. Kevin
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.