Mac OS Mojave: Network control panel config issues -- delays when applying

In Mac OS Mojave, I'm contending with lengthy delays in applying changes to network interfaces. Sometimes 60 seconds to apply a change to Service Order (i.e. move Ethernet ahead of wifi) or to configure a Static IP address.

The Network Pref window also appears blank when first loaded and takes a full minute to populate. (I have many network configs in my list)

When preparing, testing, and troubleshooting networks (a big part of my job) this is really bogging me down. Never saw this before with any previous release. Always in the past changes are instant with no "apply" delays.

This symptom continues after installing 10.14.2. I've also tried:

- Resetting PRAM
- Resetting SMC
- Reinstalling MacOS using Recovery Mode
- Removing all 3rd party apps that could interfere
- Booting with Shift key down - no performance improvement

My last move is to wipe the machine and recover from backup, discarding the network config option. However since I have so many VPN configurations this is a really big deal.

I'm hoping someone has some other suggestion.
LVL 1
d4nnyoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Operating Systems

From novice to tech pro — start learning today.