Centrally adjust "Manage group email" settings

I have set up an O365 group primarily for use of the shared calendar and its utility on our office SharePoint site.  I have set members of this group who are allowed to submit events to the calendar.  Nobody in the group needs to receive invitations when an event is submitted.  I know that individually each user can adjust their settings for the group, but is there a way for me as group owner (and O365 admin) to centrally set "Don't receive any group messages" for all members of the group?  To be clear, "Send all group conversations and events to members' inboxes" is unchecked.  Desired O365 settings for all members of the groupThanks!
Dan CarpIT DirectorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Vasil Michev (MVP)Commented:
You can toggle the AlwaysSubscribeMembersToCalendarEvents and AutoSubscribeNewMembers (together with the SubscriptionEnabled one). But the last time I tried this, it didnt yet work as expected. And you cannot apply it retroactively.
Dan CarpIT DirectorAuthor Commented:
Thanks Vasil!  I presume when you say that it didn't work as expected, you mean that you were unable to toggle the value at all...

PS U:\> Set-UnifiedGroup -Identity "GroupName" -AlwaysSubscribeMembersToCalendarEvents $false
A positional parameter cannot be found that accepts argument 'False'.
    + CategoryInfo          : InvalidArgument: (:) [Set-UnifiedGroup], ParameterBindingException
    + FullyQualifiedErrorId : PositionalParameterNotFound,Set-UnifiedGroup
    + PSComputerName        : outlook.office365.com

Open in new window


Am I missing something?
Vasil Michev (MVP)Commented:
It's a switch parameter, the correct syntax is:

Set-UnifiedGroup -Identity "GroupName" -AlwaysSubscribeMembersToCalendarEvents:$false

Open in new window


It simply didnt seem to have any effect.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Dan CarpIT DirectorAuthor Commented:
Thanks for the info and the syntax fix!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.