Avatar of purplesoup
purplesoupFlag for United Kingdom of Great Britain and Northern Ireland

asked on 

Weird ASYNC_NETWORK_IO error happening in SQL Server on VM

We create VMs with the latest build of our code on. One VM has a weird ASYNC_NETWORK_IO error when running a SQL SELECT statement. It isn't on any other VM.

I have tried googling for the error - clearly something failed to start or get set when this VM was created.

Just for peace of mind it would be really useful to know what might be the cause of this and if there is some setting I can adjust to fix it.

The symptom is that a SQL SELECT statement just seems to time out with this ASYNC_NETWORK_IO error, but the strange thing is that it must have somehow returned some results because it then blocks an INSERT statement that has used the results of the SELECT statement.

Everything necessary for the application is on the VM - the ASP.NET application and the SQL Server database so there is no actual network access outside of the VM.

There is no antivirus running on the VM either which is one possibly cause I came across.

The server is Windows Server 2016 and the SQL Server is 2016 also.

I've attached a picture of what is happening.

Just to repeat this doesn't occur on any other VMs with the same software on.

I have tried restarting IIS and restarting the VM.

The VM is Hyper-V.

User generated image
Microsoft SQL ServerNetworkingASP.NETMicrosoft Server OSVirtualization

Avatar of undefined
Last Comment
Avatar of E C
Flag of United States of America image

Some thoughts:

Is your database set to 'auto close'? (default is 'False')

Is your VM host overprovisioned? (too much ram or cpu allocated to all of the VMs) - remote into the host (not the sql vm) and check

And the flip side of that - did you allocate enough ram and cpu to this sql vm? how does it compare to the other sql vm which does not have this IO error?
Avatar of purplesoup
Flag of United Kingdom of Great Britain and Northern Ireland image


Sorry for the delay in replying.

Both VMs have a autoclose false.

I've checked OS version, RAM, CPU, free disk space etc - all pretty much match. There are slight differences in installed memory (7.03 GB vs 6.76 GB) but that is it. I've tried going through different SQL Server settings - all match up ok.

Are there some sort of network settings that might be affecting it - how can I get them to compare?
Avatar of purplesoup
Flag of United Kingdom of Great Britain and Northern Ireland image

Blurred text
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Microsoft SQL Server
Microsoft SQL Server

Microsoft SQL Server is a suite of relational database management system (RDBMS) products providing multi-user database access functionality.SQL Server is available in multiple versions, typically identified by release year, and versions are subdivided into editions to distinguish between product functionality. Component services include integration (SSIS), reporting (SSRS), analysis (SSAS), data quality, master data, T-SQL and performance tuning.

Top Experts
Get a personalized solution from industry experts
Ask the experts
Read over 600 more reviews


IBM logoIntel logoMicrosoft logoUbisoft logoSAP logo
Qualcomm logoCitrix Systems logoWorkday logoErnst & Young logo
High performer badgeUsers love us badge
LinkedIn logoFacebook logoX logoInstagram logoTikTok logoYouTube logo