Open File - Security Warning for programs on network shares

Josh Rogalski
Josh Rogalski used Ask the Experts™
on
We have several website and application links stored on a Windows network share.  Recently when we experienced a security warning that "We can't verify who created this file.  Are you sure you want to run this file?".  I tried adding the server to the "intranet" zone and the share but it didn't change anything.  This appears to happen to all our users.   Can anyone suggest a fix that I can apply through group policy?
security_warning.jpg
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Fethi ABASSIWindows system administrator

Commented:
you can disable it via GPO by adding the below registry Key
 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\yourdomain\file   DWORD   1
Josh RogalskiNetwork Technician

Author

Commented:
Interesting Fethi, is this normal behavior you think?  It would seem GPO would have a predefined setting for this but I see nothing.  I am always a little uncomfortable applying registry changes via GPO but if this is the only fix I will apply it.  Thank you for your contribution!
Network Technician
Commented:
I ended up finding that if I set "Automatically detect intranet network" to "checked" it would then successfully read all the links stored on the server I had added to the "intranet" group.  As long as those links were run from the UNC path and not a drive letter share (so \\servername\folder\link instead of F:\folder\link) it took the message away.  I Was able to set that "automatically detect" setting in group policy.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial