Mac OS Mojave: SOCKS Proxy keeps turning on by itself.

On random Mac OS devices running Mojave (any version):

SOCKS proxy is automatically re-enabled after every reboot/power cycle.

By default, no proxy settings should be configured.

The proxy is configured with: localhost port 8080

This causes all email apps to go offline intermittently. Also it causes all web browsers to become "unable to load" any web page.

Once the proxy is manually disabled in Network Preferences; everything works fine.

How do I disable permanently?
Why does the SOCKS proxy auto enable after the device is power cycled?
TheoWuIT ConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Davis McCarnOwnerCommented:
You might want to see what the free trial of MalwareBytes finds (it's a common trick used by cybercrooks):
https://www.malwarebytes.com/lp/sem/en/mac/index.html
TheoWuIT ConsultantAuthor Commented:
Hi Davis,

We have done so and MalwareBytes did not find anything. Thank you for your input.
Davis McCarnOwnerCommented:
And what antivirus software is running on them?
5 Ways Acronis Skyrockets Your Data Protection

Risks to data security are risks to business continuity. Businesses need to know what these risks look like – and where they can turn for help.
Check our newest E-Book and learn how you can differentiate your data protection business with advanced cloud solutions Acronis delivers

TheoWuIT ConsultantAuthor Commented:
Trend Micro on the older Macbook Pro (mid 2012)

No anti-virus, except for Malwarebytes yet on the brand new iMac. - We are still setting up.

On the iMac - The Proxy was already enabled after setting up the Mac for first time use.
Davis McCarnOwnerCommented:
Are you using a different browser other than Safari?
And, are you using an admin login when you disable the proxy?
TheoWuIT ConsultantAuthor Commented:
Yes we have tried on Chrome, Firefox, and Safari.

We have tried 2 different admin profiles on each system.

The proxy will stay disabled until the system is rebooted, then it comes back automatically.
Davis McCarnOwnerCommented:
I did not get any real hits on Mojave having a proxy problem.  Is there any chance there used to be a proxy and the DHCP server, even if it was a component of the antivirus software, and that is handing it back?  Turn the proxy off, disconnect from the network, reboot, and see if the setting holds.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Operating Systems

From novice to tech pro — start learning today.