Link to home
Start Free TrialLog in
Avatar of Paula Wong
Paula WongFlag for United States of America

asked on

VMware Hypvervisor Error - Fatal Error (Not found)

VMware Error

Loading Vmware Hypvervisor

I was trying to load the iso disk with the dban file and below is what I get:

Configuration error while prashing /boot.cfg
Fatal error: 15 (not found)

I don't have a bootable vmware image on the CD except the dban file.  Does anyone know what might be causing this?
Avatar of Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Flag of United Kingdom of Great Britain and Northern Ireland image

Re-download the iso from VMware.
Avatar of Paula Wong

ASKER

Hi Andrew,

I still get "Configuration Error while parsing /boot.cfg
Fatal error: 15 (Not Found)"

I just downloaded the following ISO file from VMware:

VMware vSphere Hypervisor (ESXi ISO) image (Includes VMware Tools)
2018-10-16 | 6.7.0U1 | 314.34 MB | iso

Do you know what the issue may be?

thank you!
Paula
Hi Andrew,

It looks like it might be the ISO burner software that was causing the issue.  I tried the bootabe disc on different laptops and it wouldn't boot for it so I decided to reburn the image using a different ISO burner software and that seemed to work.  I reburned the Dban software too to reformat the drives and it is going but it is slow (might be because it is a 4TB drive :)).

Thank you so much.  I"ll update once they are done.
Thank you Andrew, it worked.  I was finally able to reformat the drive and re-load vsphere.

What is interesting is that I used the vsphere 6.7 Iso to re-image the drive and the installation went fine and was pretty quick.

After it is done, it booted up and gave me a prompt/display of vsphere Esxi 5.5.0 which is what I had before (with the same static IP too).

What happened to my vsphere 6.7?  

I went to the GUI of of that IP and was able to download the vpshere 5.5 client.  Can I upgrade to vsphere 6.7 from here?

Second switch is, I am planning to load several virtual machines here and one say is a Windows VM.  Will this new VM pick up a DHCP IP from local network from the vsphere  ESXi server?

If that is all that I'm planning on running, do I need to upgrade the license on it too? It says license has expired.  I am not running anything more than just some test Virtual Machines.

Thank you in advance.
No direct upgrade paths from 5.5 to 6.7, I'm afraid.
Ok, thank you Andrew!

So how I can erase 5.5 and 6.7?  I thought that is what I did by using dban and then loaded the 6.7 iso image.
Any disk wiper software will erase the disk, if that's where you have installed ESXi.

5.5 and 6,7 cannot co-exist.
Hmm, ok Andrew.  I'll try this. thank you!
Ok, Andrew - I wiped all 4 disks' using dban and then re-installed Vmware 6.7 one one of the two 2TB drives (the other two are 2TBs and 4TBs) because I want to use the one of the 1TBs drives as a base drive for the operating systems.  The installation went fine.

Now when I reboot, it doesn't boot from it and says I get a message that says there is a Non-System disk error.  

I have a HP AHCI Sata Controller  and there is 0 Logical Volume and not Drive Array configured as per the HP Dynamic Smart Array, which is fine because all 4 disks are standalone at the moment.  

I think the one disk where I have Vmware 6.7 installed is not set as a bootable disk.  is there a way for me to set that disk as a bootable disk.  Didn't see how this can be done via the HP Dynamic Smart Array Configuration utility.

Thank you in advance!
LN
You will have to set that in the BIOS of the server.

Not sure why you are not installing to USB or SD card, and leave all the disks for your datastores and VMs.
I did try that but in the BIOS setting it points to the controller as a whole and don't see where to set it boot from one of the drives connected to the controller.

I don' t have a SD Card and installing to USB would mean that I have to leave that USB drive connected, which may inadvertently removed at times, resulting in not being able to boot if this happens.

Installing this way is similar to install Windows on C Drive and leaving the data on the D, E..drives..etc.

Do let me know if there is any other suggestions to try to boot from this drive.
You need to check and configure so the server can boot from the drive you have installed it on, as the current default drive as per BIOS configuration, is not the drive with ESXi boot loader on.
Ok, I checked the BIOS and tried several settings.

From the BIOS, the option I can choose is the PCI HP Smart Storage Controller, which then have 4 different drives attached to this PCI controller.

I used the HP Smart Storage Intelligent Provisioning Storage and even tried creating 1 logical drive from it using two drives (RAID 1) and tried using the HP ProLiant MicroServer Gen8 to do the software installation where it asks you what source media to install from and I was able to select the VMware ESXivSphere custom image setting and I chose the USB DVD drive (where my boot VMware 6.7 ISO image is loaded from) and tried rescan but it will not detect the USB bootable DVD/CD image.  

The USB DVD/CD image is working fine because if I just the bootable VMware 6.7 iso image there, it will boot up and go through the installer (which I did already) and it will asks me to choose which drive (out of 4 drives) that I have.  What is interesting is that it doesn't see the 1 logical drive that I created earlier using the HP Intelligent Provisioning software.

So I am at a lost how to go about getting VMware 6.7 to install and be able to boot from it. (Installation is fine - just booting from it after it is done installing).

Thank you!
if you have a Smart Storage controller, it will be expecting you to create an Array/Logical Drive, and you then install ESXi onto that array.

BUT, the Storage Controller on the MicroServer is a FakeRAID software controller which is not compatible with ESXi.

I've just noticed you state - HP ProLiant MicroServer Gen8....

this has internal USB flash drive and also internal microSD card for use with installing ESXi.

But to use HPE Intelligent Provisoning with MicroSD card, you MUST use a HPE MicroSD card.

So I would just stick a USB flash drive in, and install ESXi to this. (and leave all disks for datastores), but NO RAID.

You'll need another supported Storage Controller

Also note that ESXi 6.7 is not supported or certified for the Microserver Gen8 (up to 6.5 U2)
Hi Andrew,

Thank for your suggestion but take a look at this;

There's no real benefit to using USB or SDHC boot for this.

HP Proliant Microserver Gen8: OS on a Micro SD or USB drive a good idea?

https://serverfault.com/questions/723077/hp-proliant-microserver-gen8-os-on-a-micro-sd-or-usb-drive-a-good-idea/723109#723109

A better suggestion? Upgrade the controller?
We've been installing ESXi on USB and SD cards since 2004.

It's a much better idea! that's what ESXi is designed to do,.

and then you can leave all your storage for datastores.

But you've still got an issue which needs resolving with the storage controller, if you want to do real RAID.

As for the link from Stack, it's all foo... and they clearly do not understand ESXi. and the question is about Centos, not ESXi.

ESXi, only reads from the media at BOOT, and then goes memory resident, and then occasionally reads and very few writes to the USB or SD card.

It was designed to be installed as embedded on a SD card or USB flash drive.

It's why servers have a USB flash drive and SD card inside them!
Thank you for your input.

So didn't know there was an internal USB flash drive or didn't see it as an option when loading the ESXi installer.   I will get the ESXi 6.5 u2 but how to I choose or make the internal USB drive as an option to choose instead of the 4 SATA drives that  I have? ( I recall that was the only options available to me to choose from).

thank you!
So didn't know there was an internal USB flash drive or didn't see it as an option when loading the ESXi installer.

if there is no USB flash drive or MicroSD card you'll not see it as a storage option to install to!

 I will get the ESXi 6.5 u2 but how to I choose or make the internal USB drive as an option to choose instead of the 4 SATA drives that  I have? ( I recall that was the only options available to me to choose from).

You select it at installation....when you've insert the correct media!
I see what you're saying.  I have many spare TAB and Patriot 8GB USB flash drives, would 8GB work and would those be compatible?

In the event if there is a failure on the USB , I can easily re-instsall ESXi again and still use the Datastore drives (assuming those are working just fine).

thank you!
Yes, a good quality USB flash drive larger than 1GB should be fine.

In the event if there is a failure on the USB , I can easily re-install ESXi again and still use the Datastore drives (assuming those are working just fine).

That's an option, but why not just backup the ESXi configuration, and then re-install to a new USB flash drive, and restore the config!
Sounds good Andrew!  You're awesome!

Going to try this soon!
Hi Andrew,

Ok, I had a chance to work on this some more and was able to get the VMware ESXi 6.5 iso image and installed my USB flash drive to the Gen 8 Proliant server on the system board.  

It booted up from the ISO image fine and I selected the USB drive for the destination and then it gave me this error:

The system has found a problem on your machine and cannot continue.
Two file systems with the same UUID have been detected.  Make sure you do not have two ESXi installations,

See attached image.

Not sure why it would show this if I select the USB flash drive as the destination.

It could be that I still have the 6.7 version on the other drive but I am not using it.  I may have to go through erase it again using the Dban utility but that would take another full day or so (trying to avoid that) and need to find that disk.

Thank you so much in advance,
Thank you Andrew.  But it will not let me know continue to with the installation.  How do I proceed with this?

Thank you!
did you read the VMware KB ?

follow and input the commands ?
Ok, Andrew.

I went through and spent several hours.  I ran those command and did several things.  Booted up to a point where could load ESXi and create a VM and installed a guest OS with Windows on the drive, which I think had the duplicate ESXi installation. I even made sure that I added all the other drives the ESXi saw as available disks to add to the datastore, which were two left (out of the 4) so I added all of them.  

I took the ESXi installation disk out and rebooted the server and it would not load the ESXi from the internal drive (the only bootable option at this point) or boot at all.  It would go into cycle and try to boot but can't seem to find any sytsem and I would get eh CLIENT MAC ADDR: prompt at the end..

Then, I thought I would try something by taking out 3 of the disks and left only one.  Think that it saw the one drive remaining with ESXi 6.7 so I decided to take that drive out physically and swap with a different one, which didn't have anything installed to make it easier.  The installtion of ESXi 6.5 went fine at that point and finished successfuly and it told me to remove the installation media, which I did. It rebooted and now I keep getting the attached error at boot up in cycle.

I even made sure the HDD C was a a boot option in the BIOS after the CD room but some how it is not seeing the HDD drive there and can't boot from.

What could be wrong?

Thank you in advance,
LN
Sorry forgot Andrew.  Here it is.
Trying agian.
IMG_9729.jpg
Is ESXi (which version) installed on a USB flash drive or SD card?

The version of ESXi must be the HPE version.

The error message is completely normal for a x86 computer not finding a BOOTable device, and is trying to boot from Network.

or BIOS is set to BOOT from Network as first primary boot device.

So this is a HP Proliant Microserver Gen8 which you want to install ESXi on ?

What version do you want to use 6.5, 6.7 ?

and finally WHAT are you trying to achieve by this installation ?
Hi Andrew,

ESXi is installed on the hard drive now with ESXi 6.5 and it is also installed on the internal USB drive, which I left there.

Yes, this is the Gen8 server.

So it should boot  ESXi from either the hard drive or the internal USB drive but none of that is happening I get this error.

The boot from C drive and internal USB key drive is also listed as an option but those aren't showing for some reason.

Just would like to get it boot ESXi 6.5, either from the hard drive or the internal flash drive.

thank you!
Okay proceed as follows:-

1. Remove ALL hard disks from the Server.

2. Remove the USB flash drive from the server.

3. Erase ALL above.

4. Insert USB flash drive.

5. Install ESXi onto the flash drive.

6. Make sure the Server BIOS options are set to BOOT from USB flash drive.

7. BOOT server and check it boots from USB flash drive.

8. DONE.

This confirms you have installed ESXi successfully.
Hi Andrew, thank you for the quick reply.

I'm ok with step 1 and 2 but how do I do step 3 if they aren't in the server?

I can erase the USB flash drive from a different laptop but if I am not going put the hard disks back in the Server (at least not yet), I don't need to worry about erasing the the hard disks yet?

Thank you!
You don't need to erase the disks, put them in later whilst ESXi has booted, and can be erased from within ESXi.
Ok Andrew, I'm using Dban to erase the existing hard drive that I have there and also the internal USB drive.

After the erase is done,  I will remove the hard drive and install ESXi on the internal USB flash drive and will let it boot and see what happens.

Thank you so much!
ASKER CERTIFIED SOLUTION
Avatar of Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Will do. Thank you Andrew!
Andrew has been extremely helpful throughput the entire troubleshooting steps.  Thank you so much Andrew!
Andrew, you're awesome.

This issue is finally resolved and my VWmare is working now on the internal USB Flash drive and the datastore are using the hard drive (at least one for now).  I'll add the rest later but I'm sure this is going t work.

Thank you so much!  You're the VMware Guru!  I appreciate all the help!