Avatar of qvfps
qvfps
 asked on

VCenter 6.5 Could not connect to one or more vCenter Server Systems

I recently tried to check the status of a server which ties into VMWare.  It was showing errors and unable to connect to the VCenter server.   I logged onto the server and tried to connect to VCenter.  Explorer just gives me a certificate error and Firefox allows me to logon but I get the following message on top and it never populates any data.

Could not connect to one or more vCenter Server Systems
https://vcenter-01.ss.local:443/sdk

I have seen quite a few references to this issue on 5.5 but nothing I could find for 6.5

We are running VCenter 6.5 on a Windows 2012 R2. server
VirtualizationWindows OSVMware

Avatar of undefined
Last Comment
qvfps

8/22/2022 - Mon
Scott Silva

Did you try restarting the vcenter server? I have been seeing a lot of errors lately, especially with the html5 client... And be prepared, it seems to get worse with 6.7...

Next try connecting straight to the hosts and make sure they come up ok since 6.5 hosts now have their own web server.

Last resort, disconnect the hosts and reconnect them to the vcenter server, You shouldn't lose anything...
qvfps

ASKER
Thanks for the suggestions.   I rebooted the vcenter server and had the same issue when it came back up.  I am not sure how to delete the servers from VCenter as it never completes loading the data so I can not select them to do anything.
Scott Silva

Try several reboots... Give at least an hour for everything to stabilize...

Check logs for any vcenter related errors.


Worst case... Build a new vcenter server and recreate your infrastucture... Then join each host to the new one... But I would say that is a last resort.
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
qvfps

ASKER
Sorry for the lack of response.   I need permission to work on this server and no one is around over the holidays.
Scott Silva

Rebooting the vserver shouldn't affect the other running servers.
Did you successfully connect to the hosts? https://host-address/ui/#/login
It should be the local credentials usually root and its password.
qvfps

ASKER
I have rebooted the vCenter server itself a couple of times and restarted the services with no change.     I have not tried connecting directly to the host servers.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
qvfps

ASKER
I was finally able to work on this.   I was able to connect directly to the hosts.   Rebooting the vcenter server multiple times did not work and non of the instructions on how to resolve the duplicate entries in the database matched the folders/locations/valid commands etc for our installation.      

I was unable to remove the hosts from the server so I could not re-add them.   I ended up opening a support ticket and spending the afternoon on the phone with VMWare support.   They were unable to resolve the issue without blowing away the database and re-creating it.  Afterwards I was able to re-add the hosts to vcenter.
ASKER CERTIFIED SOLUTION
qvfps

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question