Extract to Excel closes application with a CLR20r3 error

I had this question after viewing Error on startup of mapped network application - clr20r3 and mscorlib..

My situation is different, of course.  My application is written in PowerBuilder and has an "Extract to Excel" option which was working fine.  Now I'm getting the CLR20r3 error as shown in the 3 screen shots of the same error below:
CLR20r3 error....Part 1CLR20r3 error....Part 2CLR20r3 error....Part 3
The application runs remotely using RDS on a Windows 2008 R2 server.  The client computers have recently been updated to Windows 10, but I don't believe that is the root cause of this since this was working for a while after the update.  Frankly, I'm at a total loss, since the program logic for this functionality is straightforward and, frankly, does not leave me with many options.  Basically, due to performance issues, I've programmed this process into 2 steps.  The first step extracts the selected report to Excel on my server under the user's profile into their "documents" folder using a generic file name (e.g. excel001.xlsx).  The second step (which causes this error, since the first step works fine...) is to simply copy the file from the generic saved file on my server to the "redirected" location the client user selected in the "Save As..." dialog box!  Also, just to confuse matters further, "saving" the same report as a PDF file works with no issues!?  Does anyone have any thoughts on this?
Jim KlocksinOwner, Data ArchitectsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Amr AlyCommented:
Hi Jim,

 At client side try to use the windows copy prior to update to windows 10 ..... for example try using win 7 or 8.1

Best regards
Jim KlocksinOwner, Data ArchitectsAuthor Commented:
I appreciate your thought, but all my clients have been upgraded to an extremely "locked down" Windows 10 computer.  Further, I think this question was most likely an over-reaction to my own "lack of access" when I'm using "my" client computer.  When connected using my own administrative userID, I had access to my own local drives (which I block access to for all my clients) and the "Extract to Excel" worked fine.  I had another client (who has a network drive that he's allowed access to) test this as well and his testing pretty much proved out that there is no problem with my application, it's a combination of the restrictions my clients have built into their workstations and the restrictions I've built into my own server for my protection from cyber attacks. Sorry for "jumping the gun", but all this cyber-security stuff makes providing flexible applications more difficult than it should be, but this is the world we live in.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.