Windows 10 Pro Can't remember Power Option

SpaceCoastLife
SpaceCoastLife used Ask the Experts™
on
I have a relatively new (12 months) Dell XPS Workstation running Windows 10 Pro that randomly drops the Power Option I set, which is "Never".
I'm looking for either a fix or work-around?

Ideas anyone?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018

Commented:
About the only thing I have seen is Windows 10 wanting to switch to Airplane mode and I stopped that.

Open cmd.exe with Run as Administrator.

Use:

Powercfg –setactive Scheme_GUID

See the TechNet Article below

https://technet.microsoft.com/en-us/library/cc748940(v=ws.10).aspx

Powercfg /? for help

Once you set the active scheme this way (and assuming Windows 10 Pro) it should stick.
Robert RComputer Service Technician

Commented:
is this a personal computer or a workstation in a managed corp environment? If it is company machine maybe the the group policy setting is over riding the changes you make.

Author

Commented:
It's a personal computer. Running Powercfg -q I see several "critical battery notification" or critical battery action" settings. Are these to be ignored considering this is not a laptop or might it be referring to the battery on the motherboard?
Starting with Angular 5

Learn the essential features and functions of the popular JavaScript framework for building mobile, desktop and web applications.

JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018

Commented:
Just make sure the one plan you want is starred and the rest should be ignored. They are ignored on my machines.

Windows 10 powercfg

Author

Commented:
It is. In my case (Power saver) *.   How do I set:
1. Turn off the display: Never
2. Put the computer to sleep: Never
Business Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018
Commented:
Find the plan you want (Basic Power Options) and select it.

Now open the admin command prompt and use

Powercfg –setactive Scheme_GUID

That will put the star beside your plan.

Then go to Advanced Power options for you plan and set the two options you want.

I do this as I describe and it works just fine.
Robert RComputer Service Technician

Commented:
since this is not a laptop definitely ignore the "critical battery notification" or critical battery action" settings, they definitely are settings for laptop. As the program cant distinguish if this is a desktop or laptop.

Author

Commented:
That's basically what I have been doing. It works for a while, maybe 4-5 weeks. Then for no apparent reason, the setting reset from Never to 1 minute. Go figure!


I did exactly as you recommend. We'll see if it holds.

Author

Commented:
Thanks for responding
JohnBusiness Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018

Commented:
You are very welcome and I was pleased to help you.
Distinguished Expert 2018

Commented:
You wrote: "It works for a while, maybe 4-5 weeks" - so it changes that rarely? So you don't know if this is solved?
Feel free to reopen the question just in case, so your problem can be analysed: power options use registry keys and we can audit what OS component or program changes these and find the culprit that triggers the reset that way.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial