ORA-00838: Specified value of MEMORY_TARGET is too small, needs to be at least 5243264M

hi am geting this error in database 12c in solaris i did this

Enter user-name: /as sysdba

Connected to an idle instance.

 

 

SQL> startup

ORA-00838: Specified value of MEMORY_TARGET is too small, needs to be at least 5243264M

SQL> create pfile from spfile;

 

 

File created.

 

 

SQL> startup

ORA-00838: Specified value of MEMORY_TARGET is too small, needs to be at least 5243264M

Open in new window

chalie001Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

johnsoneSenior Oracle DBACommented:
This is the documentation page that details the error.  You need to scroll down quite a way.

Essentially, it is telling you that the SGA_TARGE, PGA_AGGREGATE_TARGET and MEMORY_TARGET variables are not set up correctly.  As it seems you generated a pfile, if you could post that (in a code block), someone could probably help more.
slightwv (䄆 Netminder) Commented:
If you are unable to locate the pfile you created:
create pfile '/tmp/mypfile.ora' from spfile;

Then post /tmp/mypfile.ora  again, in code blocks and replace anything that you don't want posted on a public website.


More important, what were you trying to do before you started receiving this error?
HuaMin ChenProblem resolverCommented:
Try to manually adjust the value like

SQL> CREATE PFILE FROM SPFILE;
MANUALLY EDIT PFILE & CORRECT MEMORY_TARGET VALUE
SQL> CREATE SPFILE FROM PFILE;
SQL> STARTUP

Open in new window

Mark GeerlingsDatabase AdministratorCommented:
After you do these two steps:
SQL> CREATE PFILE FROM SPFILE;
MANUALLY EDIT (this new) PFILE & CORRECT MEMORY_TARGET VALUE

Open in new window


Your "STARTUP..." command must include "PFILE=[your new pfile location and name]

Slightwv gave you a good way to make that easy:
create pfile '/tmp/mypfile.ora' from spfile;

Open in new window


Then your startup should be:
STARTUP PFILE='/tmp/mypfile.ora'

Open in new window


If that is successful:
CREATE SPFILE from PFILE='/tmp/mypfile.ora'

Open in new window


Then, do a shutdown and another "STARTUP" (with no options) to run from your new spfile.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle12c

From novice to tech pro — start learning today.