Exchange Activesync Partnership Event 1008 - Iphones cant get emails

We recently restored a backup exchange database from 1 week prior due to an exchange corruption (Exch 2010)

Following this the majority of users that have their inbox's on their phone have not been able to connect to Exchange anymore.

I am getting the event 1008 in the Application logs, for "an outdated or corrupted Exchange ActiveSync device partnership"

For most users deleting the phones from OWA and re-adding the account fixed the issue.

But here are two users that I cannot get working no matter what. Have tried deleting the phones from OWA and Exchange MC multiple times, rebooting, disabling activesync/enabling

The users are both iPhone users and the errors they are gettings is "The connection to the server failed" within the inbox, but the weirdest part is that the sent items folder downloads all mail and works fine, can even send emails. Just the inbox gets that error.

Any ideas?
tom_szaboAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

yo_beeDirector of Information TechnologyCommented:
Are you able to access the email via OWA and get to the inbox?
What about Outlook?
tom_szaboAuthor Commented:
Yes Outlook and OWA work fine for that user. Just tried from my iphone and get the same error, but any other mailbox accounts seem to work completely fine.
yo_beeDirector of Information TechnologyCommented:
I am stumped
tom_szaboAuthor Commented:
Tell me about it...
tom_szaboAuthor Commented:
Did a connectivity test https://testconnectivity.microsoft.com

For that mailbox I am getting failed with this one error:

Attempting to test the GetItemEstimate command for the Inbox folder.
       The Microsoft Connectivity Analyzer received an error in response to the GetItemEstimate command.
       
      Additional Details
       
An HTTP 500 response was returned from Unknown.
HTTP Response Headers:
MS-Server-ActiveSync: 14.0
Content-Length: 75
Cache-Control: private
Content-Type: text/html
Date: Thu, 10 Jan 2019 04:54:37 GMT
Server: Microsoft-IIS/7.5
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET
Elapsed Time: 1436 ms.


For the other mailboxes, the test is successful:

(Log from same part that fails on other account)

     Additional Details
      Attempting to test the GetItemEstimate command for the Inbox folder.
       The Microsoft Connectivity Analyzer successfully received the GetItemEstimate response from the server.
       
      Additional Details
      Attempting to test synchronization of the Inbox folder.
       The Sync command completed successfully.
       
      Additional Details
       
Number of items synchronized: 100
HTTP Response Headers:
MS-Server-ActiveSync: 14.0
Content-Length: 44248
Cache-Control: private
Content-Type: application/vnd.ms-sync.wbxml
Date: Thu, 10 Jan 2019 04:53:39 GMT
Server: Microsoft-IIS/7.5
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Clients

From novice to tech pro — start learning today.