No network traffic passing for specific network range on switch

Hi guys

I have an HP network 1820-48G J9981A switch. We have a 192.168.10.0/24 network range on this switch. It has been set with a 192.168.10.10 IP. Prior to this, our network switch was completely vanilla and had no IP configurations.

Now, majority of appliances plugged into this network are on the 192.168.10.0/24 range. However, we have 7-8 devices set to 192.168.9.0/24 range. So now, we are completely unable to get to anything on the 192.168.9.0/24 IP's, as the switch is currently only seeing the 192.168.10.0/24.

My question is, what's the best way now to configure this switch? I don't want to reset it to factory default as we won't have any management. So do I set up VLAN's on all ports? How would you do it?

Or, can I set routing on the switch to say anything on 192.168.9.0/24 network needs to be forwarded on to the 192.168.10.0 gateway?


Thanks for helping
Yash
LVL 1
YashyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Paul MacDonaldDirector, Information SystemsCommented:
A network switch <> router.

A switch routes traffic between two or more ports.  A router routes traffic between two or more networks.

192.168.9.x and 192.168.10.x are two different networks.  You'll need a router to route traffic between the two.
YashyAuthor Commented:
The switch is already connected to a router which has a gateway of 192.168.10.1 and 192.168.9.1. But, old switch was vanilla, so traffic from both networks passed through.

Now that switch has a 192.168.10.0 management IP, it won't route any of the 192.168.9.0 traffic to the necessary gateway.

Should I reset the switch to factory default remotely?

Thank you
Yash
Paul MacDonaldDirector, Information SystemsCommented:
Most switches operate on MAC addresses, not IP addresses.  I don't see how setting a management address in the switch would stop it from switching.  Are you sure that's the only thing that's changed?

I expect there's something else going on here, and it may be manufacturer/model specific.  I'll shut up now and let someone else give it a go.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

SouljaSr.Net.EngCommented:
You have two options.

1. If the switch is a layer 3 switch. You can create a vlan interface for 9.x network also. Configure the devices connected to the switch to use the current management Ip on the switch as that vlan's default gateway and devices on the 9.x network to the new vlan interface. Then just put a default route on the switch pointing to  the router as next hop.

2. If the switch isn't a l3 switch. You will just need to tag both vlans on the link connected to the router. The router will have sub-interface tagging for the respective vlan. In this case let's call them vlan 9 and 10.
SouljaSr.Net.EngCommented:
3rd option. If the router has an interface configured in each subnet, just connect the associated ports on the switch to the router and assign those ports to the vlan that the router interface is in.
YashyAuthor Commented:
So it looks like a reboot on the switch got us to access some of the network devices on the 192.168.9.0 network. The rest look like they are suffering from application related issues.

Looks like it's been a false alarm. Thanks for your help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.