We help IT Professionals succeed at work.

Batch file in Scheduled Task completes only when user is logged onto server

307 Views
Last Modified: 2020-10-26
Hi there,

I have a scheduled task with these properties:

User account to run the task: A Service account that has logon as batch file privileges
Run whether user is logged on or not is enabled
Run with highest privileges is enabled
Configured for Windows Server 2012 R2
Trigger: Runs hourly
Actions values:
  • Action: Start a program
  • Program/script: Powershell.exe
  • Arguments: -command "Start-Process  C:\Build.bat -Verb runas"
  • Start in: C:\SDS_IT\

Now the problem I am having is that even though I have set the task to run whether user is logged on or not, it never completes unless the user is actually logged on.  If it I log out, the task starts and it gets to about 95% done and then it just gets stuck.  I've tested this theory several times and this is always the case.  I'm confused as to why it's not working.  The service account has local administrative permissions on this VM too.  I'm using PoweShell because I want the script to run a command prompt as administrator.

Any thoughts????
Thank you in advance!
-Christian
Comment
Watch Question

Gerwin JansenTopic Advisor
CERTIFIED EXPERT
Most Valuable Expert 2016
Commented:
This problem has been solved!
(Unlock this solution with a 7-day Free Trial)
UNLOCK SOLUTION
IT Consultancy
CERTIFIED EXPERT
Commented:
This problem has been solved!
(Unlock this solution with a 7-day Free Trial)
UNLOCK SOLUTION
Christian PalaciosSenior IT Systems Administrator

Author

Commented:
Hi there,

Thanks for the suggestion Steve, I didn't think about using an output file to see what's happening.  It's working for the sections that I need to troubleshoot.  Does anyone have experience with using Git?  If not, that's OK, I'll create a new question.
Gerwin JansenTopic Advisor
CERTIFIED EXPERT
Most Valuable Expert 2016

Commented:
>>  Does anyone have experience with using Git?
So it's a git command that is hanging / causing the issue?

Can you add a 'fake' command in the batch file:

git --version >> log.txt

Do you get an error? Then try adding setting the git environment variables in your script and add it to the PATH.
Qlemo"Batchelor", Developer and EE Topic Advisor
CERTIFIED EXPERT
Top Expert 2015

Commented:
Git commands might need a -f (force) or -y (answer "Yes") switch to remove prompting.