Windows 7 ignoring group policy folder redirection

edz_pgt
edz_pgt used Ask the Experts™
on
Windows 7 machines not listening to Folder Redirection group policy after a DC migration to Windows 2016.

At present, the old Windows 2012 Essentials server is still in place but a new Windows Server 2016 Standard server has been added. The domain has been migrated across along with the FSMO roles. After having issues with getting machines to pick up the new Group policy settings due to DNS issues, all does appear to be ok - at least, it is for Windows 10 clients. However, although Windows 7 clients can be coaxed into seeing the correct group policy, they are all ignoring the change in Folder Redirection location.

Things I've tried:
1. gpupdate /force
2. ipconfig /flushDNS
3  Several reboots

4. gpresult /v
This is interesting. After clearing the DNS cache, Windows 7 PCs do now pick up their group policy from the new server. However, they are still ignoring the folder redirection and the result of the above command shows:
FOLDER REDIRECTION
--------------------------------
N/A

5. I've tried removing the WMI filter from the redirection policy - no effect.
6. I've tried creating the new GPO and putting the redirection in there. GPRESULT lists the policy, so it's seeing the right stuff, but it still ignores the redirection.

Remember - Windows 10 PCs are working fine. This appears to be just Windows 7 machines.

Any ideas? I'm getting short of them!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
MaheshArchitect
Distinguished Expert 2018

Commented:
did you Sysvol and policies got replicated fully on 2016 DC?

run net share from cmd on 2016 DC to check if Sysvol and netlogon are shared and if it lists all GPOs present on earlier DC ?

Author

Commented:
As far as I can see, yes. Everything works for Windows 10 clients, anyway.

Author

Commented:
I'm putting in a workaround. I'm connecting to each Windows 7 PC and I'm editing the registry to change the Users Shell Folders to the new location. In doing so, I've just run into a Windows 7 PC that has actually updated. However, this was one that I was using as a test workstation during the migration yesterday. So, at some point, it seems that the policy did work for Windows 7 but perhaps doesn't anymore.

Further confusion!
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

SteveArchitect/Designer

Commented:
Check the event viewer. group policy errors are usually shown here and you need this info to know how to resolve the issue.
RobertSystem Admin

Commented:
I recommend using rsop.msc to see what policies are being applied and why others may not.
Also from the group policy management console you can run the group policy results to get a view of the policy.

Those tools along with the event viewer usually allow you to track down the cause of GPO problems.
Top Expert 2016

Commented:
It could be versioning that is causing problems.. See my article https://www.experts-exchange.com/articles/20759/Windows-Versions-and-Roaming-Profiles.html

Author

Commented:
Versioning seems like a crazy situation. How can that be acceptable?!

The bit I don't get is that it all worked fine on the old server 2012. Why would it not work in the same way on 2016?

I'll have to have another look through the logs as previously suggested. I have however managed to get this working by searching each Windows 7 registry for references to Explorer shell folders and replacing the server name in each case. There were only 5 Windows 7 PCs but it's been a very frustrating exercise and it's not really a solution - it's just a fudge.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial