DNS not on any network other than 10.46.72.x

I have two 3750 switches that are connected and working but here is my only issues. By the way I am very new to networking so please excuse me being naïve .

My issue is when I have a machine on a different subnet other than the main one 10.46.72.x DNS does not resolve even though I manually add and with a DHCP scope that I removed will not work. Can someone please tell me what  am doing wrong. Here is a copy of the config

[code][/

User Access Verification

Password:
Base-sw1>show running
Base-sw1>en
Base-sw1>enable
Password:
Base-sw1#sh ru
Base-sw1#sh running-config
Building configuration...

Current configuration : 3753 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Base-sw1
!
enable secret 5 $1$lwLf$CJoNDGBl4Ck6AAm/woBVM0
enable password secret cisco
!
no aaa new-model
switch 6 provision ws-c3750g-24ts
system mtu routing 1500
ip subnet-zero
ip routing
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet6/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/11
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/12
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/13
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/14
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/15
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/16
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/17
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/18
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/19
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/20
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/21
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/22
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet6/0/25
!
interface GigabitEthernet6/0/26
!
interface GigabitEthernet6/0/27
!
interface GigabitEthernet6/0/28
!
interface Vlan1
 ip address 10.46.72.1 255.255.255.128
!
interface Vlan10
 ip address 10.10.46.1 255.255.255.128
!
interface Vlan20
 ip address 10.20.46.1 255.255.255.128
!
interface Vlan30
 ip address 10.30.46.1 255.255.255.128
!
interface Vlan40
 ip address 10.40.46.1 255.255.255.128
!
interface Vlan50
 ip address 10.50.46.1 255.255.255.128
!
interface Vlan60
 ip address 192.168.60.1 255.255.255.0
!
ip classless
ip route 10.10.46.0 255.255.255.128 10.46.72.0
ip route 10.10.46.0 255.255.255.128 10.46.72.2
ip route 10.20.46.0 255.255.255.128 10.46.72.0
ip route 10.30.46.0 255.255.255.128 10.46.72.0
ip route 10.40.46.0 255.255.255.128 10.46.72.0
ip route 10.50.46.0 255.255.255.128 10.46.72.0
ip route 192.168.60.0 255.255.255.0 10.46.72.0
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
 password cisco
 login
line vty 5
 password cisco
 login
line vty 6 15
 login
!
end

Base-sw1#
Base-sw1#
Base-sw1#
Base-sw1#code]
techdriveAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

N. SpearsSr.Net.EngCommented:
At first glance:

- Vlan 1 is your default vlan. You have no other vlans created based on your posted config. That's why dns only works on that subnet.

- You created the VLAN SVI's but not the actual vlans. The static routes you created are not needed. It looks like you think you need them to route between each vlan on the switch. You don't. That is what the vlan interfaces are for.

vlan 10
vlan 20
vlan 30
vlan 40
vlan 50 
vlan 60

Remove static routes:

no ip route x.x.x. x.x.x.x

Add default route

ip route 0.0.0.0  0.0.0.0  y.y.y.y  

Open in new window


- The only switchports that need to be trunking are those connect to other switches or connected to hypervisor hosts. If not, configure them as access ports in the vlan you want that port in.
int gi6/0/1
switchport access vlan 20 
switchport mode access
 (as example)

Open in new window

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
N. SpearsSr.Net.EngCommented:
The next hop for your default route needs to be on that same subnet and vlan the router is connected to on that switch.

For the ports connected between the two switches. Make sure you leave it as trunk ports.

Make sure the same vlans are created on both switches.

ONLY ONE OF THE SWITCHES NEED ALL THOSE VLAN INTERFACES. THE ONE THAT WILL BE ROUTING FOR THE VLANS. The other switch just needs a management vlan interface.

Better yet. You could stack the two 3750's with stack cables and make one manageable switch.
Sajid Shaik MSystem AdminCommented:
check the IP DNS SERVER  command ps

config)#ip name-server ?
  A.B.C.D     Domain server IP address (maximum of 6)
  X:X:X:X::X  Domain server IPv6 address (maximum of 6)
  vrf         Specify VRF

all the best
N. SpearsSr.Net.EngCommented:
@Sajid

That command enables the switch as a dns server. He mentions dns works on the vlan 1 subnet, so we have to assume the dns server is external to these switches.
techdriveAuthor Commented:
Thank you all for your input.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.