Cannot browse my PC

Hi Experts,

Suddenly I am having trouble browsing my pc, when i click on my My Computer icon (Win7) It takes forever and nothing shows up, see attached.
Untitled.png
LVL 6
bfuchsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sam Simon NasserIT Support ProfessionalCommented:
open cmd as administrator, run the following commands
sfc /scannow
chkdsk c: /f /r

Open in new window

then try doing a full antivirus scan, then download malwarebytes and do full scan
bfuchsAuthor Commented:
open cmd as administrator
when I right click to select run as admin it also does not respond.
however I dont see anything running under task manager, neither are memory or cpu usage high...
Thanks,
Ben
CompProbSolvCommented:
Have you rebooted?  Tried Safe Mode?
Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

Sam Simon NasserIT Support ProfessionalCommented:
@bfuchs
if normal mode is not working, try doing them from safe mode, or use windows media to have access to repair mode
Restart your computer.
Press F8 before the Windows 7 logo appears.
At the Advanced Boot Options menu, select the Repair your computer option.
Press Enter.
System Recovery Options should now be available.
select command prompt and type the command above
windows-7-startup-repair-7-5807115d3.jpg
nobusCommented:
in such a case, it often is a dying diskjust to be sure, what pc model is this, and disk model?
usually, i start by testing ram and disk
bfuchsAuthor Commented:
Cannot restart at the moment.
When I try to run CMD nothing happens...
what pc model is this, and disk model?
See attached.
Thanks,
Ben
Untitled.png
CompProbSolvCommented:
How have you tried to restart?  What is preventing you from doing so?
Iamthecreator OMIT Admin/EE Solution GuideCommented:
As other have suggested, restart the PC. I had this issue just 2 days back on a Windows 10 Pro where I was able to browse everything except My PC. A restart magically fixed the issue.
SuhaibIT specialistCommented:
to force the laptop to power off keep pressing power button for 5-10 seconds it will power off.
then power it on and press F8 several times to get boot options (safemode, repair ...)
nobusCommented:
you did not post the disk model; if i assume a HDD 500 Gb, best test it with the proper manufacturer tool; you find them on the UBCD
bfuchsAuthor Commented:
Hi Experts,
I was was afraid it would not be a successful restart, that would leave me in deeper trouble...
Today I restarted and everything seems to be fine.
Anything specific you recommend to check now?
Thanks,
Ben
CompProbSolvCommented:
"everything seems to be fine"
The browsing problem is resolved?
bfuchsAuthor Commented:
Actually immediately after restart it was, but now this problem is happening again...
Thanks,
Ben
CompProbSolvCommented:
Did you try Safe Mode with Networking?

The suggestions above to run virus/malware scans is also very reasonable.
bfuchsAuthor Commented:
Hi Experts,
As things turned more serious, I handled this over to a Tech guy.
Will keep you posted.
Thanks,
Ben
Sam Simon NasserIT Support ProfessionalCommented:
did you run the sfc /scannow and chkdsk c: /r /f ???
bfuchsAuthor Commented:
Hi Experts,

Just updating...

My IT guy did the following

ran sfc /scannow came back clean.

set hdd to run check dsk on reboot...

Installed MBAM, and ran a Symantec scan,

after these I was able to browse my pc.

Meanwhile I finally was able to detect what is causing the problem...

I'm connected remotely to my work pc thru GoToMyPc.
when using utility to transfer files from host to client, its getting stuck in the middle.
and immediately after is when the fun starts...

I recall this is exactly what have caused the first occurrence of this problem.

btw, when the problem happens if I type cmd at the start window, nothing happens.

Another interesting factor, while I cannot browse my pc in general, however if I start type in something for example C:\temp then I get to see that folders contents.

Thanks,
Ben
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
System Utilities

From novice to tech pro — start learning today.