SBS2011 Console errors

For the past few weeks, my SBS2011 is syncing very slowly with iphones and I run the Fix my network to check for any errors and the below comes up for exchange. Also when I try to add a new user, I get an error when creating the email address which I believe is also connected to the above.
sbs2011.jpg
Christos KassianidesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hypercat (Deb)Commented:
Did you try finishing the Fix My Network wizard by clicking "Next" to fix the issues?  If you don't want it to change the other things, you can uncheck them first and just leave the last item checked.
Christos KassianidesAuthor Commented:
Yes. Unfortunately it seems that whatever has a ! is something that cannot be fixed automatically but needs user intervention but I don't know where to look.
Hypercat (Deb)Commented:
Are you trying to run the EMS on the SBS2011 server or are you running it from a workstation? If so, try running it directly on the server. Also, did you fix/change any of the other errors that show on the Fix My Network list? Particularly, the Internet port mapping issue might have something to do with slowness syncing phones and other mobile devices or using OWA, and the DNS forwarder issue might also impact internet connections and slowness.
Maximize Customer Retention with Superior Service

The IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more to help build customer satisfaction and retention.

Christos KassianidesAuthor Commented:
i can run EMS and EMC on their own but when i try using the SBS console, I get errors. With regards to the internet port, it doesn't tell me which port I need to forward. I have the following forwarded: 443, 6001-6004, 25, 143, 110, 1723, 995, 993, 587, 987. For forwarders i have my ISP DNS and googles own setup.
Hypercat (Deb)Commented:
OK, I get it now. If you have the skills, you can simply add users the traditional way using the AD Users and Computers console and the EMC.  Failing that (or if you don't want to do it that way), you can try repairing the SBS console.  The catch with that is that you have to have the original SBS 2011 Disk 2, which is the repair disk.  Here are the instructions from a Microsoft TechNet article:

To repair the Windows SBS Console:
1.  Click Start, click Control Panel, and then click Programs and Features.
2.  Click Windows Small Business Server 2011 Standard, and then click Change.
3.  Click Repair console.
4.  If you are prompted to close one or more applications, verify that Automatically close applications and attempt to restart them after a setup is complete is selected, and then click OK.
6.  Insert Windows Small Business Server Disc 2 (Component Technologies for Server Repair) into the server, and then click OK. The repair begins.
7.  When the repair is complete, restart the server.

These instructions were originally written for SBS2008 but it should work pretty much the same for 2011.
Christos KassianidesAuthor Commented:
I can try it but if I do not have the disc, can I download it from somewhere?
Hypercat (Deb)Commented:
I've tried but haven't successfully found a site where you can download that disk. And unfortunately I don't have a copy of it either.  The only other potential solution would be to try running the SBS console in safe mode. You can do this by opening an administrator command prompt, switch to the install location of SBS - traditionally C:\Program Files\Windows Small Business Server\Bin, and then run console.exe /safe.  That should get the console open and may allow you to get past any errors during the process of adding a new user.

Again the only other method I know, which in the long run might serve you well, would be to take an hour or two to learn how to add users through AD User and Computers and configure a new mailbox for an existing user through the Exchange 2010 management console.
Christos KassianidesAuthor Commented:
I know how to do that but I wanted to resolve the errors of fix my network as well. if I remember correctly this first started when I tried to run wsuscleanup script and I changed something in powershell restrictions. Once I did that EMC wouldn't load at all and when I changed it to unsigned it loaded up just fine.

Something to do with permissions most probably :)
Cris HannaSr IT Support EngineerCommented:
You should be seeing errors in the Event Logs related to the WinRM
Do you get the SBS automated report every morning?
Christos KassianidesAuthor Commented:
i do not have it configured to send the report. The normal logs look fine. I get an ASP error but that has to do with WSUS, which is not working.

Is there a place in the event logs that I should be looking specifically?
Christos KassianidesAuthor Commented:
ok found the event log. I get hte following

Event ID 142 - WSMan operation CreateShell failed, error code 5
Event ID 163 - The authentication mechanism (Negotiate) requested by the client is not supported by the server.
Possible authentication mechanisms reported by server:
Cris HannaSr IT Support EngineerCommented:
Check the server and see if the following item has been installed
Windows Management Framework 3.0

This is referenced in the TechNet forums
https://social.technet.microsoft.com/Forums/en-US/11a9e847-b8c9-4efc-8f0d-0a1bd1e3f324/sbs-2011-event-id-32784-and-id-163-after-upgrading-powershell-to-v30?forum=smallbusinessserver
Christos KassianidesAuthor Commented:
I have installed only WMF 4.0 (KB2819745) which was installed on the 14/11/2018. This could be after the last time that I added a user in the system. I will need to confirm.

Is it safe to remove?
Cris HannaSr IT Support EngineerCommented:
I would insure you have a good backup and then uninstall and reboot
Christos KassianidesAuthor Commented:
uninstalled and error has been eliminated. Not I'm getting the Internet Port (which doesn't say which port it is and I believe I have all ports open, you can see a previous post that I mention the ports), DHCP for IPv6 (which I do not use), DNS Forwarders (which I use the ISP forwarders) and a new one for Exchange SMTP Connectors (which fails to repair but exchange is working fine)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.