Cached exchange mode causing password prompts

Infinity Solutions
Infinity Solutions used Ask the Experts™
on
We have been trying to deal with this password prompt for quite a while now and for a period of time we were pointing the blame to a few add-ins. However, during today's troubleshooting I ran a little connection status test to see what it was trying to connect to during the time of the prompt. Well I found a little connection that stood out where it was trying to connect in cache mode. I decided to turn cached exchange mode off and ever since then I have not gotten a password prompt. After restarting outlook about 50 or so times I decided it was enough and tried to re-enable the cached exchange mode, and as I expected, the password prompts started coming back.

So what could be causing cached exchange mode in outlook H&B 2016 to to prompt for these windows credentials? I saw one spiceworks article where a guy was basically saying that cached mode might be connecting the public FQDN instead of the private network name and it prompts because it sees the server as being outside of the logged in domain? Just looking for a possible resolution so that we can still keep exchange mode enabled for the benefits it provides.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Danilo AndradeIT Systems Analyst

Commented:
Have you tried the resolution described on this article from Microsoft?
https://support.microsoft.com/en-us/help/2984912/outlook-continually-prompts-for-your-password-when-you-try-to-connect

You can give Office 365 troubleshooting assistant a try and see what more detailed information you get. If needed, post the results here:
https://diagnostics.outlook.com/#/
SteveArchitect/Designer

Commented:
the only realistic differences between cached and online mode is the downloading of things like offline address books. That is the starting point I'd recommend checking settings around that to see if youve got the OAB URLs set incorrectly. let us know what exchange/o365 version youre using and we may be able to point you in the right direction.
Infinity SolutionsData, Voice, Internet Services

Author

Commented:
We are using office home and business 2016 and exchange 2013
SteveArchitect/Designer

Commented:
Here's a guide based on the interface/GUI. the same can be done in powershell if you prefer it.

http://www.mustbegeek.com/configure-external-and-internal-url-in-exchange-2013/

Check the settings for OAB (offline Address Book) initially, but no harm checking all of them to be sure.

Make sure the URLs (both internal & external) set are valid, resolve to the right IP and are included in the SSL cert used on the server(s).

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial