dc not syncing with ntp server.

hi guys,
Got a esxi 6.7 server
got virtual machine which is dc -server 2016std

time always runs 5 mins slow.
i checked the w32tm /query /status - it was synching from local cmos battery

i tried changing it to external ntp time sources, but still dc takes time from local cmos battery.  it never changed to external ntp server.
in esx server, under virtual machine - synchronise guest time with host is not enabled too.

used these commands:
w32tm /config /manualpeerlist:"0.aus.pool.ntp.org,0x1 1.aus.pool.ntp.org,0x1 2.aus.pool.ntp.org,0x1 3.aus.pool.ntp.org,0x1"   - to set ntp server


used this to reset time service to defualt :
net stop w32
w32tm /unregister
w32tm /register
net start w32time

tried restarting time server - net stop w32time && net start w32time

the client machines take time from DC .. but dc not taking time from external ntp.
what else could be the problem. how do i make it to take time from external source ? ? any help would be great.
Mr.XAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KimputerIT ManagerCommented:
This is the correct command:
w32tm /config /syncfromflags:manual /manualpeerlist:"0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org 3.pool.ntp.org"
Jackie ManCommented:
Have you tried to sync the esxi host with ntp server?
systechSenior Technical LeadCommented:
Hi,

Also, try this

w32tm /config /manualpeerlist:"time.windows.com,0x1" /syncfromflags:manual /reliable:yes /update

w32tm /config /update
net stop w32time
net start w32time
w32tm /resync /nowait
net stop w32time
w32tm /unregister
w32tm /register
net start w32time
w32tm /resync /rediscover
Price Your IT Services for Profit

Managed service contracts are great - when they're making you money. Yes, you’re getting paid monthly, but is it actually profitable? Learn to calculate your hourly overhead burden so you can master your IT services pricing strategy.

Pete LongTechnical ConsultantCommented:
I had this a couple of weeks ago in vSphere 6.7 with one 2016 DC :)

Firstly make sure its setup correctly

Windows – Setting Domain Time

One was stubbornly set to CMOS Clock!

That DC was taking time from its CMOS clock (that’s not good!) that’s now been fixed (see the bottom output to confirm)
 
Net time /DOMAIN:{domain-name}

fixed it

The check from another machine with

w32tm /monitor

Then sit back, light your pipe, and admire you handiwork!

P
Mr.XAuthor Commented:
Hi,

radhakrishnan - i tried all ur commands. the last command alone did not work. have attached a file, please have a look.cmos.JPG
kimputer - tried your command, was successful but no change, still it syncs to local time. and i added au infront of ntp servers ,to make it pick australian time. 0.au.pool.ntp.org - but stil no luck
Mr.XAuthor Commented:
Hi pete long,

i used the ntp tool in server and it works. it shows the right time.
but when i do w32tm /resync.  this command not working.
ntp toolresync
please have a look at attached images
Mr.XAuthor Commented:
hi all,
thanks for all the sugggestions.

at last found what was the problem. there was a gpo enabled- configure windows ntp settings .
after changing it to not configure.  w32time resync worked and time started running correctly.
Mr.XAuthor Commented:
hi all,
thanks for all the sugggestions.

at last found what was the problem. there was a gpo enabled- configure windows ntp settings .
after changing it to not configure.  w32time resync worked and time started running correctly.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Pete LongTechnical ConsultantCommented:
I did mention GPOs in the link above :)

Glad you are fixed.

Pete
Mr.XAuthor Commented:
Hi Pete,
I got one more question. It's working now
But if I restart server or restart w32tm service, server details to local cmos battery.
I need to run w32tm /resync to make it work again.
It works good until I restart.
Anyway to make it work even after restarting. ?
KimputerIT ManagerCommented:
schedule a task (obviously with the command w32tm /resync) with the parameter "When the computer starts"
Pete LongTechnical ConsultantCommented:
If it's the PDC emulator its registry keys should be set to get external time, if its not it should get time from the PDC?
If it keeps reverting to CMOS them annually set tit to the domain and make sure VMware tools isn't messing with the time sync.

P
Mr.XAuthor Commented:
Yes it is pdc emulator
I checked registry - ntp server is ntp and shows peers in time server registry
And I verified it's not synching with wax host. It's un ticked

Probably will try task scheduler and Wil let you know
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.