Cannot share folders in a homegroup (Windows 7)

There are 2 computers in my network.  PC1 runs Windows 7 pro and the PC2 runs Windows Home Premium .  I am having problems with the homegroup.  The homegroup was created on PC1.  This is the first and only homegroup in the network.  The homegroup was created today.
I created a library on PC1 and put the directory “Sharing Folder” into the library.

Nothing has changed on this network for years.  No new software has been added, no new drives, no new shares, etc.

 On PC2, I start Windows explorer, under homegroup , I see PC1 .  It shows PC1//PC1

From PC2, when I click on PC1//PC1, I see 2 libraries and I see the folder Sharing Folder.  When I double click on Sharing folder on PC2 , what happens is I get a screen stating :

\\PC1 Sharing folder is not accessible.  You might not have permissions to use this network resource (etc).

So I go to PC1.  I start Windows Explorer.  I right click on the library Sharing Folder (not the directory inside Sharing Folder).  I left click on Share with.  There is a lock icon to the left of Nobody.
I left click on Homegroup (read/write).  Then I go back to library Sharing Folder.  

I right click on the library Sharing Folder.  Again I left click on Share with.  What I see is the lock icon to the left of Nobody.  

I assume PC1 is not letting me share the library Sharing folder.  How do I troubleshoot this?
donpickAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AlexProject Systems EngineerCommented:
You'll need to drop the user account from PC2 into the security for the share on PC1
JohnBusiness Consultant (Owner)Commented:
Homegroup only shares the public folders (between the 2 computers), not other folders.  It is not a generalized file sharing routine. If you wish generalized sharing, remove the Homegroup and use traditional sharing. See my article on this.

https://www.experts-exchange.com/articles/16639/Folder-sharing-on-modern-machines.html

Also, new editions of Windows 10 have removed Homegroup, so it is basically a deprecated concept that will die with your Windows 7 machines.
donpickAuthor Commented:
John:  Thank you for the link to the article.  Very interesting.
 
Before 16 January 2019, I was successfully sharing files between PC1 and PC2 using a Work network.  On PC1 I had created a PC2 account.  This PC2 account had the same password as the account on PC2.  I was able to share a folder on PC1 and, using advanced sharing, add the PC2 account and assign full privileges .  This worked well for years.

Suddenly, on 16 January, this method stopped working.  I had not changed anything on these computers for years.  No new anti virus, no new anything.  The only thing that changed was updates to the Windows operating system from Microsoft.  

So, today, following your article, I changed PC1 back to Work network.  I followed all your instructions to set file sharing, etc.  I made sure the homegroup was turned off.

From PC2 I can ping PC1.

Still, I cannot connect from PC2 to the share on PC1.  The error message is “Windows cannot access \\192.168.1.130 “  (which is the ip of PC1)

I turned off the firewall on PC1.  Still cannot connect.

On PC2, I logged in using the PC1 account.  Then I opened Windows explorer and typed \\192.168.1.130. Still cannot connect.  

My questions:  
1.) What update from Microsoft may have interfered with the sharing ?

2.) What do I do now?  What test can I perform to see what is blocking PC2 from accessing the share on PC1?  I am really frustrated.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

JohnBusiness Consultant (Owner)Commented:
Thank you for the update.

Try the following:  Make sure both computers are in WORKGROUP.  Restart if you change this setting.  Then ensure that both computers continue to have the very same user name and password as each other.

 I was able to share a folder on PC1  <-- Make sure this folder is NOT in the Users folder.  Security has changed so you need to folder is a more neutral location (say C:\Interchange_Folder ) . Then try sharing of that folder.

On PC2, open cmd.exe and type NET USE X: \\name_of_PC1\Interchange_Folder.  If you get an error, what is the numerical error?
donpickAuthor Commented:
I will work on this next week.
oBdACommented:
That is an issue with the January 2019 Cumulative Update 4480970.
January 8, 2019—KB4480970 (Monthly Rollup)
https://support.microsoft.com/en-us/help/4480970/windows-7-update-kb4480970
Known issues: Local users who are part of the local “Administrators“ group may not be able to remotely access shares on Windows Server 2008 R2 and Windows 7 machines after installing the January 8th, 2019 security updates. This does not affect domain accounts in the local "Administrators" group.
This is resolved in 4487345; download it manually from the Update Catalog (it is not offered through Windows Update!) and install it on the machine that shares the folder:
Description of the update for Windows 7 SP1 and Windows Server 2008 R2: January 11, 2019
https://support.microsoft.com/en-us/help/4487345/update-for-windows-7-sp1-and-windows-server-2008-r2
Direct link to the Update Catalog: http://www.catalog.update.microsoft.com/Search.aspx?q=KB4487345

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JohnBusiness Consultant (Owner)Commented:
Fixes were applied to networking (but not Homegroup) by the end of this past January as noted above. The fixes were not complete when I last posted earlier.
donpickAuthor Commented:
Thank you, oBda:  I will try this as soon as possible.
donpickAuthor Commented:
Thank you, oBdA and John for your help.  I am still working on this problem.  There seems to be more things involved.  I will ask more questions later.
JohnBusiness Consultant (Owner)Commented:
Thanks for the update
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.