Windows 2016 RDP issue.

Hello,

I am getting the attached error when trying to RDP to a Windows 2016 server.  The server has no windows firewall and no third party antivirus software enabled.

telnet test to the server via tcp 3389 is fine and RDP service is running on the server.

Please advise if you see anything we should check.

I was doing a software update on the server before the issue happens.  The server is running in vmware and I have reverted back the snapshot.  

Many thanks.
RDP-error.png
nav2567Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MaheshArchitectCommented:
Either server is shutting down or core update is running or you have enabled network level authentication (NLA) on server under rdp properties

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nav2567Author Commented:
I unchecked NLA but I still get the same error.  

The server is up.  When I go to Windows Updates, I am seeing the attached screen for a long time.  I have restarted the server couple of time but it does not help.
windows-updates..png
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Firstly, turning off the Windows Firewall places it in a form of limp mode. It does not turn off like a light bulb does with a switch. Instead of turning it off, turn logging on for all three profiles and make sure it's on for same. Then, check the logs to verify if it is dropping the expected packets.

Secondly, make sure inbound RDP is enabled for Remote Access via Computer --> Properties.

NOTE: There are variations between Windows versions as far as exceptions for the Remote Desktop Protocol goes. If using Group Policy to set the exceptions keep in mind that some settings like TCP 3389 Inbound for certain versions of Windows may be needed to get things going in a heterogeneous Windows environment.
DanOwnerCommented:
I thought you rdp goes to a disabled state with the firewall off.  Can you try turning it on?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2016

From novice to tech pro — start learning today.