UnicodeDecodeError: 'ascii' codec can't decode byte 0x8b in position 513: ordinal not in range(128) error when upgrading Dell ESXi v6.5

gopher_49
gopher_49 used Ask the Experts™
on
I'm getting the error "UnicodeDecodeError: 'ascii' codec can't decode byte 0x8b in position 513: ordinal not in range(128)" when trying to upgrade a Dell ESXi v6.5 to version VMware-VMvisor-Installer-6.5.0.update02-8294253.x86_64-DellEMC_Customized-A00.iso .  What am I doing wrong?  I tried the VUM and had the same issue.  I tried rebuilding the bootbank and altbootbank also...
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Murali SripadaVMware Engineer | vExpert 18/19
Distinguished Expert 2018

Commented:
Can you share screenshot where you are seeing this message?
This is a generic message related to python decode. I wanted to know the stacktrace below that error if it is unable to read the bootbank etc
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
That's interesting I was getting that earlier, but nothing to do with VMware! (I was executing code on a Deep Learning DGX-1 and training a neural network!)

A Unicode error, with byte string conversion to unicode.

Is this BOOTING from CDROM and upgrading ?

I would check you do not have any illegal characters in the output of the configuration file - esx.conf using vi or you could switch and use esxcfg-info.

the character it's complaining about is a - Single Left-Pointing Angle Quotation Mark

This is an illegal character in something in your configuration, which is causing the upgrade script to crash. (it's not expected!).

So re-check configuration.

Author

Commented:
I noticed this error is posted from Python... Which makes me thing it was related to the scripts bundled with the Dell ISO.  When on hold with Dell PowerEdge FX2 support I realized I download the general Dell ISO.  I entered in my service tag and noticed the ISO on the FX2 download page was a different file name and version..  I downloaded the .zip version, uploaded to a datastore, and ran 'esxcli software vib update -d "/vmfs/volumes/general/ISOs/VMware-VMvisor-Installer-6.5.0.update02-10719125.x86_64-DellEMC_Customized-A07.zip"' .  

The update ran and I rebooted.. It all works now.  I was able to update all 3 x hosts in no time at all..  The .zip ESXi update method with Dell images is the way to go for sure.. ISO images are silly and require reboots.. And silly virtual media tasks..  The .zip ESXi update method is 5 x times quicker..
See my recent comment.. That was the fix.. I wasn't downloaded the ESXi ISO via service tag search on the Dell support site.  I was using the general ISO image.. I have a FX2 and the drivers/ISO are very specific.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial