Link to home
Start Free TrialLog in
Avatar of David Stevens
David StevensFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Active Directory Not Replicating after Promotion with an initial failed Promotion attempt.

I have 2 sites connected with a site to site VPN. HQ is using SonicWall TZ400 and Branch has a Soniwall TZ 300. The HQ has 2x Windows 2019 DC's and the branch office had its own domain. This branch domain was taken down yesterday as it was only there after a company take over. I Joined and re purposed a window 2016 server as a Domain controller at the branch site joined to the HQ domain and it went through the install wizards fine then it rebooted and it just hung for about 2hrs. Eventually i did a manual reboot but things were not right so i demoted the server and ran the process again. Normally i would change the server name but didn't. This time it appeared to be floor less and the DNS and everything was all replicated.

When i moved a user though i realized it was not be replicated at HQ and various other things like password resets and user creations. So i went to the DNS on the branch office and it had 3 DC's / NS and everything appeared to be fine.
I looked at both DC's at HQ and none of them had the NEW DC listed as a NS but just an A record entry. When i went to Sites and Services the Replicate Now failed (the naming context is in the process of being removed or is not replicated from the specified server.

I went back to the Branch office server which seem to have 3 NS entries in DNS and initially looked fine and i ran dcdiag/tes:dns at the branch office and there were a lot of missing record failures
         Summary of DNS test results:

                                            Auth Basc Forw Del  Dyn  RReg Ext
            _________________________________________________________________
            Domain: consonto.local
               BMFLON1                      PASS FAIL PASS PASS PASS FAIL n/a

         ......................... consonto.local failed test DNS

Is this a give time moment, reinstall DNS .....I have created new users and need to have it replicating. Its odd that on AD install it appeared to pull across a clean copy of DNS.
ASKER CERTIFIED SOLUTION
Avatar of Mahesh
Mahesh
Flag of India image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of David Stevens

ASKER

Hi Thanks Mahesh for the response.

Just to add i created a new user on the HQ server and one on the NEW branch server. Interestingly the HQ got replicated down but the NEW branch office didn't get replicated the other way.
Thank you for pointing me in the right direction. I ran dcdiag and saw the errors and then after manually recreating the NS records and cname records i ran dcdiag and the main errors had virtually gone and replication worked, I then rebooted the server and everything was fine. a big thank you.