Script Component in SSIS giving error after writing code for JSON file parsing

I am new to SSIS
I am using a Script component in SSIS for parsing a JSON file.
I am getting errors after I add the C# code in the Script component for parsing of the JSON file.

I am attaching a file which describes the issue that I am facing.
Is this a bug in the Software of Visual Studio 2015 professional? Do I need to re-install Visual Studio 2015 professional?
issues-with-json-scripting.docx
vsuripeddiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kelvin McDanielSr. DeveloperCommented:
You didn’t specify which version of Windows or SQL Server tools (for Visual Studio) you are using. Regardless, this is all that I could immediately find regarding the issue:

From support.microsoft.com: Error when you execute SSIS package on FIPS-enabled Windows

That KB article identifies the root of the problem:
This issue occurs because SSIS uses the MD5 algorithm. The MD5 algorithm is not FIPS compliant.

Open in new window


It also provides workarounds that may or may not work for your situation. The one that you’ll probably end up using is where they suggest editing a registry key to disable FIPS enforcement. However, that won’t work if you need to run this package on a machine that NEEDS to have FIPS enabled. You might need to come up with an alternative strategy for getting the data in that file ready for SSIS to use.

Good Luck!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
vsuripeddiAuthor Commented:
@Kelvin McDaniel,

Thanks for the update....
I am using SQL Server 2017 developer edition

I am not sure if 2017 developer version has any service packs...

The link you had provided suggests that I change the value to 1 in the Registry Editor

I tried to go into the path
"Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\FipsAlgorithmPolicy" and change the value to 1
However, it did not allow me to change to 1
Also, I could not locate service packs for SQL Server 2017 Developer edition
vsuripeddiAuthor Commented:
@Kelvin McDaniel

I used SSDT tools for Visual Studio 2015 professional edition
Kelvin McDanielSr. DeveloperCommented:
That's what I figured. That particular setting is not typical for non-corporate/consultant environments and -- more than likely -- it's controlled by policy.

At this point, I think your lowest common denominator option is to create a dll that handles ingesting the file into a collection, which SSIS can then use in its flows. Hopefully, that one layer of abstraction will keep you from getting hit with that exception. If not, then you'll probably have to completely externalize that step.

To be clear:
1. Create a DLL  that SSIS can reference.
2. Use something like FileHelpers to turn the text into a useable collection.
3. Update your to call a method in this DLL, which will return the collection made in #2 above.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
C#

From novice to tech pro — start learning today.