Windows Server 2016  gets  "System error 58 has occurred" when I use the" net use"  connect to another server

rich brown
rich brown used Ask the Experts™
on
I upgraded from Windows Server 2012 R2 to Windows Server 2016. Now I get "System error 58 has occurred" when I use the" net use" command to connect to a SUSE server.  The SMB 1.0 is already enabled on the 2016 server, but it still fails to connect.  I need to be able to read\write\execute  to the same servers as I did with my Server 2012.
Is there any way to get my 2016 server to use SMB1.0  to connect? If not, is there a workaround I can use to perform the same task without updated my SUSE servers?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Iradat SiddiquiManager Operations
Commented:
SMB 1.0 is not available by default in Windows Server 2016 and you may go to Server Manager >Manage>Add Role and Features> Select "SMB 1.0 /CIFS File sharing Supporting" under features and install it.
System Engineer | .NET Developer | Microsoft MVP | Technical Speaker
Commented:
But you have this error on client that access to the share on Windows Server 2016 really?
On the client you have enable SMB1?
https://support.microsoft.com/en-us/help/4034314/smbv1-is-not-installed-by-default-in-windows

Author

Commented:
These devices are not likely running Windows. They are more likely running older versions of Linux, Samba, or other types of third-party software to provide SMB services. Often, these versions of Linux and Samba are, themselves, no longer supported.

The server I'm trying to connect to are more likely running older versions of Linux, Samba, or other types of third-party software to provide SMB services. Often, these versions of Linux and Samba are, themselves, no longer supported.

Is there a workaround that does not include getting the server I am trying to connect to make an update on their end? Is there something other than SMB  I can use that operates the same way as SMB?
Shaun VermaakTechnical Specialist
Awarded 2017
Distinguished Expert 2018
Commented:
The SMB 1.0 is already enabled on the 2016 server, but it still fails to connect.
Enabling it and recommending you enable it is really a bad idea. Fix it so that it does not rely on SMB1

Author

Commented:
Thanks all.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial