slow behavior when open IE with twebbrowse

Yair Abraham
Yair Abraham used Ask the Experts™
on
very slow behavior when open IE with twebbrowser (borland) - i have a page that open in a c++ program on the cloud - but the all  behavior is slow and evan the images and progress-bar  are stack and not moving- i have image that spin - but trow this way it not spin
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Sinisa VukSoftware architect
Top Expert 2012

Commented:
Hi!
Some questions first:
- do you have same 'slowness' with other pages - not related to yours (in cloud)?
- did you try other web browsers with your page (chrome, opera,...)
- Delphi version?
- did you take in consideration another web browser framework like embeddedwb?

From my knowledge - Delphi's Twebbrowser relay on lesser then IE 9 version - and think that is a problem here.
You should put it in higher emulation mode.
Another blog to consider....
This registry hack (described on those links) - is per application (.exe).
For my need I put some code in app where use twebbrowser and app put self into registry (under current user).
Do not recommend to turn feature compatibility emulation off.

Author

Commented:
Hi  

Thanks for replay

The slow behavior and others issues  is only  opening with the twebbrowser  if open in the cloud with regular IE all good

 others issues:
1. alert show on pop-up, like old way  -  not in the bottom of the window
2. Response.AddHeader "X-Download-Options", "noopen" - not affecting with  twebbrowser

Author

Commented:
Hi
1. I Want to  mention that we don't use  Delphi's Twebbrowser =- we use c++ borland
2. i put alert for IE version - it is IE 11

Thanks
Sinisa VukSoftware architect
Top Expert 2012

Commented:
I assume not IE11 even it say so. Engine, I think is new but in compatibility mode with IE8/9.
Try my suggestion... with modification on page (header/meta): '<meta http-equiv="X-UA-Compatible" content="IE=11" />'

for alerts - you can suppress it with: wb.Silent = true;
Geert GOracle dba
Top Expert 2009

Commented:
well you can get that behavior easily
i forgot which event to attach it to, but this code in the correct event slows a lot down:

sleep(10000);

Open in new window

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial